Subject: [P2Prg] P2P in mobile cellular environments

From: Andersen Frank-Uwe <[email-masked]>
Date: Tue, 21 Oct 2003 10:47:32 +0200

Hello all,

some time ago on this list, I have raised the issue of P2P aspects in mobile cellular environments, i.e. special constraints and requirements that need to be considered today and, more importantly, in the future.  

Since I could not attend the group meeting, may I ask you, Jeffrey, Bill, (or Mauricio or Chuck?) to put this on the research directions list that is currently evolving.

I am not talking about things like administrative (e.g. the current provider practice of IP data blocking between mobile devices) or economic issues (e.g. today's pricing for mobile data connections).

Instead, I am talking about principal issues for P2P data transmission in mobile cellular environments that will always be there: high delay/round trip times (2x involvement of air interfaces) and limited bandwidth (compared to fix networks), heterogeneous access networks (expected for beyond 3G mobile networks), multihoming, and, last but not least, the relation towards ad-hoc mobile networks.

I believe that there is indeed a considerable field for research, and it would be great if some of it could be added to the research track list.

Frank-Uwe Andersen

-- 

Frank-Uwe Andersen
Siemens AG 
Product Oriented Research - Networking
Berlin

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg

---

From: Bill Yeager <[email-masked]>
Date: Tue, 21 Oct 2003 09:51:44 -0700 (PDT)

| Instead, I am talking about principal issues for P2P data transmission in
| mobile cellular environments that will always be there: high delay/round
| trip times (2x involvement of air interfaces) and limited bandwidth
| (compared to fix networks), heterogeneous access networks (expected for
| beyond 3G mobile networks), multihoming, and, last but not least, the
| relation towards ad-hoc mobile networks.

Hi Frank-Uwe,

You are correct that these issues need to be researched. Are you interesting
in leading such a subgroup's discussion? 

I can contribute a little here since I've done lots of work in the past with
these networks too.

Bill

---

From: Kuldip Singh Pabla <[email-masked]>
Date: Tue, 21 Oct 2003 12:43:33 -0700

Hi Frank-Uwe,

I have initiated a similar project under JXTA.org. Its about 
Infrastructure-less (ad hoc) P2P using constrained devices such as smart 
phones, PDAs etc. Like Project JXTA, it is looking into multihome 
interfaces.

You may want to visit http://jxme.jxta.org for more details.

-Kuldip