Subject: Re: [P2Prg] SIP

From: "Ayyasamy, Senthilkumar \(UMKC-Student\)" <[email-masked]>
Date: Sun, 7 Dec 2003 04:11:40 -0600

JSR 180 defines a SIP API for J2ME. For now, 
it is used for mobile devices. But, as I 
read them, it really has features necessary 
for a complete P2P application development 
platform. Also, it can exploit SIP features
(application layer mobility, global 
identifier etc etc )

As for what SIP has to offer, read:
http://dsonline.computer.org/0311/f/w6p2p.htm

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg

---

From: "M. Ranganathan" <[email-masked]>
Date: Sun, 07 Dec 2003 10:58:40 -0500

Thanks! Actually I am the co-spec-lead for jsr 32 (JAIN-SIP) and plan to 
implement (JSR 180 - indeed I am in the process of doing so). I think 
SIP has a lot to offer as a lower layer protocol on top of which higher 
layer P2P abstractions can be built (maybe as SIP extensions ??)

Ranga

-- 
M. Ranganathan 

Advanced Networking Technologies Divsion,
National Institute of Standards and Technology (NIST),
100 Bureau Drive, Stop 8920, Gaithersburg, MD 20899. 

tel:301 975 3664 , fax:301 590 0932 , http://www.antd.nist.gov/~mranga

Advanced Networking Technologies For the People!

---

From: "Paul Francis" <[email-masked]>
Date: Sun, 7 Dec 2003 11:56:57 -0500

I would hope that no SIP extensions are necessary.  What did you have in
mind?

PF

---

From: "M. Ranganathan" <[email-masked]>
Date: Sun, 07 Dec 2003 14:17:22 -0500

Ah that is the question I should like to ponder! For example perhaps one 
needs an extension for resource discovery (?). I am not certain - one 
would need to work through some scenarios.
Ranga.

-- 
M. Ranganathan