Subject: RE: [P2Prg] SIP

From: "Ayyasamy, Senthilkumar \(UMKC-Student\)" <[email-masked]>
Date: Sun, 7 Dec 2003 22:24:11 -0600

>But SIP seems useful at the point where peer A decides it wants 
>to talk to peer B, and needs some way to address B, contact B 
>and tell it that it wants to talk, tell B what it wants to talk 
>about, and decide how to actually do the talking.  In short, it 
>aids in setting up a session between A and B.
 
i.e. a rendezvous mechanism. SIP should also be used for C to 
contact A and convey information about B i.e. referral.
 
----- Original Message ----- 
From: "Bill Yeager" <[email-masked]>

>> I think the Session Initiation Protocol belongs at the 
>> application level. 
 
So do P2P; a lot of new services can be introduced by 
assuming a P2P model at the application layer. Do you 
have any intention to touch network layer? I agree
that ad-hoc network require network level changes to
support P2P mode. else, it is waste of time.
 
>>It is not about
>> 1) Routing
 
In P2P terminology, "routing" is used to refer the 
associated look-up and query process (academic 
publications refer them as DOLR -Distributed Object 
Location Routing.) So, it is actually a combination 
of pt. 2 and pt. 4. If you support pt. 5, it is 
called semantic routing.  
 
>> 2) DHT content lookup
>> 3) Security is much more complicated than secure sessions
>> 5) Meta-Data
 
I don't think anyone suggested SIP for the listed tasks. 
But, it can make the work of pt.5 easy. The level of 
semanticness depends on the meta data expressed using 
URI. SIP considers URI as a global identifier. So, metadata 
related work can be done easily over SIP.

>> 4) Discovery - Which is really very dependent on the overlay 
>> network infrastructure
 
You should probably check Henning's 3DS work. It shows how 
resource discovery can be enabled using SIP without creating
an explicit overlay infrastructure. 
 
>> I personally am very much against overloading protocols like 
>> SIP. 
 
I don't think anyone is overloading SIP. We are just asking to 
exploit SIP features to its full extend (because it has seen 
wide deployment.) One of the tasks of IRTF RG is to do gap 
analysis between IETF activities and research. I agree, it is
interesting to work on revolutionary ideas (but, market would 
have picked home brew methods by the time it is standardized.) 
 
SIP is not a full blown P2P architecture. It just serves as a 
rendezvous protocol. A lot of work which is necessary for 
any P2P system has to be done. But, building over SIP takes 
an evolutionary - rather than revolutionary - approach.

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg

---

From: "Paul Francis" <[email-masked]>
Date: Mon, 8 Dec 2003 09:28:21 -0500

In my original posting, I don't think I understood the scope for which SIP
was being proposed.  I agree with Bill that SIP shouldn't be overloaded to
do things it was not designed to do.  As a litmus test, I'd say that if you
need to add extensions to it to do something you want, then you shouldn't be
using it.  On the other hand, SIP might be useful for more than just session
setup, given its namespace etc.  So perhaps an interesting exercise would be
for someone to sit down and carefully scope out where SIP would be useful
and where it wouldn't, then revisit this question.

PF

---

From: "M. Ranganathan" <[email-masked]>
Date: Mon, 08 Dec 2003 11:10:17 -0500

SIP extensions are usually pretty harmeless ( they dont change the 
protocol operation - they just add new messages types and headers and 
proxy servers can tell end points if they do support the extensions).  I 
dont see the a-priori hestitation needing to add extensions if we find 
that is necessary. There are many stacks around for SIP which are able 
to handle extensions (for example consider JAIN-SIP if you will excuse 
the shameless self promotion).  I dont see SIP extensions as a show 
stopper. Extensions are a part of the protocol itself so in some sense 
"Extension" is an oxymoron of sorts. SIP extensions for all sorts of 
things exist at this point.

Yes I totally agree that it would be an interesting and necessary 
exercise to arhitect something that would work on top of SIP and see 
what extensions if any are needed. I'd be glad to participate in 
defining things as I think I know pretty much what SIP does and is 
capable of doing.  However, I dont know what we have decided to call a 
P2P system. Is there any document to define the architectural 
requirements of a P2P system the way we are referring to it in this 
group?  I should like to get my hands on such a document or at least 
participate in defining one.

Best Regards

Ranga.

-- 
M. Ranganathan 

Advanced Networking Technologies Divsion,
National Institute of Standards and Technology (NIST),
100 Bureau Drive, Stop 8920, Gaithersburg, MD 20899. 

tel:301 975 3664 , fax:301 590 0932 , http://www.antd.nist.gov/~mranga

Advanced Networking Technologies For the People!