Subject: [P2PSIP] [SIPP2P] question about some tables definition in the draft RELOAD-Base

From: [email-masked]
Date: Thu, 18 Dec 2008 13:59:42 +0800

Dear sir,

I am studying the section 10 Chord algorithm in the draft RELOAD-Base. But
I am confused with some terminology, I don’t know if it is the
non-consistency problem or need to be further defined clearly.
The terminologies confused to me are various tables presented in different
subsections, like Routing table, finger table, connection table, neighbor
table, and neighborhood table. Anyone can define them more clear for me so
that I can read it easily.
Thanks in advance.

BR,
Jeffrey
本信件可能包含工研院機密資訊，非指定之收件者，請勿使用或揭露本信件內容，並請銷毀此信件。
This email may contain confidential information. Please do not use or disclose it in any way and delete it if you are not the intended recipient.
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: "Bruce Lowekamp" <[email-masked]>
Date: Thu, 18 Dec 2008 10:35:02 -0500

Jeffrey,

I think the terminology confusion comes from the use of generic terms
in the bulk of the draft, but more chord-derived terms in the chord
section.

The connection table and routing table are generic terms defined in
the terminology section and used in the majority of the draft.  Finger
table is a chord-specific term for routing table.  Neighborhood table
is also a chord-specific term (called leaf set in some other
algorithms).  I believe Finger Table and Neighborhood Table are used
only in the Chord section.

Hope that helps.  Please let me know if there are specific areas of
confusion where we can work to clear up the terminology.

Bruce

On Thu, Dec 18, 2008 at 12:59 AM,  <[email-masked]> wrote:
> Dear sir,
>
> I am studying the section 10 Chord algorithm in the draft RELOAD-Base. But I
> am confused with some terminology, I don't know if it is the non-consistency
> problem or need to be further defined clearly.
> This email may contain confidential information. Please do not use or
> disclose it in any way and delete it if you are not the intended recipient.
>