Subject: [P2PSIP] P2PSIP ID and physical location

From: Xianghan Zheng <[email-masked]>
Date: Tue, 02 Dec 2008 14:26:56 +0100

Hello,
Is someone considering the mapping between the P2PSIP ID and physical 
location. I think it is necessary to think about it although it is not 
trivial and might cause some security problem. 

In the draft 
"http://www.p2psip.org/drafts/draft-licanhuang-p2psip-subsetresourcelocation-00.txt", 
However, the peer ID is formed as domain name. Is that conflict with the 
concept that the ID should 128/160 bit integer?  Is it possible that 
each peer in one domain assigned  similar identity? Any suggestions? 
Thank you.

Best Regards,
Xianghan Zheng 

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: "Bruce Lowekamp" <[email-masked]>
Date: Tue, 2 Dec 2008 09:32:28 -0500

Assigning peer ids based on network topology would compromise both the
security and the reliability of the overlay.

The security properties depend on an attacker not being able to target
a particular peer id when they request a certificate.  If ids are
assigned based on network topology, then an attacker may be able to
figure out how to target a particular resource id to attack a specific
identity in the overlay.

Reliability is an issue because if ids are assigned based on topology
and an ISP goes offline, the overlay loses an entire range of peer
ids.  This means both that everything stored there will be lost
(especially since in chord replicase are stored on successors) and it
will most likely overload the peer with an id immediately after the
ISP that went offline because it will suddenly be responsible for a
huge range of resources.

There are an awful lot of topology-aware DHT algorithms out there that
rely on other techniques to improve performance (such as selecting
fingers based on topology, which works with the most basic chord
algorithm).  Pastry and Tapestry are two to start with.

Bruce

On Tue, Dec 2, 2008 at 8:26 AM, Xianghan Zheng <[email-masked]> wrote:
> concept that the ID should 128/160 bit integer?  Is it possible that each
> peer in one domain assigned  similar identity? Any suggestions? Thank you.
>
> Best Regards,
> Xianghan Zheng
>
>
>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 02 Dec 2008 06:39:08 -0800

Currently RELOAD Requires that the Node-Ids be cryptographically
random, which precludes this technique.

It's not clear to me why it's desirable for nodes which are
geographically close to be close in the overlay topology.y

-Ekr

At Tue, 02 Dec 2008 14:26:56 +0100,
Xianghan Zheng wrote:
> 
> [1  <text/plain; ISO-8859-1 (7bit)>]
> Hello,
> [2 xianghan_zheng.vcf <text/x-vcard; utf-8 (base64)>]
> begin:vcard
> fn:Xianghan Zheng
> n:Zheng;Xianghan
> org:;Information and Communication Technology
> adr:;;;Grimstad;;4879;Grimstad
> title:PHD Studnet
> tel;work:+47 3725 3441
> tel;cell:+47 91664693
> version:2.1
> end:vcard
> 
> [3  <text/plain; us-ascii (7bit)>]

---

From: songhaibin 64081 <[email-masked]>
Date: Tue, 02 Dec 2008 23:11:03 +0800

Hi Ekr,

> geographically close to be close in the overlay topology.y

P2P networks are teemed with dynamic nodes. When a peer leaves the overlay, it will transfer the stored resource records to a node which has a close node ID. From the perspective of an ISP's network, making P2PSIP node IDs with proximity property will reduce the network hops when data transfer happens. 

Besides that, I think overlay maintenance messages will also take less network hops if most neighbors have close node IDs. If node ID has proximity property, it will help for the peer selection when there are a list of peers providing the same resource.

I think we can find some papers describing the proximity for DHTs. I agree with Bruce that there are many considerations when assigning node id.

Best Regards,
Song Haibin

---

From: Bruce Davie <[email-masked]>
Date: Tue, 2 Dec 2008 10:37:51 -0500

Song,
it is certainly true that proximity is often used in DHTs, but not, as  
far as I know, for the assignment of node IDs. It is used, for  
example, to select among many possible candidate nodes for inclusion  
in the routing table. But, as others have already said, the randomness  
of note IDs is important for the security and robustness of a DHT. You  
can have efficient routing without giving up the randomness of note ID  
assignment. See, for example, Pastry. http://www.freepastry.org/pubs.htm

Bruce Davie
On Dec 2, 2008, at 10:11 AM, songhaibin 64081 wrote:

> P2P networks are teemed with dynamic nodes. When a peer leaves the  
> overlay, it will transfer the stored resource records to a node  
> which has a close node ID. From the perspective of an ISP's network,  
> making P2PSIP node IDs with proximity property will reduce the  
> network hops when data transfer happens.
>
> Besides that, I think overlay maintenance messages will also take  
> less network hops if most neighbors have close node IDs. If node ID  
> has proximity property, it will help for the peer selection when  
> there are a list of peers providing the same resource.
>
> I think we can find some papers describing the proximity for DHTs. I  
> agree with Bruce that there are many considerations when assigning  
> node id.
>
> Best Regards,
> Song Haibin
>
>
>>

---

From: songhaibin 64081 <[email-masked]>
Date: Wed, 03 Dec 2008 00:13:21 +0800

Bruce,

I agree with you that pastry has proximity property, and can achieve efficent routing. But for leafset, peer must choose leafset nodes that have closest IDs with it. It doesn't have a list of candidate peers to choose from as the routing table entries do. SO, by randomly assigned IDs, it will make the resource records mainternance between leafset nodes(when join or leave, or replicate happens often) not efficient because they waste the network hops.

If node IDs have network proximity property, it will make the routing message which gets closer and closer to the destination ID(e.g. Chord or Pastry), also gets closer and closer to the destination node in the network topology. It is a nature effect.

We could discuss with the ALTO guys and see what in their mind.

I think we should allow different options for node id assignment according to different scenarios. 

my two cents
Song Haibin

---

From: Bruce Davie <[email-masked]>
Date: Tue, 2 Dec 2008 18:30:23 -0500

Well, I'm one of those " Alto guys ". Alto will answer queries about  
proximity, but the question of randomness of node IDs is well outside  
Alto's scope. This working group will have to decide whether, as I  
suspect, randomness of node IDs is an important property to preserve.

Bruce
On Dec 2, 2008, at 11:13 AM, songhaibin 64081 wrote:

> Bruce,
>
> I agree with you that pastry has proximity property, and can achieve  
> efficent routing. But for leafset, peer must choose leafset nodes  
> that have closest IDs with it. It doesn't have a list of candidate  
> peers to choose from as the routing table entries do. SO, by  
> randomly assigned IDs, it will make the resource records  
> mainternance between leafset nodes(when join or leave, or replicate  
> happens often) not efficient because they waste the network hops.
>
> If node IDs have network proximity property, it will make the  
> routing message which gets closer and closer to the destination  
> ID(e.g. Chord or Pastry), also gets closer and closer to the  
> destination node in the network topology. It is a nature effect.
>
>>> P2PSIP@ is well outside Alto'ietf.org/mailman/listinfo/p2psip
>>
>>

---

From: "lichun li" <[email-masked]>
Date: Wed, 3 Dec 2008 08:55:10 +0800

I think both randomness of node ID and proximity-aware DHT are
options. Randomness of node IDs is required in some overlays for
security and load balancing reasons. Some overlays may not require
randomness of node IDs because security and load balancing issues are
already handled by other means. Sometimes proximity-aware DHT is not
necessary. For example, all nodes of a overlay locate in the same LAN.

On Wed, Dec 3, 2008 at 7:30 AM, Bruce Davie <[email-masked]> wrote:
> proximity, but the question of randomness of node IDs is well outside Alto's
> scope. This working group will have to decide whether, as I suspect,
> randomness of node IDs is an important property to preserve.
>
> Bruce
>> efficent routing. But for leafset, peer must choose leafset nodes that have
>> closest IDs with it. It doesn't have a list of candidate peers to choose
>> from as the routing table entries do. SO, by randomly assigned IDs, it will
>> make the resource records mainternance between leafset nodes(when join or
>> leave, or replicate happens often) not efficient because they waste the
>> network hops.
>>
>> If node IDs have network proximity property, it will make the routing
>> message which gets closer and closer to the destination ID(e.g. Chord or
>> Pastry), also gets closer and closer to the destination node in the network
>> topology. It is a nature effect.
>>
>>>> P2P networks are teemed with dynamic nodes. When a peer leaves
>>>
>>> the
>>>>
>>>> which has a close node ID. From the perspective of an ISP's
>>>
>>> network,
>>>>
>>>> Besides that, I think overlay maintenance messages will also
>>>
>>> take
>>>>
>>>> less network hops if most neighbors have close node IDs. If node
>>>
>>> ID
>>>>
>>>> I think we can find some papers describing the proximity for
>>>
>>> DHTs. I
>>>>
>>>> agree with Bruce that there are many considerations when
>>>
>>> assigning
>>>>
>>>> node id.
>>>>
>>>> Best Regards,
>>>> Song Haibin
>>>>
>>>>
>>>>>
>>>>>> Is someone considering the mapping between the P2PSIP ID and
>>>>>
>>>>> physical
>>>>>>
>>>>>> location. I think it is necessary to think about it although it
>>>>>
>>>>> is not
>>>>>>
>>>>>> "http://www.p2psip.org/drafts/draft-licanhuang-p2psip-
>>>>>
>>>>> subsetresourcelocation-00.txt",
>>>>>>
>>>>>> However, the peer ID is formed as domain name. Is that conflict
>>>>>
>>>>> with the
>>>>>>
>>>>>> concept that the ID should 128/160 bit integer?  Is it possible
>>>>>
>>>>> that
>>>>>>
>>>>>> each peer in one domain assigned  similar identity? Any
>>>>>
>>>>> suggestions?
>>>>>>
>>>>>> Thank you.
>>>>>>
>>>>>> Best Regards,
>>>>>> Xianghan Zheng
>>>>>>
>>>>>>
>>>>>>

-- 
Sincerely yours,

Lichun Li
Mobile Life New Media Lab, BUPT
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: songhaibin 64081 <[email-masked]>
Date: Wed, 03 Dec 2008 08:58:25 +0800

Bruce,

> Well, I'm one of those " Alto guys ". 

So am I.

>Alto will answer queries 
> about  
> Alto's scope. 

Yes. But I think alto's information can be a guidance for node id assignment. At least it is feasible for some scenarios, e.g. where the operator deploys all the peers.

>This working group will have to decide whether, as I 
> 

Shall we allow more options here?

Best Regards,
Song Haibin

> > I think we should allow different options for node id assignment 
> 
> > according to different scenarios.
> >
> > my two cents
> > Song Haibin
> >
> >

---

From: "Wei Gengyu" <[email-masked]>
Date: Thu, 4 Dec 2008 23:12:40 +0800

Bruce and Haibin,

In my opinion, the randomness of Node ID should be mandatory.

People who concern about the physical location of Node ID need to design a 
method
to bind the Node ID with an IP address.

It is not a good choice to have Node ID contain network info.

Regards,

Gengyu

----- Original Message ----- 
From: "Bruce Davie" <[email-masked]>
To: "songhaibin 64081" <[email-masked]>
Cc: "P2PSIP WG" <[email-masked]>
Sent: Wednesday, December 03, 2008 7:30 AM
Subject: Re: [P2PSIP] P2PSIP ID and physical location

>> efficent routing. But for leafset, peer must choose leafset nodes  that 
>> have closest IDs with it. It doesn't have a list of candidate  peers to 
>> choose from as the routing table entries do. SO, by  randomly assigned 
>> IDs, it will make the resource records  mainternance between leafset 
>> nodes(when join or leave, or replicate  happens often) not efficient 
>> because they waste the network hops.
>>
>> Pastry), also gets closer and closer to the  destination node in the 
>> network topology. It is a nature effect.
>>

---

From: songhaibin 64081 <[email-masked]>
Date: Fri, 05 Dec 2008 10:51:05 +0800

> It is not a good choice to have Node ID contain network info.

Why not?

-Haibin

> > suspect, randomness of node IDs is an important property to 
> preserve.>
> > Bruce
> routing

---

From: "Wei Gengyu" <[email-masked]>
Date: Fri, 5 Dec 2008 13:15:17 +0800

The following is personal answer to the quesiotn "It is not a good choice to 
have Node ID contain network info."

1) Node ID is an identifier.
   Node ID is used to identify an entity at application layer.
   The Node ID should not changed during communications.

2) IP address may change.
   Suppose the Node ID contains an IP address, the IP address may change 
during commincation.
   e.g. a moving node (mobile terminal).

3) Cross-layer generation process.
   If Node ID is defined as an identifier of application layer,
   the generation process is the duty of application layer.
   If Node ID contains IP address, the generation process will be an 
cross-layer work.

4) Binding Node ID and IP address
   Binding a Node ID and an IP address is easier than cross-layer work.
   And the concept or idea of Binding is not new.
   But it is required to define how to bind a Node ID with an network info.

Gengyu

---

From: Song Haibin <[email-masked]>
Date: Mon, 08 Dec 2008 10:18:08 +0800

Gengyu,

I am very clear of what you said, even years ago. But I don't mean node id
must be generated by IP address here. I think it could be generated by
referring to the network topology/policy, by taking the topology/policy info
that ALTO server provided into account.

Best Regards,
Haibin
Email: [email-masked]
Skype: alexsonghw

>-----Original Message-----
>From: Wei Gengyu [mailto:[email-masked]]
>Sent: Friday, December 05, 2008 1:15 PM
>To: songhaibin 64081
>Cc: Bruce Davie; P2PSIP WG

---

From: "Wei Gengyu" <[email-masked]>
Date: Mon, 8 Dec 2008 14:36:15 +0800

Haibin,

I would like to know what do you mean the topology/policy info.
Wether the topology is the P2PSIP overlay or the physical network topology?

Regards,

Gengyu