Subject: Re: [P2PSIP] 答复: New version of draft-ietf-p2psip-base

From: Cullen Jennings <[email-masked]>
Date: Tue, 27 Oct 2009 12:41:04 +0100

I'm a bit confused on how splitting the text across 4 drafts that all  
normatively reference each other will help. An implementor will still  
have to read all of them to do anything and it makes it hard to keep  
them consistent. If there are parts of the draft that you think don't  
need to be implemented and could just be removed, well that would help  
make it shorter and I'd be very happy to get recommendations and how  
to make it easier for implementors by making less stuff that needed to  
be implemented.

Cullen <in my individual contributor role>

On Oct 27, 2009, at 4:44 , lucy yong wrote:

> Hi Cullen and Chairs,
>
> I volunteered to review this draft in last IETF meeting and read  
> chapter 1~4
> and some in the rest of v4.
>
> IMHO, the draft contains too much contents and too long. It would be  
> nice if
> it can be split into two or three drafts. One is about overlay  
> framework and
> another is Overlay protocol.
>
> Two major protocols for overlay management and data storage are  
> specified in
> current draft, which can be specified in two drafts as well.
>
> There are other protocols that apply to overlay network. If we  
> complete the
> framework draft, all protocol drafts can be developed in parallel.  
> Having
> such BIG and HEAVY draft is hard to get consensuses and make any  
> change in
> later.
>
> Regards,
> Lucy
>
> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表  
> Cullen
> Jennings
> 发送时间: 2009年10月24日 2:39
> 收件人: P2PSIP WG
> 主题: [P2PSIP] New version of draft-ietf-p2psip-base
>
>
> We just submitted a new version of the base draft at
>
> http://www.ietf.org/id/draft-ietf-p2psip-base-05.txt
>
> (there is a new version of the sip-usage as well).
>
> The major changes are mostly a very long and excruciating editorial
> pass to try and improve the grammar.
>
> At this point, I don't know of any significant issues that need to be
> resolved. I think the draft is ready for WGLC.
>
> I'm sure that during WGLC some major issues will come up, some
> important decisions will be made about what needs to be mandatory and
> such, and we will find several small inconsistencies and typos in the
> draft as well as things that need a clearer explanation. This will
> take some time and I expect multiple more revisions for this draft
> before it is published, however, I do think this is the right time to
> start WGLC. Lets get the issues on the table and then we can start
> resolving them.
>
> Thanks,
> Cullen <in my individual contributor role>
>
>
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip
>
>

---

From: Yong Lucy <[email-masked]>
Date: Tue, 27 Oct 2009 07:20:49 -0500

Splitting text will make each draft focusing on one subject in overlay
network. Although an implementer may need to read all of them, he/she don't
need to read them in the same level detail. If each draft addresses one
subject, there is no issue on keeping consistent because one draft can
reference another RFC and does not repeat the same text. IETF has been
working on this style well for long. 
Regards,
Lucy

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Tuesday, October 27, 2009 6:41 AM
> To: lucy yong
> Cc: P2PSIP WG
> Subject: Re: 答复: [P2PSIP] New version of draft-ietf-p2psip-base
> 
>

---

From: Brian Rosen <[email-masked]>
Date: Tue, 27 Oct 2009 12:47:31 -0400

<as an individual>
Having dealt with both kinds, I lean towards one document with everything.
I really don't like having to refer back to other documents to get the
picture, and I can always skim through the parts I don't care about.  I find
that I retain parts of the "skim" which keeps the big picture in my head
better.

I just did this over in ecrit (-framework and -phonebcp).  It was a mistake:
we should have had one document.

Brian

> Splitting text will make each draft focusing on one subject in
network. Although an implementer may need to read all of them, he/she
> don't
need to read them in the same level detail. If each draft addresses
> one
subject, there is no issue on keeping consistent because one draft
> can
reference another RFC and does not repeat the same text. IETF has
> been

> Subject:
> Re: 答复: [P2PSIP] New version of draft-ietf-p2psip-base
> 
> 
> I'm a bit
> confused on how splitting the text across 4 drafts that all
> normatively
> reference each other will help. An implementor will still
> have to read all
> of them to do anything and it makes it hard to keep
> them consistent. If
> there are parts of the draft that you think don't
> need to be implemented and
> could just be removed, well that would help
> > Two major
> protocols for overlay management and data storage are
> > specified in
> >
> > There are
> other protocols that apply to overlay network. If we
> > complete the
> >
> > 发件
> 人: [email-masked] [mailto:[email-masked]] 代表
> > Cullen
> >
> Jennings
> > 发送时间: 2009年10月24日 2:39
> > 收件人: P2PSIP WG
> > 主题:
> [P2PSIP] New version of draft-ietf-p2psip-base
> >
> >
> > We just submitted a
> > I'm sure that during
> WGLC some major issues will come up, some

P2PSIP mailing
> list
[email-masked]