Subject: [P2PSIP] Partial search?

From: "Thomas Kluge" <[email-masked]>
Date: Wed, 1 Dec 2010 15:08:26 +0100

This might be slightly off topic here, but is there something which covers 
partial search of ressources?

What I if have in mind is a RELOAD SIP usage where a participiant only knows 
a substring of the AOR and after a 'search' he gets all stored AORs in the 
overlay containing that value?

Thomas Kluge (T-Systems International)

---

From: jc <[email-masked]>
Date: Wed, 1 Dec 2010 17:44:11 -0500

You would require a binary search tree or controlled query flooding. I'm not sure how a usage could be created because the generic DHT is too dumb and too static for this.

Julian Cain

On Dec 1, 2010, at 9:08 AM, "Thomas Kluge" <[email-masked]> wrote:

> This might be slightly off topic here, but is there something which covers partial search of ressources?
> 
> What I if have in mind is a RELOAD SIP usage where a participiant only knows a substring of the AOR and after a 'search' he gets all stored AORs in the overlay containing that value?
> 
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: Jani Hautakorpi <[email-masked]>
Date: Thu, 2 Dec 2010 10:27:56 +0200

> overlay containing that value?

We have done some research on search mechanisms in structured P2P
network (e.g., networks that use RELOAD), see our paper:

   http://dx.doi.org/10.1109/ICCCN.2010.5560101

Some of the work done by others is briefly presented in "Related Work"
section of the paper.

-- 
Jani

---

From: jc <[email-masked]>
Date: Thu, 2 Dec 2010 04:44:20 -0500

Sent from my iPhone

On Dec 2, 2010, at 4:20 AM, "Britsch, Matthias" <[email-masked]> wrote:

> Hi Julian
> 
> I think the problem is not only including all peers in the search
> request, but the nature of searching for hashed values.
> 
> Assume you want to communicate to somebody, say Mr. Smith with ACME, but
> you don't know how his first name, so what you would like to do is
> searching for "[email-masked]".
> 
> In my understanding even flooding (controlled or not) would not help.

Skype uses controlled flooding to perform this exact action. It's how the GI works.

> 
> Regards,     Matthias
> 
> 
> 
> 
> Deutsche Telekom AG
> Aufsichtsrat/ Supervisory Board: Prof. Dr. Ulrich Lehner (Vorsitzender/ Chairman)
> Vorstand/ Board of Management: Rene Obermann (Vorsitzender/ Chairman), Dr. Manfred Balz, Reinhard Clemens,  Niek Jan van Damme, Timotheus Hottges, Guido Kerkhoff, Edward R. Kozel, Thomas Sattelberger
> Handelsregister/Commercial Register Entry: Amtsgericht Bonn, HRB 6794, Registered Office Bonn
> USt.-ID./VAT Reg.No.: DE123475223
> Sitz der Gesellschaft/ Corporate Headquarters: Bonn
> 
> 
> 
> 
> -----Original Message----- 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of jc
> Sent: Mittwoch, 1. Dezember 2010 23:44
> To: Thomas Kluge
> Cc: <[email-masked]>
> Subject: Re: [P2PSIP] Partial search?
> 
> You would require a binary search tree or controlled query flooding. I'm
> not sure how a usage could be created because the generic DHT is too
> dumb and too static for this.
> 
> Julian Cain
> 
>> What I if have in mind is a RELOAD SIP usage where a participiant only
> knows a substring of the AOR and after a 'search' he gets all stored
> AORs in the overlay containing that value?
>>

---

From: "Britsch, Matthias" <[email-masked]>
Date: Thu, 2 Dec 2010 10:20:31 +0100

Hi Julian

Regards,     Matthias

Deutsche Telekom AG

-----Original Message----- 

Julian Cain

---

From: [email-masked]
Date: Fri, 3 Dec 2010 09:54:18 +0800

Another way is storing <substring, AOR> mapping in DHT. Emule's DHT (KAD) 
uses this way for file search.  But I think it may overload some peers.

BR
Lichun

jc <[email-masked]> 
发件人:  [email-masked]
2010-12-02 06:44

收件人
Thomas Kluge <[email-masked]>
抄送
"<[email-masked]>" <[email-masked]>
主题
Re: [P2PSIP] Partial search?

You would require a binary search tree or controlled query flooding. I'm 
not sure how a usage could be created because the generic DHT is too dumb 
and too static for this.

Julian Cain

> What I if have in mind is a RELOAD SIP usage where a participiant only 
knows a substring of the AOR and after a 'search' he gets all stored AORs 
in the overlay containing that value?

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: jc <[email-masked]>
Date: Fri, 3 Dec 2010 14:18:50 -0500

Sent from my iPhone

On Dec 2, 2010, at 8:54 PM, [email-masked] wrote:

> 
> Another way is storing <substring, AOR> mapping in DHT. Emule's DHT (KAD) uses this way for file search.  But I think it may overload some peers. 

This overloads the entire DHT. Your basically flooding it with duplicate "values" under different keys. Ever wonder why Kad has a lookup time of 300+ seconds?