Subject: [P2PSIP] RELOAD support in Wireshark 1.6 [was Re: I-D Action: draft-ietf-p2psip-base-15.txt]

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 08 Jun 2011 12:22:49 -0700

FYI, version 1.6.0 of Wireshark was released yesterday, with support for RELOAD
up to -15.  This is a stable version so hopefully this will simplify and
accelerate the implementation and deployment of RELOAD.

On 05/27/2011 08:37 PM, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Peer-to-Peer Session Initiation Protocol Working Group of the IETF.
> 
> 	Title           : REsource LOcation And Discovery (RELOAD) Base Protocol
> 	Author(s)       : Cullen Jennings
>                           Bruce B. Lowekamp
>                           Eric Rescorla
>                           Salman A. Baset
>                           Henning Schulzrinne
> 	Filename        : draft-ietf-p2psip-base-15.txt
> 	Pages           : 160
> 	Date            : 2011-05-27
> 
>    This specification defines REsource LOcation And Discovery (RELOAD),
>    a peer-to-peer (P2P) signaling protocol for use on the Internet.  A
>    P2P signaling protocol provides its clients with an abstract storage
>    and messaging service between a set of cooperating peers that form
>    the overlay network.  RELOAD is designed to support a P2P Session
>    Initiation Protocol (P2PSIP) network, but can be utilized by other
>    applications with similar requirements by defining new usages that
>    specify the kinds of data that must be stored for a particular
>    application.  RELOAD defines a security model based on a certificate
>    enrollment service that provides unique identities.  NAT traversal is
>    a fundamental service of the protocol.  RELOAD also allows access
>    from &quot;client&quot; nodes that do not need to route traffic or store data
>    for others.

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org

---

From: "Michael Chen" <[email-masked]>
Date: Fri, 10 Jun 2011 22:26:41 -0700

FYI,

A new feature added to Wireshark 1.6.0 is the ability to dissect RELOAD
messages under DTLS if the agreed upon cipher-suite is either
RSA-NULL-MD5 (0x0001) or RSA-NULL-SHA (0x0002), even when DTLS is not
configured with the client/server private keys.

  https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5863

Take OpenSSL for example, you can make the following call on both sides
to take advantage of this feature:

  SSL_CTX_set_cipher_list(dtls, "NULL-SHA");

This has proven to be very helpful for debugging and inter-op tests.

Thanks

--Michael 

> -------- Original Message --------
> Subject: [P2PSIP] RELOAD support in Wireshark 1.6 [was Re: I-D Action:
> draft-ietf-p2psip-base-15.txt]
> From: Marc Petit-Huguenin <[email-masked]>
> Date: Wed, June 08, 2011 12:22 pm
> To: 
> Cc: [email-masked]
> 
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> 
> iEYEARECAAYFAk3vzAgACgkQ9RoMZyVa61fsvACgnyEAQkegmAGyFzGvUIpfoy+f
> 5wgAoJ+lwiyQzv3qZnUYPxpCrkv/A5gG
> =gRdu
> -----END PGP SIGNATURE-----
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip