Subject: [P2PSIP] data kinds in p2psip diagnostics

From: "Songhaibin (A)" <[email-masked]>
Date: Mon, 14 Jan 2013 09:22:32 +0000

Hi all,

When I am trying to update the document. I find we probably need to make the data model in p2psip diagnostics consistent with the base protocol document.

a). In the base document, data Kinds are organized under the Resource-ID. So in order to make them consistent, for the diagnostics data Kinds, the Resource-ID should be the exactly the node-ID.

b)We should specify the data model for each diagnostics kind, most of them are "Single" IMO. And the access control method is different from the existing access control method, as we discussed during last IETF.

c) To be clear, text should be added to clarify that, when a node leaves the overlay, it does not have to Store the diagnostics Kinds information to other peers. But the existing document says nothing about the transferring of the diagnostics information.

Any comments?

BR,
-Haibin

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 14 Jan 2013 16:41:41 -0800

On 01/14/2013 01:22 AM, Songhaibin (A) wrote:
> Hi all,
> 
> 
> 
> When I am trying to update the document. I find we probably need to make
> the data model in p2psip diagnostics consistent with the base protocol
> document.
> 
> 
> 
> a). In the base document, data Kinds are organized under the Resource-ID.
> So in order to make them consistent, for the diagnostics data Kinds, the
> Resource-ID should be the exactly the node-ID.
> 
> 
> 
> b)We should specify the data model for each diagnostics kind, most of them
> are “Single” IMO. And the access control method is different from the
> existing access control method, as we discussed during last IETF.
> 
> 
> 
> c) To be clear, text should be added to clarify that, when a node leaves
> the overlay, it does not have to Store the diagnostics Kinds information to
> other peers. But the existing document says nothing about the transferring
> of the diagnostics information.
> 
> 
> 
> Any comments?
> 

I am confused.  I thought that the data available from -diagnostics were *not*
data Kinds as described in -base (make sense because clients could not make
such data available).

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: "Songhaibin (A)" <[email-masked]>
Date: Tue, 15 Jan 2013 09:06:05 +0000

Hi Marc,

OK. I think we can also clarify it clear in the text that the diagnostics data kinds are not the data kinds in the base. We use 16 bits integer for the diagnostics data kinds, but the base document uses 32 bits integer for data Kind IDs. I'm okay with two different data kinds concept.

thanks,
-Haibin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Marc Petit-Huguenin
> Sent: Tuesday, January 15, 2013 8:42 AM
> To: Songhaibin (A)
> Cc: P2PSIP WG
> Subject: Re: [P2PSIP] data kinds in p2psip diagnostics
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.12 (GNU/Linux)
> 
> iQIcBAEBCAAGBQJQ9KXEAAoJECnERZXWan7EcFcQALSV1ruudxVLz5rAh0A+o9De
> xbqVI99cPwXQwUzpHWnvgYZAd2Wyr9PHPKhbv/aS7nzhQF5cwMJrniYSd5Kj36R
> m
> lpBVuH8B8TwNV05f8a6+3me4QIDZIWZ9LdxasudDMmhS8lwh1PQydAHr4KHatDhl
> oEaUppYaVKKd6a+psrlEJ93yk22cembTFYXrTWzH7/lLK6nh/n4iwOw6N3cuLksr
> Hx9DvTMDrCqKdDiHhC/iPLZVwmi9oPROpXSJtfdTn5RjTSmxV9v3Tv7cd0ljBV86
> WTuSmr0ZQJ45VLc6kooqRbbjL2cfNY1brTZ13PUz3N/sFmW2t60JTGOnIFIe+w3r
> wEUm29TcPsInM1mhjkqF2KnZJdNZ5N8+Kvhk/xjIUfbSgjEhdB9dZWjm07UTigxY
> t0y+lTwMTMMV0dqwE9GXXusvcGcSdDkjRkooU450wcEFzWo2RR8kyQBbIozNcHr
> G
> z1+A0jd19rUrO1Pl0QJJbmN0hDPURgxZxpE0LVcmcQaX0iiba9IUY4fqZlCYfMck
> 5eTlFK8I5O38gMJwFZUSn0hN+bW5hP81D8tyn/uoQK0GiHVPXzd22GkPle3zOTk4
> /zm03Mu0+psDAMj45BMDIAlzV4IXXVgb8It61uPCqW/ClTes2Ev51U9N6AXgBmJa
> bwlKM5F8aw5p6mrfZhaX
> =7ynt
> -----END PGP SIGNATURE-----
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip