Subject: [P2PSIP] Joel Jaeggli's Abstain on draft-ietf-p2psip-diagnostics-19: (with COMMENT)

From: "Joel Jaeggli" <[email-masked]>
Date: Tue, 15 Dec 2015 23:35:06 -0800

Joel Jaeggli has entered the following ballot position for
draft-ietf-p2psip-diagnostics-19: Abstain

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-p2psip-diagnostics/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Mhement Ersue did the opsdir review,

While I would not prevent this document on a technical basis I would hope
very strongly that in addressing the discusses that further refinement
can improve the proposed standard... where that done I'd be happy to
ballot no objection.

-----------

 reviewed the document "P2P Overlay Diagnostics"
(draft-ietf-p2psip-diagnostics-19.txt) as part of the Operational
directorate's ongoing effort to review all IETF documents being processed
by the IESG.  These comments were written primarily for the benefit of
the operational area directors.  Document editors and WG chairs should
treat these comments just like any other last call comments.
 
Intended status: Standards Track
Updates: 6940 (if approved)
Current IESG state: In Last Call (ends 2015-12-14)
IANA Review State: IANA - Not OK (see for IANA comments at:
https://datatracker.ietf.org/doc/draft-ietf-p2psip-diagnostics/history/)
 
Summary: The document describes mechanisms for P2P overlay diagnostics. 
It defines extensions to the RELOAD P2PSIP base protocol to collect
diagnostic information, and details the protocol specifications for these
extensions.  
 
Comments:
- The document is not easy to read and the clarity could be improved.
- It is common practice and rule to mention in the document abstract the
RFC which is going to be updated.
- There are many occurrences of the word “should”. Are these meant to be
normative language and “SHOULD”?
 
- There are different terms used in the first few sections, which are not
introduced properly. One substantial term the reader is surprised with is
"diagnostic kind type".
- I believe the basic terms used in the document should be defined in a
Terminology section if not defined in RFC 6940. The Terminology section
should mention that the terminology from RFC 6940 is used.
- The term "Kind" has been defined in RFC 6940. If the term "kind" is to
be used as defined in RFC 6940 it should be used with a capital "K".
- There are different very long sentences and a few
5-to-6-part-substantives which don't contribute to readability (e.g.:
“single, general P2PSIP overlay diagnostic framework”).
- Concerning: "The second is a new method and response, PathTrack,"
I would like to suggest to delete "and response" or call it "a new
request/response method".
 
The idnits tool returns one error and numerous warnings which need to be
fixed (13 warnings, 2 comment and 1 error).
See
http://tools.ietf.org/idnits?url=https://tools.ietf.org/id/draft-ietf-p2psip-diagnostics-19.txt

---

From: "Songhaibin (A)" <[email-masked]>
Date: Thu, 31 Dec 2015 03:05:36 +0000

Dear Joel,

Please see my reply in line.

> -----Original Message-----
> From: Joel Jaeggli [mailto:[email-masked]]
> Sent: Wednesday, December 16, 2015 3:35 PM
> To: The IESG
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Joel Jaeggli's Abstain on draft-ietf-p2psip-diagnostics-19: (with
> COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 

Thanks.

> 
> While I would not prevent this document on a technical basis I would hope very
> strongly that in addressing the discusses that further refinement can improve
> the proposed standard... where that done I'd be happy to ballot no objection.
> 
> -----------
> 
> (draft-ietf-p2psip-diagnostics-19.txt) as part of the Operational directorate's
> ongoing effort to review all IETF documents being processed by the IESG.
> These comments were written primarily for the benefit of the operational area
> directors.  Document editors and WG chairs should treat these comments
> just like any other last call comments.
> 
> Current IESG state: In Last Call (ends 2015-12-14) IANA Review State: IANA -
> Not OK (see for IANA comments at:
> It defines extensions to the RELOAD P2PSIP base protocol to collect diagnostic
> information, and details the protocol specifications for these extensions.
> 
> Comments:

If it can be more specific, then it will be more helpful.

> - It is common practice and rule to mention in the document abstract the RFC
> which is going to be updated.

This will be resolved in another discussion thread that whether it updates RFC6940.

> normative language and “SHOULD”?

No, "should"s are not normative language in this document.

> introduced properly. One substantial term the reader is surprised with is

It is a language problem, "diagnostic Kind" is more clear than "diagnostic kind type". I can revise that.

> Terminology section if not defined in RFC 6940. The Terminology section should
> mention that the terminology from RFC 6940 is used.
> - The term "Kind" has been defined in RFC 6940. If the term "kind" is to be used
> as defined in RFC 6940 it should be used with a capital "K".

It has already mentioned concepts from RFC6940 are used in the terminology section. The suggestion to change "kind" to "Kind" is correct and accepted.

> - There are different very long sentences and a few 5-to-6-part-substantives
> which don't contribute to readability (e.g.:

What about changing it to "a P2P overlay diagnostic framework ..."?

> request/response method".

Accept.

> 
> The idnits tool returns one error and numerous warnings which need to be fixed
> (13 warnings, 2 comment and 1 error).
> See

The warnings of references (TBD1...TBD8) will be resolved after those numbers are assigned by IANA. Actually although they are embraced by square brackets, they are not references, but only the numbers to be determined. I do not understand why there are the following two warnings:
"  == Line 337 has weird spacing: '...ionType  type;...'

  == Line 531 has weird spacing: '... opaque  diagn..."

The comment for document date is invalid now as we run idnits tool today. And the other comment will be resolved in another thread on whether it updates RFC6940.
I will check why there is 1 error about too long lines in the document, and it will be easily solved.

Thanks again,

-Haibin Song