Subject: [Pals] IPR review of draft-ietf-pals-ms-pw-protection

From: Stewart Bryant <[email-masked]>
Date: Tue, 28 Apr 2015 19:07:00 +0100

The authors of draft-ietf-pals-ms-pw-protection have requested
that I make a WG last call on this draft. However following
established practice I first need to determine whether there
is any undisclosed IPR on this draft.

Authors, please reply to this message including the PALS WG
in the CC list indicating whether or not you know of any
not yet disclosed IPR that is applicable.

WG if you know of any IPR that is relevant please disclose it.

This poll will end 12 May 2015, or when I have heard from all
authors, which ever is later.

Thanks

Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 28 Apr 2015 19:13:53 +0100

I have some comments on draft-ietf-pals-ms-pw-protection

1) I am not sure whether this is standards track or not. I does not
really specify a new protocol, it just describes how you would use
an existing protocol in a new environment. It seems to me that
this should either be an informational or perhaps an applicability
statement.

2) If this were ST, then I think it would be useful to clarify that
Appendix 1 is not normative.

3) I count six authors,  hopefully you can justify this to the IESG
if asked.

- Stewart

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 28 Apr 2015 15:54:25 -0400

Stewart,

I am not aware of any IPR regarding this draft.

Thanks,
Andy

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 28 Apr 2015 16:09:57 -0400

Stewart,

Thanks for your comments.

1) Regarding standards track, this was discussed during the WG adoption
poll. At that time, Greg Mirsky wrote:

Firstly, I support adoption of this document by the WG.
Second, considering that the document doesn’t put forth any IANA requests,
nor changes any earlier defined procedures but rather document
applicability of the RFC 6478, would authors consider Informational track
for this document?

To which I replied:

Thanks for your support, and yes we would, although we prefer standards
track so that it would be marked as "Updates 6870" in the RFC database, so
anyone implementing 6870 will also read it, and a reference added if
there's ever a 6870-bis.

This answer still holds, since it extends the applicability of RFC 6870,
making it standards track insures that future readers of 6870 should also
read it. I don't think that would be the case were it informational.

We (the authors) are of course willing to further discuss this, we just
want to make sure that it get the proper visibility to readers of 6870.

2) Appendix 1 is already clear that it is optional, it's right in the title
as well as the final paragraph of section A.1, and in the abstract at the
top of the draft as well. However, let us know if you have any specific
changes you would like to see in the text.

3) I'll poll the authors about this.

Thanks again,
Andy

On Tue, Apr 28, 2015 at 2:13 PM, Stewart Bryant <[email-masked]> wrote:

> _______________________________________________
> Pals mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pals
>

---

From: "Wang Lei" <[email-masked]>
Date: Wed, 29 Apr 2015 08:59:11 +0800

I am not aware of any IPR related to this draft. 

Best Regards,

Lei Wang

发件人: Stewart Bryant [mailto:[email-masked]] 
发送时间: 2015年4月29日 2:07
收件人: [email-masked]
抄送: [email-masked]
主题: IPR review of draft-ietf-pals-ms-pw-protection

Thanks

Stewart

---

From: Loa Andersson <[email-masked]>
Date: Wed, 29 Apr 2015 07:40:42 +0200

Stewart,

I'm not aware of any IPR that relates to this draft.

/Loa

On 2015-04-28 21:54, Andrew G. Malis wrote:
> On Tue, Apr 28, 2015 at 2:07 PM, Stewart Bryant <[email-masked]
> <mailto:[email-masked]>> wrote:
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: 신종윤(Shin Jongyoon) <[email-masked]>
Date: Wed, 29 Apr 2015 06:09:38 +0000

Dear All,

I am not aware of any IPR that applies to this draft.

Best regards,
Jongyoon

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Wednesday, April 29, 2015 2:41 PM
> To: Andrew G. Malis; Stewart Bryant
> Cc: [email-masked]; [email-masked]
> Subject: Re: IPR review of draft-ietf-pals-ms-pw-protection
> 
> Stewart,
>

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 29 Apr 2015 11:14:35 +0100

On 28/04/2015 21:09, Andrew G. Malis wrote:
> 1) Regarding standards track, this was discussed during the WG 
> adoption poll. At that time, Greg Mirsky wrote:
>
>
>     Second, considering that the document doesn’t put forth any IANA
>     requests, nor changes any earlier defined procedures but rather
>     document applicability of the RFC 6478, would authors consider
>     Informational track for this document?
>
>
> To which I replied:
>
>     Thanks for your support, and yes we would, although we prefer
>     standards track so that it would be marked as "Updates 6870" in
>     the RFC database, so anyone implementing 6870 will also read it,
>     and a reference added if there's ever a 6870-bis.
>
>
> This answer still holds, since it extends the applicability of RFC 
> 6870, making it standards track insures that future readers of 6870 
> should also read it. I don't think that would be the case were it 
> informational.
>
> We (the authors) are of course willing to further discuss this, we 
> just want to make sure that it get the proper visibility to readers of 
> 6870.
>
I am not sure that it does actually update RFC6870.

An RFC6870 implementation that ignored this would not be incorrect in 
any way. It seems to me that this is ships in the night WRT RFC6870.

I am not sure I buy the -bis argument either since anyone competent to 
write the bis would find this.

- Stewart
> 2) Appendix 1 is already clear that it is optional, it's right in the 
> title as well as the final paragraph of section A.1, and in the 
> abstract at the top of the draft as well. However, let us know if you 
> have any specific changes you would like to see in the text.
>
> On Tue, Apr 28, 2015 at 2:13 PM, Stewart Bryant <[email-masked] 
>     [email-masked] <mailto:[email-masked]>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: D'Alessandro Alessandro Gerardo <[email-masked]>
Date: Wed, 29 Apr 2015 14:06:29 +0000

Dear Stewart,

Best regards,
Alessandro

Sent by Samsung Mobile!

------------------------------------------------------------------
Telecom Italia
Alessandro Gerardo D'Alessandro
Transport Innovation
Via Reiss Romoli, 274 - 10148 Torino
phone:  +39 011 228 5887
mobile: +39 335 766 9607
fax: +39 06 418 639 07

Da: Stewart Bryant [mailto:[email-masked]]
Inviato: martedì 28 aprile 2015 20:07
A: [email-masked]
Cc: [email-masked]
Oggetto: IPR review of draft-ietf-pals-ms-pw-protection

Thanks

Stewart

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

[rispetta l'ambiente]Rispetta l'ambiente. Non stampare questa mail se non è necessario.