Subject: Re: [Pals] Shepherd's review of draft-ietf-pals-redundancy-spe-01

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Tue, 4 Aug 2015 08:52:02 +0000

Hi Jie

Please could you also fix the following I-D Nit before you post the new version:

Checking nits according to http://www.ietf.org/id-info/checklist :
  ----------------------------------------------------------------------------

  ** The abstract seems to contain references ([RFC6870]), which it
     shouldn't.  Please replace those with straight textual mentions of the
     documents in question.

Best regards

Matthew

From: Pals <[email-masked]<mailto:[email-masked]>> on behalf of Matthew Bocci <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 30 July 2015 10:54
To: "Dongjie (Jimmy)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Pals] Shepherd's review of draft-ietf-pals-redundancy-spe-01

Hi Jie

Thank you. The changes you propose below should be fine.

I’ll post the shepherds write up as soon as you post an updated draft.

Best regards

Matthew

From: "Dongjie (Jimmy)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 29 July 2015 08:00
To: Matthew Bocci <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Shepherd's review of draft-ietf-pals-redundancy-spe-01

Hi Matthew,

Thanks a lot for your comments, please see my replies inline with [Jie]:

Best regards,
Jie

From: Bocci, Matthew (Matthew) [mailto:[email-masked]]
Sent: Monday, July 27, 2015 8:38 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Shepherd's review of draft-ietf-pals-redundancy-spe-01

Authors

I am the document shepherd for draft-ietf-pals-redundancy-spe-01.  I have reviewed the draft, and I think it is mostly ready to go. However, I have a few suggestions that I think would improve the clarity of the draft. Please treat these suggestions as last call comments.

Introduction:
"In some MS-PW scenarios, there are benefits to provide PW redundancy  on S-PEs, such as reducing the burden on the access T-PE nodes, and faster protection switching. “
I think you are assuming that it is faster because PW status messages have to propagate through less hops, but I am not sure that makes a huge difference because most deployments are only 2 or 3 hops. Please can you be more explicit.

[Jie] Since the switchover is performed on S-PE, this mechanism is segment protection of MS-PW, which means it could be faster than end-to-end protection. I agree in most scenarios there are only a few hops, while since the PW status message is processed by the control plane of each S-PE hop, there still can be some difference. We could make this more explicit by adding some description about segment protection vs. end-to-end protection in the introduction.

Section 3, S-PE Operations:
- I think you need to be more explicit about the mode that each T-PE operates in. It looks like T-PE1 has to operate as a master, and T-PE2 and T-PE3 always act in independent mode. However, the draft doesn’t explicitly make that statement anywhere (at least not for T-PE2 and T-PE3). Please can you add such a statement?

[Jie] Will add some statement about the mode of T-PE2 and T-PE3.

Section 6: Security Considerations.
I think you will need to be more explicit. It might help to add an explicit statement that the requirements that apply to those RFCs apply here. You should also add a reference to RFC6073 here as S-PE security is relevant.

[Jie] Will add the explicit statement and the reference to RFC6073 to the Security Considerations section.

Regards

Matthew

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 4 Aug 2015 09:25:33 +0000

Hi Matthew,

Sure, we will fix this nit and upload the new version soon.

Best regards,
Jie

From: Bocci, Matthew (Matthew) [mailto:[email-masked]]
Sent: Tuesday, August 04, 2015 4:52 PM
To: Bocci, Matthew (Matthew); Dongjie (Jimmy); [email-masked]
Cc: [email-masked]
Subject: Re: [Pals] Shepherd's review of draft-ietf-pals-redundancy-spe-01

Hi Jie

     documents in question.

Best regards

Matthew

Hi Jie

I'll post the shepherds write up as soon as you post an updated draft.

Best regards

Matthew

Hi Matthew,

Best regards,
Jie

Authors

Introduction:
"In some MS-PW scenarios, there are benefits to provide PW redundancy  on S-PEs, such as reducing the burden on the access T-PE nodes, and faster protection switching. "
I think you are assuming that it is faster because PW status messages have to propagate through less hops, but I am not sure that makes a huge difference because most deployments are only 2 or 3 hops. Please can you be more explicit.

Section 3, S-PE Operations:
- I think you need to be more explicit about the mode that each T-PE operates in. It looks like T-PE1 has to operate as a master, and T-PE2 and T-PE3 always act in independent mode. However, the draft doesn't explicitly make that statement anywhere (at least not for T-PE2 and T-PE3). Please can you add such a statement?

Regards

Matthew