Subject: [Pals] Alissa Cooper's No Objection on draft-ietf-pals-mpls-tp-pw-over-bidir-lsp-08: (with COMMENT)

From: "Alissa Cooper" <[email-masked]>
Date: Wed, 06 Jul 2016 15:25:40 -0700

Alissa Cooper has entered the following ballot position for
draft-ietf-pals-mpls-tp-pw-over-bidir-lsp-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pals-mpls-tp-pw-over-bidir-lsp/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

In Section 1:

"Further, the
   operators may apply different protection mechanisms on different
   parts of the network.  As such, for optimal traffic management,
   traffic belonging to a particular user should traverse over the same
   fiber.  That implies that both forwarding and reserve direction PWs
   that belong to the same user flow need to be mapped to the same co-
   routed bi-directional LSP or two LSPs with the same route."

I'm wondering if this is a bit over-stated, and if "protection
mechanisms" means specifically MPLS protection or if it is really a
euphemism for a wide class of things, some of which are in an individual
user's interest, and some of which are not (e.g., traffic shaping,
content filtering, etc.). I think these claims should be stated more
neutrally, e.g., "operators may prefer to have a user's traffic traverse
the same fiber" rather than talking about "optimal traffic management."
And "protection" should either be defined, or a more descriptive term
should be used.

---

From: Mach Chen <[email-masked]>
Date: Tue, 12 Jul 2016 09:08:05 +0000

Hi Alissa,

Thanks for your comments!

Please see my reply inline...

> -----Original Message-----
> From: Alissa Cooper [mailto:[email-masked]]
> Sent: Thursday, July 07, 2016 6:26 AM
> To: The IESG
> Cc: [email-masked]; Stewart Bryant;
> [email-masked]; [email-masked]; [email-masked]
> Subject: Alissa Cooper's No Objection on
> draft-ietf-pals-mpls-tp-pw-over-bidir-lsp-08: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> I'm wondering if this is a bit over-stated, and if "protection mechanisms"
> means specifically MPLS protection or if it is really a euphemism for a wide class
> of things, some of which are in an individual user's interest, and some of which
> are not (e.g., traffic shaping, content filtering, etc.). I think these claims should
> be stated more neutrally, e.g., "operators may prefer to have a user's traffic
> traverse the same fiber" rather than talking about "optimal traffic
> management."
> And "protection" should either be defined, or a more descriptive term should
> be used.

How about this:

"Further, the operators may apply different protection mechanisms on different parts of the network (e.g., deploy 1:1 protection in one part and 1+1 protection in other parts). As such, operators may prefer to have a user's traffic traverse the same fiber."

Best regards,
Mach