Subject: [Pals] Alexey Melnikov's Discuss on draft-ietf-pals-mc-pon-04: (with DISCUSS)

From: "Alexey Melnikov" <[email-masked]>
Date: Tue, 13 Sep 2016 23:57:23 -0700

Alexey Melnikov has entered the following ballot position for
draft-ietf-pals-mc-pon-04: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pals-mc-pon/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

I have a couple of minor blocking points I would like to discuss, but
they should be easy to fix:

1) In 2.1.1 and other sub-sections: should sub-TLV format be defined now,
even though you don't specify any sub-TLV? (or is it already specified in
another document?) Should recipients ignore unrecognized sub-TLVs or do
something else? Please clarify.

2) In 2.1.3: what is "system priority"? This is not explained. Please
either add an explanation or a reference to a document that defines it.

---

From: Jiangyuanlong <[email-masked]>
Date: Sun, 18 Sep 2016 08:11:36 +0000

Hi Alexey,

1) For this protocol version (001), no Optional Sub-TLV is defined yet, thus the field does not exist on the wire. This field is intended to give a guideline on future protocol extensions, but there is no details of sub-TLVs format yet, and we would like to defer the format and how to process it to future versions of the protocol.

2) System Priority is a 2-octets value assigned by management or administration policy, the OLT with the numerically lower value of System Priority has the higher priority. We will clarify it in the next revision.

Thanks,
Yuanlong

-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]] 
Sent: Wednesday, September 14, 2016 2:57 PM
To: The IESG
Cc: [email-masked]; Andrew G. Malis; [email-masked]; [email-masked]; [email-masked]
Subject: Alexey Melnikov's Discuss on draft-ietf-pals-mc-pon-04: (with DISCUSS)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I have a couple of minor blocking points I would like to discuss, but they should be easy to fix:

1) In 2.1.1 and other sub-sections: should sub-TLV format be defined now, even though you don't specify any sub-TLV? (or is it already specified in another document?) Should recipients ignore unrecognized sub-TLVs or do something else? Please clarify.

2) In 2.1.3: what is "system priority"? This is not explained. Please either add an explanation or a reference to a document that defines it.

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 18 Sep 2016 09:38:57 +0100

Hi,

> On 18 Sep 2016, at 09:11, Jiangyuanlong <[email-masked]> wrote:
> 
> Hi Alexey,
> 

It is important to think about extensibility model now, before you need to start adding it in a rush in the future. You should define the sub-TLV format now (no need to define any sub-TLVs), so that it can be handled in a forward compatible manner in the future.

You also need to describe what should happen in version 001, if a sub-TLV is discovered. Is it an error or should they be just ignored?

> 2) System Priority is a 2-octets value assigned by management or administration policy, the OLT with the numerically lower value of System Priority has the higher priority. We will clarify it in th…

Sounds good.

Best Regards,
Alexey

---

From: Jiangyuanlong <[email-masked]>
Date: Sun, 18 Sep 2016 09:19:02 +0000

Alexey,

Similar to LDP protocol as specified in RFC5036 and RFC4447, we may add the following texts to the document:

The Optional Sub-TLV structure is defined as follows:

    0                   1                   2                   3

    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   | Sub-TLV Type  |    Length     |    Variable Length Value      |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                         Variable Length Value                 |

   |                             "                                 |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   The Optional Sub-TLV Type values will be specified by IANA in "IANA

   Allocations for ICCP MC-PON" [IANA-TODO].

   The Length field is defined as the length of the Sub-TLV Type

   including the Sub-TLV Type field and Length field itself.  Processing of

   the Sub-TLV Types should continue when unknown Sub-TLV Type

parameters are encountered, and they MUST be silently ignored.

BTW, the IANA maybe need to allocate Optional Sub-TLV Type for ICCP MC-PON in future.

Do you think the texts are acceptable?

Thanks,

Yuanlong

-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]]
Sent: Sunday, September 18, 2016 4:39 PM
To: Jiangyuanlong
Cc: The IESG; [email-masked]; Andrew G. Malis; [email-masked]; [email-masked]
Subject: Re: Alexey Melnikov's Discuss on draft-ietf-pals-mc-pon-04: (with DISCUSS)

Hi,

> On 18 Sep 2016, at 09:11, Jiangyuanlong <[email-masked]<mailto:[email-masked]>> wrote:

Sounds good.

Best Regards,

Alexey

> Cc: [email-masked]<mailto:[email-masked]>; Andrew G. Malis; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 18 Sep 2016 11:36:05 +0100

Hi Yuanlong,

> On 18 Sep 2016, at 10:19, Jiangyuanlong <[email-masked]> wrote:
> 
> Alexey,
>  

Yes, this looks reasonable to me. Thank you!