Subject: Usage scenarios

From: <[email-masked]>
Date: Wed, 6 Feb 2002 18:13:39 -0600

Hello all,

As another usage scenario, should we also consider the usage of PANA for a Diameter Mobile IPv6 application?

- A Diameter Mobile IPv6 application will most probably be defined to allow a commercial deployement of Mobile IPv6 (Inter domain roaming)

- But since Mobile IPv6 does not have the equivalent of a Foreign Agent, MIPv6 does not define the equivalent of the MIPv4 Registration Request the user can use in order to send its credential to get authenticated and get access to the local network

- PANA could be a good candidate for the user to send its credentials to the local network and performs authentication. Although I agree that PANA must not handle mobility management; it should co-exist with MIPv6 and allows integration of the authentication and mobility procedures as required in RFC 2977 in order to reduce the initial registration time latency.

The requirement draft states that "Mobile IPv4 registration request message is used as the carrier for authentication extensions (MN-FA  [MIPV4], or MN-AAA [MNAAA]) to receive forwarding service from the foreign agents. In that sense, designing the equivalent of Mobile  IPv4 registration request messages for general network access is the goal of this work, but not defining the equivalent of MN-FA or MN-AAA extensions." and has the following requirement: "PANA MUST NOT handle mobility management of the PaC. But, it MUST be able to co-exist and not interfere with various mobility management protocols, such as Mobile IPv4 [MIPV4], Mobile IPv6 [MIPV6]" so I was thinking that we could add the equivalent of MIPv4 Registration Request for MIPv6 in the usage scenarios draft.

Looking forward for your comments,

Thank you,

Franck

---

From: "Alper Yegin" <[email-masked]>
Date: Wed, 6 Feb 2002 18:11:36 -0800

Frank,

This is a very good scenario.

We can show how to use PANA as the missing piece of Mobile IPv6: an attended
in
the visited network to grant network access first, before the mobile node
registers
with the home agent.

PANA is a better fit than PPP or 802.1x, because by using PANA
we can keep the complete solution (Mobile IPv6 + PANA)
L2 independent.

alper

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, February 06, 2002 4:13 PM
Subject: Usage scenarios

> - A Diameter Mobile IPv6 application will most probably be defined to
allow a commercial deployement of Mobile IPv6 (Inter domain roaming)
>
> - But since Mobile IPv6 does not have the equivalent of a Foreign Agent,
MIPv6 does not define the equivalent of the MIPv4 Registration Request the
user can use in order to send its credential to get authenticated and get
access to the local network
>
> - PANA could be a good candidate for the user to send its credentials to
the local network and performs authentication. Although I agree that PANA
must not handle mobility management; it should co-exist with MIPv6 and
allows integration of the authentication and mobility procedures as required
in RFC 2977 in order to reduce the initial registration time latency.
>
> The requirement draft states that "Mobile IPv4 registration request
message is used as the carrier for authentication extensions (MN-FA
[MIPV4], or MN-AAA [MNAAA]) to receive forwarding service from the foreign
agents. In that sense, designing the equivalent of Mobile  IPv4 registration
request messages for general network access is the goal of this work, but
not defining the equivalent of MN-FA or MN-AAA extensions." and has the
following requirement: "PANA MUST NOT handle mobility management of the PaC.
But, it MUST be able to co-exist and not interfere with various mobility
management protocols, such as Mobile IPv4 [MIPV4], Mobile IPv6 [MIPV6]" so I
was thinking that we could add the equivalent of MIPv4 Registration Request
for MIPv6 in the usage scenarios draft.

---

From: Jacques Caron <[email-masked]>
Date: Thu, 07 Feb 2002 23:46:32 +0100

What about having some way of transporting EAP within the startup phase of 
MIPv6?

[I have to admit my knowledge of MIPv4 is sketchy, and that of MIPv6 
totally inexistent, but it still seems like a better solution to me].

Jacques.

> > Looking forward for your comments,

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

---

From: "Alper Yegin" <[email-masked]>
Date: Thu, 7 Feb 2002 19:42:30 -0800

Jacques,

Mobile IPv6 doesn't have a message to carry EAP between the mobile node
and an attendant in the visited network. This is the gap that can be bridged
by PANA.

alper

> > > As another usage scenario, should we also consider the usage of PANA
for a
> >Diameter Mobile IPv6 application?
> > >

---

From: julien Bournelle <[email-masked]>
Date: Fri, 8 Feb 2002 11:49:11 +0100 (MET)

> and an attendant in the visited network. This is the gap that can be bridged

Hi,
 just to point out that in general Mobile IPv6 doesn't offer a mechanism
to carry authentication information between a mobile node and the AAA
infrastructure. As PANA means "Protocol for carrying Authentication
Network Access", it could be a way to fill in this gap. The PAA could be
the intermediate between the mobile node and the AAA infrastructure.

Julien

---

From: subir Das <[email-masked]>
Date: Tue, 12 Feb 2002 12:06:13 -0500

> As another usage scenario, should we also consider the usage of PANA for a Diameter Mobile IPv6 application?

   PANA does not handle mobility and also does not mandate AAA protocols. So the usage scenario should be generic. In the body you may  mention this for an example.

> - PANA could be a good candidate for the user to send its credentials to the local network and performs authentication. Although I agree that PANA must not handle mobility management; it should co-…

   My take will be not to integrate these two. Network access should be different from mobility management. Moreover,  mobility is not an integral  part to our design. I agree this will minimize the round trip delay but as Hesham mentioned this is purely an architectural issue.

>
>
> The requirement draft states that "Mobile IPv4 registration request message is used as the carrier for authentication extensions (MN-FA  [MIPV4], or MN-AAA [MNAAA]) to receive forwarding service from the foreign agents. In that sense, designing the equivalent of Mobile  IPv4 registration request messages for general network access is the goal of this work, but not defining the equivalent of MN-FA or MN-AAA extensions."

=> I guess this is for ease of understanding

  Subir

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 12 Feb 2002 21:04:19 +0100 (CET)

> - PANA could be a good candidate for the user to send its credentials to the
> local network and performs authentication. Although I agree that PANA must
> not handle mobility management; it should co-exist with MIPv6 and allows
> integration of the authentication and mobility procedures as required in RFC
> 2977 in order to reduce the initial registration time latency.

Frank,

By your reference to 2977 and reducing the latency are you making the argument
that you think it is a requirement that PANA have the ability to
"piggyback" a MIPv6 binding update as part of the authentication exchange?

If you are making this case, it sure sounds like a premature optimization to
me, since there isn't any evidence that saving one roundtrip time for
relatively infrequent movement between service providers. Also, that approach
makes assumptions about business arrangements i.e. to what extent
the home AAA is operated by the same organization as the home agent.

Architecturally (preserving flexibility) it makes a lot of sense to
separate the authentication protocol from the mobility management protocol.

   Erik