Subject: EAPoIP

From: Paal Engelstad <[email-masked]>
Date: Thu, 7 Feb 2002 21:10:15 +0100

James,

> For the other part, we now have EAP over ICMP and EAP over UDP.  (The
> latter called "EAPoIP" for some reason.)  

It is a good point. EAPoIP is not a good name. 

One reason was that I never expected someone would suggest to run an application layer client/server protocol over ICMP. It really undermined the intentions of ICMP from the old days. 

ICMP was intended for error and control messages related to routing. I see no reason why PANA should go in the forefront to undermine fundamental principles established in the IP architecture.

I may address your comment about the name in the next version of the draft. Thansk for reminding me.

Thanks again,
Paal

Both seem to have the
> IP-address-allocated-first problem, unless I'm missing something.
> 
> For what it's worth, I think the deployment scenario considered in
> draft-tsirtsis-eap-over-icmp has problems: how do broadcast and
> multicast work in such a situation?  There's clearly no coordination
> of multicast address assignment between the ISPs, nor any obvious way
> to have the End Node do the right thing with received broadcasts.
> 
> The IARs in section 1.1 of this draft may know which link-layer
> addresses correspond to which authenticated End Nodes for purposes of
> access filtering, but the End Nodes do not have information about the
> other End Nodes, nor necessarily about the IAR(s) to which they
> *didn't* authenticate.
> 
> -- 
> James Carlson, Solaris Networking         <[email-masked]>
> SUN Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
> MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677
> 
>

---

From: "Alper Yegin" <[email-masked]>
Date: Thu, 7 Feb 2002 19:24:28 -0800

Paal,

I disagree with your points....

> One reason was that I never expected someone would suggest to run an
application layer client/server protocol over ICMP. It really undermined the
intentions of ICMP from the old days.

PANA is not application layer. It's functionality is part of overall network
connectivity.

>
> ICMP was intended for error and control messages related to routing. I see
no reason why PANA should go in the forefront to undermine fundamental
principles established in the IP architecture.

Well, this is part of "control". Asking for a router on your link and
learning routers is
control, right? (router discovery). Without authentication/authorization,
this gives you
off-link connectivity. Same goes for PANA. Only after PANA exchange, you can
get
"connected".

alper