Subject: Requirements and PAA Discovery

From: Paal Engelstad <[email-masked]>
Date: Tue, 5 Feb 2002 23:33:40 +0100

Requirements team,

I miss a section dealing with PAA discovery.

If PAA discovery is out of scope of the reqs document, I would at least mention something like:

"The PANA carrier should be able to interwork with different PAA discovery mechanisms." (Preferably something a little less vague.)

I think the PAA discovery discussion shows that PAA discovery may not be straightforward. 

Thus, the WG may want to have a PAA discovery mechanism that can be implemented right away (say DHCP), and then eventually work on an additional PAA discovery mechanism (say anycast/multicast solicitation) that can be used an optional mechanism in future scenarios (say if DHCP is not present). The first discovery mechanism may even be replace by a better one.

Paal

> 
> Fra: [email-masked]
> Dato: 2002/02/05 Tue PM 03:52:07 CET
> Til: IETF-Announce: ;
> CC: [email-masked]
> Tema: I-D ACTION:draft-ietf-pana-requirements-00.txt
> 
> 	Title		: Protocol for Carrying Authentication for Network 
>                           Access (PANA)Requirements and Terminology
> 	Author(s)	: A. Yegin et al.
> 	Filename	: draft-ietf-pana-requirements-00.txt
> 	Pages		: 10
> 	Date		: 04-Feb-02
> 	
> It is expected that future IP devices will have a variety of access 
> technologies to gain network connectivity. Currently there are 
> access-specific mechanisms for providing client information to the 
> network for authentication and authorization purposes. In addition 
> to being limited to specific access medias (e.g., 802.1x for IEEE 
> 802 links), some of these protocols are also sub-optimal (e.g., PPP 
> due to its mandatory framing which is not always needed).
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-pana-requirements-00.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-pana-requirements-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-pana-requirements-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
>

---

From: "Alper Yegin" <[email-masked]>
Date: Tue, 5 Feb 2002 20:27:32 -0800

Paal,

I think this is a good point.

IMO, PaC would either know (e.g., through
a well defined IP address) or discover
the PAA in a network.

PANA proposals must also define the method
used by the PaCs in locating a PAA. We should
add some text to reflect this in the draft.

Comments?

alper

----- Original Message -----
From: "Paal Engelstad" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, February 05, 2002 2:33 PM
Subject: Requirements and PAA Discovery

> "The PANA carrier should be able to interwork with different PAA discovery
mechanisms." (Preferably something a little less vague.)
> Thus, the WG may want to have a PAA discovery mechanism that can be
implemented right away (say DHCP), and then eventually work on an additional
PAA discovery mechanism (say anycast/multicast solicitation) that can be
used an optional mechanism in future scenarios (say if DHCP is not present).
The first discovery mechanism may even be replace by a better one.
> > implementation to automatically retrieve the ASCII version of the

----------------------------------------------------------------------------
----

> --OtherAccess
> Content-Type: Message/External-body;
> access-type="mail-server";
> server="[email-masked]"
>
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> ENCODING mime
> FILE /internet-drafts/draft-ietf-pana-requirements-00.txt
>
> --OtherAccess
> Content-Type: Message/External-body;
> name="draft-ietf-pana-requirements-00.txt";
> site="ftp.ietf.org";
> access-type="anon-ftp";
> directory="internet-drafts"
>
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> --OtherAccess--
>
> ]ÛÞãmënF§0Ú

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 6 Feb 2002 09:15:50 -0500

> add some text to reflect this in the draft.

I agree.  PAA discovery is also mentioned in the charter.

> alper

Yoshihiro Ohba