Subject: RE: Usage scenarios

From: <[email-masked]>
Date: Tue, 12 Feb 2002 17:40:02 -0600

> Frank,
> 
> I think the above performance requirement has some problems.
> 
> Suppose I agree with the need to be able to send the MIPv6 signalling
> message(s) in the same packets as the AAA message(s) for 
> performance reasons,
> then it would seem to also be a valid requirement that the same
> packets also be capable of carrying 
>  - IMAP login and synchronization messages
>  - http requests to get the latest news, stock quotes, etc
>  - etc
> 
> Where would this lead us?

Eric, perhaps you're missing the point that we are not proposing anything new but simply support a requirement that has been deemed valid by several parties, to the extent that MIPv4 application developed a solution for it. Whether we want to create or not new requirements that will lead to the scenarios you mention is out of scope.  

> I think the problem with these types of optimizations that 
> you are suggesting
> is that it is a very slippery slope and we don't have 
> real-world experience
> saying that taking the first step down that slippery slope is 
> worth the
> effort (and risk of sliding down).

Again, there have been several parties that agreed to the requirements and, unless something new has happened in the meanwhile, I believe that this type of optimization is still needed. Not every party may like it, but I do not see any good concrete reason why it should not be possible to support it.

---

From: Erik Nordmark <[email-masked]>
Date: Wed, 13 Feb 2002 00:51:22 +0100 (CET)

> Again, there have been several parties that agreed to the requirements and,
> unless something new has happened in the meanwhile, I believe that this type
> of optimization is still needed. Not every party may like it, but I do not
> see any good concrete reason why it should not be possible to support it.

The new part is probably that AAA WG is having a hard time finishing
the protocols that support all these options and different behaviors.

But in any case, it is largely up to the PANA WG to decide what they think are
the key requirements to solve the problem that needs to be solved.

   Erik

---

From: "Dr. Subrata Goswami" <[email-masked]>
Date: Tue, 12 Feb 2002 16:04:18 -0800

-----Original Message-----
From: Erik Nordmark [mailto:[email-masked]]
Sent: Tuesday, February 12, 2002 3:51 PM
To: [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: RE: Usage scenarios

But in any case, it is largely up to the PANA WG to decide what they think
are
the key requirements to solve the problem that needs to be solved.

   Erik