Subject: Performance requirements

From: Paal Engelstad <[email-masked]>
Date: Thu, 21 Feb 2002 22:50:09 +0100

Reqs team,

I have gone through the reqs document over again, I wonder if also the Performance requirements need some more detailing. 

It seems like a lot of people on the list require a protocol that is "efficient", that allows "frequent end node movement" without disruption, etc. I think we should determine more quantitively what are the performance requirements are before we start designing the protocol. The sooner, the better.

Later we might get into a ICMP vs. UDP discussion, or a secret-key vs. public-key discussion. With more detailed performance requirements, it will be easier to handle these discussions.

Paal

> At 12:18 08/02/2002, George Tsirtsis wrote:
> >Paal,
> >
> >You keep ignoring maybe the most important reason we are here and that is
> >straight forward network access. You are 

<...>

try :-) you will realize that
> using
> >EAPoverUDP to get basic internet access is too inefficient and it does not

<...>

> >shorts of scenarios, including wide are wireless and potentially frequently
> >due to end node movement. For this kind of fundamental function it is
> >prudent to go lower in the networking stack
>

---

From: Reinaldo Penno <[email-masked]>
Date: Thu, 21 Feb 2002 15:44:16 -0800 (PST)

Hello Paal,

I totally agree we need this scoped out better. 

But as I said on the last IETF meeting. Saying that a
protocol needs to be "efficient" is the same thing as
saying that you need to go from San Fracisco to Tokyo
"fast" (it depends on how much money you have, if
stopping in Hawaii to catch some waves has greater
priority, if you are afraid of flying and prefer some
CruiseLine, etc).

We need to find out the constraints that determine
what this efficient means. Does it need congestion
avoidance? Does it need retrasmission? Does it need
hashing? Given these constraints we will find out what
efficient means.

Maybe some of the requirements right of the bat take
some protocols/solutions out of the list.

regards,

Reinaldo

--- Paal Engelstad <[email-masked]> wrote:
> Reqs team,
> 
> I have gone through the reqs document over again, I
> wonder if also the Performance requirements need
> some more detailing. 
> 
> It seems like a lot of people on the list require a
> protocol that is "efficient", that allows "frequent
> end node movement" without disruption, etc. I think
> we should determine more quantitively what are the
> performance requirements are before we start
> designing the protocol. The sooner, the better.
> 
> Later we might get into a ICMP vs. UDP discussion,
> or a secret-key vs. public-key discussion. With more
> detailed performance requirements, it will be easier
> to handle these discussions.
> 
> Paal
> 
> 

__________________________________________________
Do You Yahoo!?
Yahoo! Sports - Coverage of the 2002 Olympic Games
http://sports.yahoo.com