Subject: Question for terminal power off indication

From: Xin Chen <[email-masked]>
Date: Tue, 10 Sep 2002 11:26:58 +0100

Dear all,
 
 I am a starter of PPP and related extentions. I have a question based on
the case below,
 
An authenticator in a WLAN link uses EAP to authenticate terminals. The
authenticator uses AAA (radius or Diameter) to communicate with
authentication server. The authentication server is not only providing
authentication service but registration services. Once the authentication is
successful, the terminal will be considered registered with the network, and
services can be provided.
 
And the registration service of the authentication server needs to know the
user's status in the network (registered or not). Therefore, it relys on
some sort of information reported by the authenticator which is close to the
terminals
 
When the terminal powers off, we want the authenticator to detect this and
report to the authenitcation server that user is not registered anymore
(becuase user has turned off its terminal).
 
The question is does the current WLAN technologies and EAP protocol support
this operation. 
 
Is this within PANA scope, or just link layer technology issue?
 
Regards
 
Xin Chen
Mobile Network Architecture
Fujitsu Laboratories of Europe LTD
Tel: +44 (0) 2086064453
Mobile: +44 (0)7775741020

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Tue, 10 Sep 2002 15:12:21 -0700

Message

Based on the requirements, PANA will provide a "disconnect"
message which can be sent by either PAA or PaC. If the
terminal (PaC) has a chance to send this explicit message,
it can "de-register" directly. Otherwise, the network would
have to rely on other lower-layer indicators (link down, etc.),
or a timeout.

alper

  ----- Original Message ----- 
  From: Xin Chen 
  To: [email-masked]' 
  Sent: Tuesday, September 10, 2002 3:26 AM
  Subject: Question for terminal power off indication

  Dear all,
   
   I am a starter of PPP and related extentions. I have a question based on the case below,
   
  An authenticator in a WLAN link uses EAP to authenticate terminals. The authenticator uses AAA (radius or Diameter) to communicate with authentication server. The authentication server is not only providing authentication service but registration services. Once the authentication is successful, the terminal will be considered registered with the network, and services can be provided.
   
  And the registration service of the authentication server needs to know the user's status in the network (registered or not). Therefore, it relys on some sort of information reported by the authenticator which is close to the terminals
   
  When the terminal powers off, we want the authenticator to detect this and report to the authenitcation server that user is not registered anymore (becuase user has turned off its terminal).
   
  The question is does the current WLAN technologies and EAP protocol support this operation. 

  Regards

  Xin Chen