Subject: Requirement on the PAA-EP protocol

From: "Alper E. YEGIN" <[email-masked]>
Date: Wed, 25 Sep 2002 13:02:42 -0700

During the discussion of separating PAA from EP,
a number of candidate protocols were mentioned
for the required communication between these two
entities. 

Two essential features that need to be satisfied by
such a protocol are:

- one-to-many relation between the PAA and EPs.
Note that one PAA might have to communicate with
several EPs once a PaC is authenticated. The 
provisioning protocol must be able to handle this
one-to-many communication.

- PAA must be able to "push" the provisioning
information to EPs, without any of the EPs "pulling"
it. Since PANA exchange takes place between PaC
and PAA, EPs are unlikely to be aware of it. The
provisioning protocol must be able to "publish" 
required information to the EPs even when this information
wasn't requested by them.

So, which one(s) of the protocols that are currently
available can meet these requirements? Diameter, Radius,
SNMP, Cops, ... ? It's highly desirable to "identify" an
existing protocol for this purpose, rather than "develop"
a new one..

alper

---

From: Reinaldo Penno <[email-masked]>
Date: Thu, 26 Sep 2002 20:46:28 -0700 (PDT)

Hello Alper,

IMO we should make a formal list of requirements and
try to match against the possible candidates...It
might be fast and only one protocol matches the need.

On the other hand there is a possibility that more
than one protocol meets the requirements and some
people prefer one over the other. Then we would need
protocol advocates...

regards,

Reinaldo

--- "Alper E. YEGIN" <[email-masked]> wrote:
> a number of candidate protocols were menti

__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Fri, 27 Sep 2002 14:24:40 -0700

Hi Reinaldo,

> people prefer one over the other. Then we would need

Completely agree! The purpose of my message was not
to have a thorough evaluation of solutions, but to get a quick idea on
if/how these additional requirements can be satisfied. These
two are somewhat result of how we are designing PANA.

alper