Subject: RE: "new" issue / Event Notification

From: <[email-masked]>
Date: Fri, 16 May 2003 10:06:42 +0300

This is a tradeoff in deployment point of view. If the 
PAA-EP protocol doesn't implement it, then the EP has to 
be extended to support PANA-Discover message. In the end
PAA-EP communication must support PaC notification. So, 
there is a requirement for the notification but not for
the protocol. Makes things complicated. Anyway, with a
PAA-EP protocol that support PaC notification, there has
to be an interface between PAA and the protocol.
- Dan

> -----Original Message-----
> From: ext Alper Yegin [mailto:[email-masked]]
> Sent: 15 May, 2003 21:31
> To: [email-masked]; Forsberg Dan (NRC/Helsinki)
> Cc: [email-masked]
> Subject: Re: "new" issue / Event Notification
> 
> 
> >> For now we can keep the EP's ability to send PANA_discover message.
> >> We can mark it as an optional feature which can be 
> replaced by a PAA-EP
> >> protocol message in any deployment. That way, even if a 
> specific PAA-EP
> >> protocol does not know how to trigger the PAA, the 
> deployment can rely on
> >> this message as a substitute.
> > 
> > from this standpoint, is 'event notification' (pull model) still a
> > requirement for the PAA-EP protocol ?
> 
> No, it is not, because PANA protocol offers a substitute for that.
> 
> Alper
> 
> 
>

---

From: [email-masked]
Date: Fri, 16 May 2003 10:37:51 +0200

[email-masked] wrote:

> the protocol. Makes things complicated. 

I must admit that I feel confused here. traditionally the needs for a 
given interface communication are the requirements for the protocol on 
this interface.

> Anyway, with a

my naive personal opinion on this subject is:
since there will finally be a distinct protocol for the PAA-EP 
communication, it would be much better if it supports the pull model, 
otherwise the EP will have to support both PANA and 'PAA-EP' protocol 
stacks (I agree it's possible). hence, it should be a requirement.

btw, this requirement concerning the 'pull model' is not crucial since 
most of the candidate protocols for the PAA-EP interface support this 
feature.

> - Dan

thanks,
yacine