Subject: RE: Second shot on message formatting.

From: <[email-masked]>
Date: Thu, 8 May 2003 09:05:40 +0300

Issue10 is related to message formatting. 
http://danforsberg.info:8080/pana-issues/issue10
- Dan

-----Original Message-----
From: ext [mailto:[email-masked]]
Sent: 07 May, 2003 12:32
To: [email-masked]
Subject: Second shot on message formatting.

Hi,

Since there is not much progress, let me give you the second shot for the message formatting :).

Changes:
 - Removed Application-Id field from the header for 
   now (not enough support for this or Diameter compatibility).
 - Added PANA-Failure-Request/Answer messages (was missing 
   in the previous version).
 - Merged PANA-Disconnect-Request/Answer and 
   PANA-Revocation-Request/Answer messages to 
   PANA-Termination-Request/Answer messages. This is because
   the messages were similar to each other and contain the 
   Result-Code AVP, which can be used to differentiate 
   disconnect and revocation.

Br,
- Dan
 <<draft-ietf-pana-pana-00-sec9b.txt>>

---

From: <[email-masked]>
Date: Fri, 9 May 2003 16:36:20 +0300

Alper,

Comments inline.

> From: ext Alper Yegin [mailto:[email-masked]]
> Sent: 09 May, 2003 02:28
> To: Forsberg Dan (NRC/Helsinki); [email-masked]
> Subject: Re: Second shot on message formatting.
> 
> 
> Hi Dan,
> 
> 
> Here are my comments:
> 
> - inclusion of session id is discussed on another thread. 
> Once we figure out
> how it will be used, we can come back and adjust the message formats.
> 

Ok.

> -add/remove device id: what are the scenarios we'll use these AVPs? We
> should discuss them on another thread, and come back and 
> design the message
> format. We should identify what we want to do, and what we 
> don't want/mean
> to do with these extensions...
> 

This is issue5: 
http://danforsberg.info:8080/pana-issues/issue5

> -  can we fold device-type and device-data type AVPs into one? This
> particular AVP's data part can have a field "address type" 
> which can be: 1-
> IPv6 address, 2- IPv4 address, 3- Link-layer address. This is 
> followed by
> "address" field. I think we can get away without having to 
> enumerate every
> link-layer. Please see section 4.6.1 of rfc2461.
> 

Yep. I'll fix that.

> - I'd say we should not mandate DIAMETER style session IDs.
> We can recommend it though.

I reopened the issue6:
http://danforsberg.info:8080/pana-issues/issue6

> 
> Alper
> 
> 
> On 5/7/03 2:32 AM, "[email-masked]" 
> <[email-masked]> wrote:
> 
> > Hi,
> > 
> > Since there is not much progress, let me give you the 
> second shot for the
> > message formatting :).
> > 
> > Changes: