Subject: RE: [Pana] PAA changed

From: [email-masked]
Date: Tue, 30 Sep 2003 12:30:42 +0300

It's an open question and for further study. Relates 
to the mobility issue number 7. We may even consider 
this as out of the scope of PANA.

- Dan 

-----Original Message-----
From: ext Srinath [mailto:[email-masked]]
Sent: 30 September, 2003 11:46
To: [email-masked]
Subject: [Pana] PAA changed

Hello,

In the PaC state machine there is a transition from
OPEN to DISC if the PAA has changed . It is not very
clear how the PaC knows that the PAA has changed . 

Does the old PAA explicitly inform the PaC of the
change of PAA - with new address ? (in this case it
doesnt have to multicast the DISCOVER message) 
or 
does the PaC assume the PAA has changed once it doesnt
get any response from the PAA ?(in this case DISCOVER
has to be multicast) 

Thank you,
Srinath

________________________________________________________________________
Yahoo! India Matrimony: Find your partner online.
Go to http://yahoo.shaadi.com

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 30 Sep 2003 08:59:59 -0700

I tend to agree with Dan that we might not have to fully describe
PAA_change stuff in the state machine for the following reason.

It seems to be a bit weird to define a transition from OPEN to DISC
when the PAA has changed.  This is because the PaC had not really been
authorized by the new PAA before the PAA changes.  In that sense, it
should be a transition from OFFLINE to DISC instead of OPEN to DISC.

Having said that, I am wondering that we really might not need to
define the "PAA_changed" variable in the PaC state machine.  An
implementation can simply reset the state to OFFLINE with setting the
SESS_RESUM variable when the PAA changes and can send an "Auth user"
signal to launch a PANA_Reauth exchange, as if a new PANA session with
the new PAA were created and started but with re-using some states
shared with the old PAA.

So I would like to suggest replacing the event and action for
transition from OPEN state to DISC state

From:

"If PAA_changed OR SIGNAL:EAP reauth 
 -----------------------------------
 Tx: PANA-PAA-Discover; If PAA changed set SESS_RESUM"

To:

"If SIGNAL:EAP reauth 
 ---------------------
 Tx: PANA-PAA-Discover"

Yoshihiro Ohba

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 30 Sep 2003 08:59:59 -0700

From:

To:

"If SIGNAL:EAP reauth 
 ---------------------
 Tx: PANA-PAA-Discover"

Yoshihiro Ohba