Subject: New [issue25] Service Profile names

From: <[email-masked]>
Date: Wed, 10 Sep 2003 14:22:14 +0300

New submission from Dan Forsberg <[email-masked]>:

> From Reinaldo Penno:
<klip>
> 3) In section 4.2, paragraph 3 it is mentioned that
> "The result does not depend on which PAA PaC chooses.
> By default PaC chooses the PAA that sent the first
> reponse"
> 
> This is the DHCP approach. Where all servers are
> equally good. 
> 
> I would propose that we think about incorporating
> something of the PPPoE protocol that is widespread,
> since PANA is more related to the PPPoE model.
> 
> In the response of the Discovery message each PPPoE
> server include all the Service Profile (names) it
> supports (the definition is loose on purpose).
> Nowadays it is usually a list of ISPs or bandwidth
> packages a user can choose.
> 
> I would argue that in the case of PANA (and specially
> in the case of NAP vs ISP authentication), PAA servers
> might support a very different set of attributes and a
> PaC might prefer one over the other if it new of each
> choices.
> 
> We could have a AVP in PANA for that purpose in the
> answer to the Discovery message. it seems very simple,
> could be optional and will provide a crucial
> functionality for people that use PPPoE to migrate to
> PANA.

Yoshihiro Ohba:

When we dicussed NAP and ISP separate authentication, I think the
assumption is that there is a single PAA the PaC sees, and the NAI is
used to choose a particular ISP.  Why do you need multiple PAAs to
support NAP and ISP separate authentication?

----------
category: Technical
document: draft-ietf-pana-pana-xx.txt
messages: 80
nosy: dforsber
priority: May Fix
status: Pending
title: Service Profile names
________________________________________________
PANA Issues <[email-masked]>
http://danforsberg.info:8080/pana-issues/issue25
________________________________________________

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 11 Sep 2003 10:53:53 -0700

I think more about this issue and now I tend to agree that the
proposed functionality might be useful even if there is one PAA on an
IP link.  First, there may be multiple IP links available at a
physical location (e.g., a hotspot).  In such a case, if
PANA-Start-Request messages sent by PAAs contain some profile
information, a PaC can use the information to choose an appropriate IP
link to start authentication.  Second, even if there is only one IP
link in a physical location and one PAA on the link, a PaC can use the
information to determine whether it starts authentication on the IP
link or not.

Yoshihiro Ohba

---

From: Alper Yegin <[email-masked]>
Date: Thu, 25 Sep 2003 10:50:16 -0700

This piece of data sounds informative and potentially useful. I presume if
we wanted to have this support, we'd define a new AVP that carries some sort
of an "identifier" and optionally carried in PANA-Start-Request. Do we have
to define the format of the data this AVP embeds? What type of information
would the data be carrying?

Alper