Subject: [Pana] PaC statemachine

From: Srinath <[email-masked]>
Date: Mon, 29 Sep 2003 13:13:21 +0100 (BST)

Hello all,

I am a student working under Hannes Tschofenig on 
PANA. I have a question on the proposed PaC
statemachine.

-> In the PaC statemachine , authentication failure
scenario is not very clear. What happens in WAIT_EAP
state if RX :EAP-Failure AND 1stEAP=FAILURE AND
2ndEAP=FAILURE ? 

I guess there should be a state AUTH_FAILED in PaC and
from the WAIT_PAA , there should be a state transition
to AUTH_FAILED if 
RX :EAP-Failure AND 1stEAP=FAILURE AND 2ndEAP=FAILURE

Regards,
Srinath Thiruvengadam

________________________________________________________________________
Yahoo! India Matrimony: Find your partner online.
Go to http://yahoo.shaadi.com

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: [email-masked]
Date: Mon, 29 Sep 2003 15:42:14 +0300

Hi Srinath,

You're right that PANA-Bind-Request message contains the EAP Payload AVP, which was not shown in the texts as in the other texts. Anyway, the case where both EAP methods fail the transition is to state OFFLINE. Why would you need to have a new state? For retransmission purposes I wouldn't do it.

I'll fix the text for next version of the PaC state machine. Thanks for input.

Br,
- Dan

-----Original Message-----
From: ext Srinath [mailto:[email-masked]]
Sent: 29 September, 2003 15:13
To: [email-masked]
Subject: [Pana] PaC statemachine

Hello all,

Regards,
Srinath Thiruvengadam

---

From: [email-masked]
Date: Mon, 29 Sep 2003 15:42:14 +0300

Hi Srinath,

Br,
- Dan

-----Original Message-----
From: ext Srinath [mailto:[email-masked]]
Sent: 29 September, 2003 15:13
To: [email-masked]
Subject: [Pana] PaC statemachine

Hello all,

Regards,
Srinath Thiruvengadam