Subject: [Pana] [issue28] PaC and PAA state machines

From: [email-masked]
Date: Fri, 26 Sep 2003 13:42:54 +0300

Dan Forsberg <[email-masked]> added the comment:

New version (v0.2) of PAA state machine.
See file: PAA_State_Machine_v0.2.jpg
- Added variables
- Changes based on Y.Ohba's comments
- Removed path between WAIT_EAP and OPEN states
- Does not contain error handling
- Does not contain timer handling

________________________________________________
PANA Issues <[email-masked]>
http://danforsberg.info:8080/pana-issues/issue28
________________________________________________

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: [email-masked]
Date: Mon, 29 Sep 2003 10:33:22 +0300

New version (v0.3) of PaC state machine.
See file: PaC_State_Machine_v0.3.jpg
- More explicit handling of SESS_RESUM variable
- Added new variable ACCEPT_2ND_EAP to clarify
  the state machine

---

From: [email-masked]
Date: Mon, 29 Sep 2003 10:33:22 +0300

---

From: [email-masked]
Date: Mon, 29 Sep 2003 10:35:30 +0300

Hi Yoshihiro,

I created v0.3 of PaC state machine. The F-flag means no 2nd EAP round (see your 2nd comment). I added the variable to clarify the state machine. 

- Dan

-----Original Message-----
From: ext Yoshihiro Ohba [mailto:[email-masked]]
Sent: 27 September, 2003 03:10
To: Forsberg Dan (NRC/Helsinki)
Cc: [email-masked]
Subject: Re: [Pana] [issue28] PaC and PAA state machines

Hi Dan,

This version looks nicer.  I have two comments on the PaC state
machine.

o In the transition from DISC state to WAIT_PAA state, what does "(set
  SET_RESUM?)" mean? (is it doing conditional check or setting a
  varible?)  Also, "Rx:" and "Tx:" are missing for the event and action
  for this transition, respectively.

o According to the PANA specification, when PAA offers the opportunity
  for the 2nd EAP authentication by setting the F-flag in
  PANA-Bind-Request, PaC can decline the offer by unsetting the F-flag
  in PANA-Bind-Answer.  I think this is not supported in the current
  version of PAC state machine.  In order to support it, I think an
  additional variable such as ACCEPT_2ND_EAP (Unset(0), Set(1)) is
  needed.  By using this variable, the transition condition from
  WAIT_PAA state to 2ND_EAP state can be written such as:

  "Rx: 1st PANA-Bind-Request,(EAP Success/Failure),!F-flag 
   AND ACCEPT_2ND_EAP".

Yoshihiro Ohba

---

From: [email-masked]
Date: Mon, 29 Sep 2003 10:35:30 +0300

Hi Yoshihiro,

- Dan

-----Original Message-----
From: ext Yoshihiro Ohba [mailto:[email-masked]]
Sent: 27 September, 2003 03:10
To: Forsberg Dan (NRC/Helsinki)
Cc: [email-masked]
Subject: Re: [Pana] [issue28] PaC and PAA state machines

Hi Dan,

Yoshihiro Ohba