Subject: [Pana] Editorial comments on 4.2

From: [email-masked]
Date: Thu, 6 May 2004 11:01:33 +0300

Some editorial comments for section 4.2. About the last change I'm not 100% sure, but at least something more explicit is needed into the text.
- Dan

Editorial:
4.2.
Change:
"that sent the that sent the"
to:
"that sent the"

Change:
"Protection-Capability and Post-PANA-Address-Configuration AVP AVPs MAY"
To:
"Protection-Capability and Post-PANA-Address-Configuration AVPs MAY"

Change:
"It is possible that both PAA and PaC initiate the discovery and initial handshake procedure at the same time, i.e., the PAA sends a PANA-Start-Request message while the PaC sends a PANA-PAA-Discover message. To resolve the race condition, the PAA SHOULD silently discard the PANA-PAA-Discover message received from the PaC after it has sent a PANA-Start-Request message with creating a state for the PaC."
To:
"It is possible that both PAA and PaC initiate the discovery and initial handshake procedure at the same time, i.e., the PAA sends a PANA-Start-Request message while the PaC sends a PANA-PAA-Discover message. To resolve the race condition, the PAA SHOULD silently discard the PANA-PAA-Discover message received from the PaC after it has sent a PANA-Start-Request message with creating a state (i.e. no Cookie AVP included) for the PaC. In this case PAA will retransmit PANA-Start-Request based on a timer, if PaC doesn't respond in time (message was lost for example). If PAA had sent stateless PANA-Start-Request message (i.e. Cookie AVP was included), then it SHOULD answer to the PANA-PAA-Discover message."

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 06 May 2004 05:39:34 -0700

Hi Dan,

> "that sent the that sent the"

OK.

> "Protection-Capability and Post-PANA-Address-Configuration AVPs MAY"

OK.

> "It is possible that both PAA and PaC initiate the discovery and initial handshake procedure at the same time, i.e., the PAA sends a PANA-Start-Request message while the PaC sends a PANA-PAA-Discov…

Yes, your text is better.

I reflected all of them to the manuscript.  I will produce -04c snapshot
shortly.

Thank you.

Yoshihiro Ohba

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 06 May 2004 05:39:34 -0700

Hi Dan,

OK.

OK.

Thank you.

Yoshihiro Ohba