Subject: Re: [Pana] Proposed text for issue 104

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 30 Sep 2004 21:48:26 -0400

On Tue, Aug 31, 2004 at 04:57:54PM -0700, Alper Yegin wrote:
> 
> [2] Section 3.1:
> 
> Change:
> 
>          <-----     PANA-Bind-Request[Session-Id, EAP{Success},
>                          Device-Id, Lifetime, Protection-Cap., Key-Id,
> MAC]
> 
> To:
> 
>          <-----     PANA-Bind-Request[Session-Id, EAP{Success},
>                          Device-Id, IP-Address, Lifetime,
> Protection-Cap.,
>                          Key-Id, MAC]

[This is not related to issue 104, but I realized that PPAC AVP is
missing here.  I will add PPAC AVP.]

> 
> [5] Section 4.1.7:
> 
> Change:
> 
>    o  When a device identifier of the communication peer is bound to the
>       PANA session, it matches the device identifier carried in MAC and/
>       or IP header(s), or other auxiliary indetifier provided by the
>       lower-layers (e.g., circuit ID).
> 
> 
> To:
> 
>    o  When a device identifier of the PaC is bound to the
>       PANA session, it matches the device identifier carried in MAC or
>       or IP header, or other locally-significant identifier provided by 
>       the lower-layers (e.g., circuit ID) unless the message is 
>       a PANA-Update-Request with IP-Address AVP.
> 
> 
> Change:
> 
>    o  When a Device-Id AVP is included, the AVP is valid if the device
>       identifier type contained in the AVP is supported (this check is
>       for both PaC and PAA) and is the requested one (this check is for
>       PAA only) and the device identifier value contained in the AVP
>       matches the value extracted from the lower-layer encapsulation
>       header corresponding to the device identifier type contained in
>       the AVP.  Note that a Device-Id AVP carries the PaC's device
>       identifier in messages from PaC to PAA and PAA's device identifier
>       in messages from PAA to PaC.
> 
> To:
> 
> 
>    o  When a Device-Id AVP is included, the AVP is valid if the device
>       identifier type contained in the AVP is supported (check performed
>       by both PaC and PAA) and is the requested one (check performed by
>       PAA only) and the device identifier value contained in the AVP
>       matches the value extracted from the lower-layer encapsulation
>       header corresponding to the device identifier type contained in
>       the AVP (check performed by PAA only).  Note that a Device-Id AVP
>       carries the PaC's device identifier in messages from PaC to PAA  
>       and EP(s)' device identifier in messages from PAA to PaC.
> 
> Add:
> 
>    o  When the IP-Address AVP is received in a message from the PAA,
>       the AVP is valid if the IP address matches the source address
>       in the IP header.

An IP-Address AVP is carried in a message also from the PaC (i.e., PUR).
How about the following?

"
     o When the IP-Address AVP is received in a message, the AVP is
       valid if the IP address matches the source address
       in the IP header.
"

> 
> [10] Section 6.4.7:
> 
> Change:
> 
> 6.4.7  PANA-Bind-Request (PBR)
> 
>    PANA-Bind-Request (PBR) is sent by the PAA to the PaC.
> 
>          PANA-Bind-Request ::= < PANA-Header: 4, REQ [SEP] [NAP] >
>                        < Session-Id >
>                        { Result-Code }
>                        { PPAC }
>                        [ EAP-Payload ]
>                        [ Device-Id ]
>                        [ Session-Lifetime ]
>                        [ Protection-Capability ]
>                        [ Key-Id ]
>                     *  [ EP-Device-Id ]
>                     *  [ AVP ]
>                    0*1 < MAC >
> 
> 
> To:
> 
> 6.4.7  PANA-Bind-Request (PBR)
> 
>    PANA-Bind-Request (PBR) is sent by the PAA to the PaC.
> 
>          PANA-Bind-Request ::= < PANA-Header: 4, REQ [SEP] [NAP] >
>                        < Session-Id >
>                        { Result-Code }
>                        { PPAC }
>                        { IP-Address }
>                        [ EAP-Payload ]
>                        [ Device-Id ]
>                        [ Session-Lifetime ]
>                        [ Protection-Capability ]
>                        [ Key-Id ]
>                     *  [ Device-Id ]
>                     *  [ AVP ]
>                    0*1 < MAC >

Device-Id AVP appears twice.   I will remove the first one.

Yoshihiro Ohba

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Alper Yegin <[email-masked]>
Date: Thu, 02 Sep 2004 10:33:42 -0700

These look good, thanks.

Alper

> -----Original Message-----
> From: Yoshihiro Ohba [mailto:[email-masked]]
> Sent: Thursday, September 30, 2004 6:48 PM
> To: Alper Yegin
> Cc: 'Yoshihiro Ohba'; [email-masked]
> Subject: Re: [Pana] Proposed text for issue 104
>