Subject: [PANRG] Remind me again. What IS Path Aware Networking? :-)

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 3 Jun 2020 20:43:19 -0500

During our call today, we talked (if I understood correctly) about having
one place where we loosely describe what Path Aware Networking is (since we
have at least three definitions in the charter, research-questions, and
what-not-to-do), and pointing to that one place everywhere else that sort
of has a description.

I believe the action was that Spencer, Brian, Theresa, and Gorry would
huddle and try to come up with a description that we think is good enough
to show the working group.

Did I have that right?

Best,

Spencer

---

From: Theresa Enghardt <[email-masked]>
Date: Wed, 3 Jun 2020 19:47:03 -0700

Hi,

On 03.06.20 18:43, Spencer Dawkins at IETF wrote:
> During our call today, we talked (if I understood correctly) about
> having one place where we loosely describe what Path Aware Networking
> is (since we have at least three definitions in the charter,
> research-questions, and what-not-to-do), and pointing to that one
> place everywhere else that sort of has a description. 
>
> huddle and try to come up with a description that we think is good
> enough to show the working group. 
>
> Did I have that right?

Without trying to sign him up for anything, I think Cyrill's name was
mentioned, too.

Otherwise, this matches what I recall.

As far as I'm concerned, feel free to just send a doodle link.

Best,
Theresa

---

From: Tim Chown <[email-masked]>
Date: Thu, 4 Jun 2020 13:20:22 +0100

> On 4 Jun 2020, at 02:43, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> During our call today, we talked (if I understood correctly) about having one place where we loosely describe what Path Aware Networking is (since we have at least three definitions in the charter, research-questions, and what-not-to-do), and pointing to that one place everywhere else that sort of has a description. 
> 
> I believe the action was that Spencer, Brian, Theresa, and Gorry would huddle and try to come up with a description that we think is good enough to show the working group. 
> 
> Did I have that right?

I couldn’t make the virtual meeting due to its timing in BST, but this would be very useful.  I had no idea that panrg included certain areas of interest.

Tim

---

From: <[email-masked]>
Date: Thu, 4 Jun 2020 12:42:47 +0000

Hi Spencer, all,

As you are there, I reiterate a comment that I made when reviewing some of the RG documents: As networking is about manipulating paths, I do think something is “weird” with the pan term.

I don’t think it is late to use a new term rather than continuing to use this confusing one.

“Collaborative Networking” (prefixed with “host-aware” or “application-aware” if needed) would be a better name IMO to reflect the idea of:

(1)     networks exposing some services/features/information and the host/application make use of the information to infer the paths (including services) that will be used to forward specific flows.

(2)     Applications/hosts including signals that will be used by on-path nodes to forward/process packets.

Cheers,
Med

De : Panrg [mailto:[email-masked]] De la part de Spencer Dawkins at IETF
Envoyé : jeudi 4 juin 2020 03:43
À : [email-masked]
Objet : [PANRG] Remind me again. What IS Path Aware Networking? :-)

Did I have that right?

Best,

Spencer