Subject: [PANRG] PANRG@IETF111: Call for presentations

From: Jen Linkova <[email-masked]>
Date: Wed, 16 Jun 2021 08:50:48 +1000

Hello,

The chairs have requested a 60 mins slot for PANRG at IETF111.
We are looking for the agenda items so if you'd like to present please
send your request to [email-masked].

IETF 111 starts Monday, 26 July and runs through Friday afternoon, 30
July. Sessions will run from 12:00-18:00 PDT (19:00-01:00 UTC) each
day.
-- 
SY, Jen Linkova aka Furry

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 16 Jun 2021 07:16:44 -0500

Dear PANRG,

> send your request to [email-masked].

This isn't quite a request for a slot from me (that might still happen, on
a related topic), but Lorenzo Colitti and Tommy Pauly gave an excellent
presentation in INTAREA at IETF 110 (slides at
https://datatracker.ietf.org/meeting/110/materials/slides-110-intarea-per-app-networking-considerations-01)
on **cnsiderations for** application aware networking (and I'm already
seeing specific proposals for APN on agenda requests for IETF 111, so it
will be back).

I thought this presentation had considerable overlap with the two hardest
problems that we've identified in our work, and asked

   - *is that engineering or research?* people should be crisp on whether
   this is ready for engineering yet. I recognize that people are engineering
   solutions in this space now, that's not my question. PANRG (in the IRTF)
   has been looking at impediments to deployment in the past (in
   https://datatracker.ietf.org/doc/draft-irtf-panrg-what-not-to-do/), and
   trust (whether hosts trusting the network or the network trusting hosts)
   has been the one consideration that seems intractable.

Tommy: answered

   - 3 different legs: one belongs to IAB for the overall architecture, *one
   is still research in solution space, that's trust between those nodes*;
   and here: what are we doing today? tools we have, ways we think are bad to
   use those tools

Do the chairs have any objection to my asking Lorenzo and Tommy (cc:-ed) to
talk about this in PANRG at IETF 111? I know APN isn't particularly in
scope for us, but IRTF RGs do have some latitude that IETF WGs don't have,
by design.

Best,

Spencer

---

From: Jen Linkova <[email-masked]>
Date: Thu, 17 Jun 2021 09:40:49 +1000

On Wed, Jun 16, 2021 at 10:17 PM Spencer Dawkins at IETF
<[email-masked]> wrote:
> This isn't quite a request for a slot from me (that might still happen, on a related topic),
>but Lorenzo Colitti and Tommy Pauly gave an excellent presentation in INTAREA at IETF 110 (slides at https://datatracker.ietf.org/meeting/110/materials/slides-110-intarea-per-app-networking-considerations-01) on *cnsiderations for* application aware networking (and I'm already seeing specific proposals for APN on agenda requests for IETF 111, so it will be back).
>
> I thought this presentation had considerable overlap with the two hardest problems that we've identified in our work, and asked
>
> is that engineering or research? people should be crisp on whether this is ready for engineering yet. I recognize that people are engineering solutions in this space now, that's not my question. PANRG (in the IRTF) has been looking at impediments to deployment in the past (in https://datatracker.ietf.org/doc/draft-irtf-panrg-what-not-to-do/), and trust (whether hosts trusting the network or the network trusting hosts) has been the one consideration that seems intractable.
>
> Tommy: answered
>
> 3 different legs: one belongs to IAB for the overall architecture, one is still research in solution space, that's trust between those nodes; and here: what are we doing today? tools we have, ways we think are bad to use those tools
>
> Do the chairs have any objection to my asking Lorenzo and Tommy (cc:-ed) to talk about this in PANRG at IETF 111?

[the chair hat's on] I think it's a brilliant idea, thanks a lot for
suggesting this, Spencer!

> I know APN isn't particularly in scope for us, but IRTF RGs do have some latitude that IETF WGs don't have, by design.

Well, I'd say that APN is often perceived as having some overlap with
the PAN problem space...

---

From: Colin Perkins <[email-masked]>
Date: Thu, 17 Jun 2021 12:43:49 +0100

> On 16 Jun 2021, at 13:16, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Dear PANRG, 
> 
> On Tue, Jun 15, 2021 at 5:51 PM Jen Linkova <[email-masked] <mailto:[email-masked]>> wrote:
> Hello,
> 
> send your request to [email-masked] <mailto:[email-masked]>.
> 
> This isn't quite a request for a slot from me (that might still happen, on a related topic), but Lorenzo Colitti and Tommy Pauly gave an excellent presentation in INTAREA at IETF 110 (slides at https://datatracker.ietf.org/meeting/110/materials/slides-110-intarea-per-app-networking-considerations-01 <https://datatracker.ietf.org/meeting/110/materials/slides-110-intarea-per-app-networking-considerations-01>) on *cnsiderations for* application aware networking (and I'm already seeing specific proposals for APN on agenda requests for IETF 111, so it will be back). 

APN was proposed as a BoF at IETF 111, although I’m not sure if it was approved.

Colin

> is that engineering or research? people should be crisp on whether this is ready for engineering yet. I recognize that people are engineering solutions in this space now, that's not my question. PANRG (in the IRTF) has been looking at impediments to deployment in the past (in https://datatracker.ietf.org/doc/draft-irtf-panrg-what-not-to-do/ <https://datatracker.ietf.org/doc/draft-irtf-panrg-what-not-to-do/>), and trust (whether hosts trusting the network or the network trusting hosts) has been the one consideration that seems intractable.
> Tommy: answered
> Do the chairs have any objection to my asking Lorenzo and Tommy (cc:-ed) to talk about this in PANRG at IETF 111? I know APN isn't particularly in scope for us, but IRTF RGs do have some latitude that IETF WGs don't have, by design. 
> 
> Best,
> 
> Spencer
> _______________________________________________
> Panrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/panrg

-- 
Colin Perkins
https://csperkins.org/

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 17 Jun 2021 11:35:15 -0500

Hi, Colin,

> APN was proposed as a BoF at IETF 111, although I’m not sure if it was

Thanks for the pointer. I'm not watching BOF requests as closely as I have
in the past.

Looking at https://trac.tools.ietf.org/bof/trac/wiki, which looks to be
still in use for IETF 111, I'm seeing that

   - APN is listed as a BOF under RTG,
   - the cutoff date for BOF submissions was 23:59 UTC Friday, 2021-06-1 ,
   and
   -  the IETF 111 BOF wiki page hasn't yet been updated to show what's
   approved, and what's not (for an example of what I'm talking about, see
   https://trac.tools.ietf.org/bof/trac/wiki/BofIETF110, which divides the
   requested BOFs into what was approved, and what was not).

I see that the IESG and IAB still meet jointly to discuss BOF requests
before a decision is made (in the past, this happened the week after the
BOF cutoff submission date), and I guess that the shepherding ADs would be
making final decisions right about now, and contacting the BOF proponents
to talk about next steps (whether the BOF was approved or not).

But, ignoring the question of whether there will be an IETF APN BOF at IETF
111, I'm looking at this text from the wiki:

*Thanks to the feedback we received so far, we have narrowed down the scope
of the APN work in IETF and made it clear. The application-side solution is
removed, and only focus on the network-side solution.*

Jen and Brian are the PANRG co-chairs, and I am not, but to me, this looks
like what was removed from previous APN scope is actually a better fit for
discussion in PANRG than the entire application+network scope that has been
discussed in a variety of venues since at least mod-2019 (according to
https://github.com/APN-Community). So I suspect it's possible that PANRG
could consider whether that part of APN qualifies as interesting research.

Fortunately, I'm sure that Brian and Jen will Do The Right Thing, whatever
that is. 🙂

Best,

Spencer

>    https://datatracker.ietf.org/doc/draft-irtf-panrg-what-not-to-do/),
>    and trust (whether hosts trusting the network or the network trusting
>    hosts) has been the one consideration that seems intractable.
>
> Tommy: answered
>
> Do the chairs have any objection to my asking Lorenzo and Tommy (cc:-ed)
> to talk about this in PANRG at IETF 111? I know APN isn't particularly in

---

From: Colin Perkins <[email-masked]>
Date: Mon, 21 Jun 2021 17:26:02 +0100

> On 17 Jun 2021, at 17:35, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Hi, Colin,
> 
> On Thu, Jun 17, 2021 at 6:44 AM Colin Perkins <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
>> On 16 Jun 2021, at 13:16, Spencer Dawkins at IETF <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear PANRG, 
>> 
> Thanks for the pointer. I'm not watching BOF requests as closely as I have in the past.  
> 
> Looking at https://trac.tools.ietf.org/bof/trac/wiki <https://trac.tools.ietf.org/bof/trac/wiki>, which looks to be still in use for IETF 111, I'm seeing that 
...
> But, ignoring the question of whether there will be an IETF APN BOF at IETF 111, I'm looking at this text from the wiki:
> 
> Thanks to the feedback we received so far, we have narrowed down the scope of the APN work in IETF and made it clear. The application-side solution is removed, and only focus on the network-side solution.
> 
> Jen and Brian are the PANRG co-chairs, and I am not, but to me, this looks like what was removed from previous APN scope is actually a better fit for discussion in PANRG than the entire application+network scope that has been discussed in a variety of venues since at least mod-2019 (according to https://github.com/APN-Community <https://github.com/APN-Community>). So I suspect it's possible that PANRG could consider whether that part of APN qualifies as interesting research. 
> 
> Fortunately, I'm sure that Brian and Jen will Do The Right Thing, whatever that is. 🙂

The scope of the work certainly started out quite broad, and the current BoF request has a more narrow focus, certainly.

Understanding application awareness in a limited domain, and how it differs from path-awareness in the broader Internet, might be worth this group discussing. 

Colin