Subject: [paws] clarifying use of HTTP redirect

From: "Harasty, Daniel J" <[email-masked]>
Date: Wed, 5 Jun 2013 13:02:08 +0000

Vince, all,

I'd like to propose some clarifications regarding use of HTTP Redirect.  These would be suitable for adding to Section 7 of the
Protocol to Access Spectrum Database, Draft 5.  ("draft-ietf-paws-protocol-05.txt"):

The server SHOULD use HTTP status code "307 Temporary Redirect" to indicate that the Device SHOULD resubmit the same request to an alternate URL.  The device MAY revert to the original URL for the very next requests, or MAY continue to use the alternate URL for a period (e.g.: the remainder of its session, or a fixed period of time, or until power-cycled, or until it receives another redirect).  However, it SHOULD NOT modify it stored list of available URLs.

The server SHOULD use HTTP status code "301 Moved Permanently" to indicate that the Device SHOULD resubmit this request an alternate URL and SHOULD submit all future requests to the same.  If the Device maintains a list of available URLs, it SHOULD replace only the current URL with the replacement indicated in the Redirect.

I believe this language will facilitate interoperability.

- Dan Harasty
Wireless Systems and Networks Dept
Applied Communication Sciences
Red Bank, NJ

---

From: Vincent Chen <[email-masked]>
Date: Wed, 5 Jun 2013 11:27:58 -0700

Thank you Dan!

That sounds reasonable. I'll update the doc.

-vince

On Wed, Jun 5, 2013 at 6:02 AM, Harasty, Daniel J <[email-masked]>wrote:

>  Vince, all,****
>
> ** **
>
> I’d like to propose some clarifications regarding use of HTTP Redirect.
> These would be suitable for adding to Section 7 of the ****
>
> Protocol to Access Spectrum Database, Draft 5.
> (“draft-ietf-paws-protocol-05.txt”):****
>
> ** **
>
> The server SHOULD use HTTP status code “307 Temporary Redirect” to
> indicate that the Device SHOULD resubmit the same request to an alternate
> URL.  The device MAY revert to the original URL for the very next requests,
> or MAY continue to use the alternate URL for a period (e.g.: the remainder
> of its session, or a fixed period of time, or until power-cycled, or until
> it receives another redirect).  However, it SHOULD NOT modify it stored
> list of available URLs.****
>
> ** **
>
> The server SHOULD use HTTP status code “301 Moved Permanently” to indicate
> that the Device SHOULD resubmit this request an alternate URL and SHOULD
> submit all future requests to the same.  If the Device maintains a list of
> available URLs, it SHOULD replace only the current URL with the replacement
> indicated in the Redirect.****
>
> ** **
>
> I believe this language will facilitate interoperability.****
>
> ** **
>
> - Dan Harasty****
>
> Wireless Systems and Networks Dept****
>
> Applied Communication Sciences****
>
> Red Bank, NJ****
>
> ** **
>
> _______________________________________________
> paws mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/paws
>
>

-- 
-vince