Subject: [Pce] Reg LSPA Object

From: "S.SenthilKumar" <[email-masked]>
Date: Thu, 20 Nov 2008 16:02:06 +0530

Dear All

I like to understand more about LSPA Object defined in PCEP.

1. What will be content of the following fields?

*	Exclude-any                             
*	Include-any
*	Include-all

2. More information can be added into PCEP RFC

3. What is the use-case of this object

4. If more than one request is present in a single PCReq message, How LSPA
object is associated with a single request present in the message?

General comment:  PCEP RFC has lot of Typo errors and the same can be
rectified. I will also review and provide my comments in the mean time.

Thanking you,

Best regards,

S.SenthilKumar

7.11.  LSPA Object

   The LSPA object is optional and specifies various TE LSP attributes

   to be taken into account by the PCE during path computation.  The

   LSPA (LSP Attributes) object can be carried within a PCReq message,

   or a PCRep message in case of unsuccessful path computation (in this

   case, the PCRep message also contains a NO-PATH object and the LSPA

   object is used to indicate the set of constraints that could not be

   satisfied).  Most of the fields of the LSPA object are identical to

   the fields of the SESSION-ATTRIBUTE (C-Type = 7) object defined in

   [RFC3209] and [RFC4090].  When absent from the PCReq message, this

   means that the Setup and Holding priorities are equal to 0, and there

   are no affinity constraints.

   LSPA Object-Class is to be assigned by IANA (recommended value=9)

   LSPA Object-Types is to be assigned by IANA (recommended value=1)

   The format of the LSPA object body is:

    0                   1                   2                   3

    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                       Exclude-any                             |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                       Include-any                             |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                       Include-all                             |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |  Setup Prio   |  Holding Prio |     Flags   |L|   Reserved    |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                                                               |

   //                     Optional TLVs                           //

   |                                                               |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: JP Vasseur <[email-masked]>
Date: Thu, 20 Nov 2008 06:16:59 -0600

Hi,

On Nov 20, 2008, at 4:32 AM, S.SenthilKumar wrote:

> Exclude-any
> Include-any
> Include-all

The text is quite clear:

Most of the fields of the LSPA object are identical to
>    [RFC3209] and [RFC4090].

So you may want to red 3209 and 4090 for more details on these fields.

> 3. What is the use-case of this object

To express constraints.

> 4. If more than one request is present in a single PCReq message,  
> How LSPA object is associated with a single request present in the  
> message?
>

Please look at the BNF:

The format of a PCReq message is as follows:
    <PCReq Message>::= <Common Header>
                       [<SVEC-list>]
                       <request-list>

    where:
       <svec-list>::=<SVEC>[<svec-list>]
       <request-list>::=<request>[<request-list>]

       <request>::= <RP>
                    <END-POINTS>
                    [<LSPA>]
                    [<BANDWIDTH>]
                    [<metric-list>]
                    [<RRO>[<BANDWIDTH>]]
                    [<IRO>]
                    [<LOAD-BALANCING>]
    where:

    <metric-list>::=<METRIC>[<metric-list>]

What you want to do above is thus supported.

> General comment:  PCEP RFC has lot of Typo errors and the same can  
> be rectified. I will also review and provide my comments in the mean  
> time.

Most of them have been fixed. The RFC editor will correct the  
remaining ones if any,

Thanks.

JP.