Subject: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

From: Nic Neate <[email-masked]>
Date: Wed, 19 Nov 2008 20:28:33 +0000

Hi,

I have a suggestion for a small extension to the PCEP P2MP draft.

I believe the base PCEP specification currently has three options for calculating diverse protection paths: link diverse, node diverse and SRLG diverse (draft-ietf-pce-pcep section 7.13.2).

In P2MP, S2L sub-path diverse is another important case.  I think it would be good to allow the PCC to request computation of S2L sub-path diverse protection paths.

This is useful when doing 1+1 protection in a ring topology, for example.

Nic

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 19 Nov 2008 20:49:06 -0000

Ah, that is an interesting and valid point, Nic.

And I think one might also consider "directional diversity" for your ring 
example.

A
----- Original Message ----- 
From: "Nic Neate" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Wednesday, November 19, 2008 8:28 PM
Subject: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

Hi,

I believe the base PCEP specification currently has three options for 
calculating diverse protection paths: link diverse, node diverse and SRLG 
diverse (draft-ietf-pce-pcep section 7.13.2).

In P2MP, S2L sub-path diverse is another important case.  I think it would 
be good to allow the PCC to request computation of S2L sub-path diverse 
protection paths.

Nic

--------------------------------------------------------------------------------

---

From: Quintin Zhao <[email-masked]>
Date: Thu, 20 Nov 2008 11:16:21 -0500

Nic and Adrian,

Thanks for your suggestions!
 
By using the existing SVEC functionality, PCC can request the secondary P2MP
LSP path computation to protect the whole P2MP path tree by specifying the
S/N/L bit in the SVEC object. 

If we understand the new requirements you suggested for S2L sub-path
diversity, you want the PCC to be able to ask the PCE to compute secondary
P2MP path tree with partial path diversity for certain leaves or certain S2L
sub-path. 

We will address these new requirements in our next version of the draft.
 
Quintin

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Wednesday, November 19, 2008 3:49 PM
To: Nic Neate; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

A
----- Original Message ----- 
From: "Nic Neate" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; 
<[email-masked]>

Hi,

Nic

----------------------------------------------------------------------------
----

---

From: Nic Neate <[email-masked]>
Date: Thu, 20 Nov 2008 16:33:33 +0000

Hi Quintin,

I don't think "partial path diversity for certain leaves" is quite the point I was suggesting.

The idea of S2L sub-path diversity is that, when you're doing 1+1 protection, you don't need complete tree diversity.  It is sufficient just to ensure that, for any given leaf, the S2L sub-paths to that leaf in the two trees are diverse.  Then, following some network failure, traffic will still be delivered to all leaves on at least one of the two trees.

Two P2MP LSPs going in opposite ways around a ring is the easiest way to picture this.

Nic

-----Original Message-----
From: Quintin Zhao [mailto:[email-masked]]
Sent: 20 November 2008 16:16
To: Aria - Adrian Farrel Personal; Nic Neate
Cc: [email-masked]; [email-masked]; [email-masked]; 'Mohamad CHAITOU'; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

Nic and Adrian,

By using the existing SVEC functionality, PCC can request the secondary P2MP LSP path computation to protect the whole P2MP path tree by specifying the S/N/L bit in the SVEC object.

If we understand the new requirements you suggested for S2L sub-path diversity, you want the PCC to be able to ask the PCE to compute secondary P2MP path tree with partial path diversity for certain leaves or certain S2L sub-path.

Quintin

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]]
Sent: Wednesday, November 19, 2008 3:49 PM
To: Nic Neate; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

And I think one might also consider "directional diversity" for your ring example.

A
----- Original Message -----
From: "Nic Neate" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, November 19, 2008 8:28 PM
Subject: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

Hi,

Nic

---

From: "Fabien Verhaeghe" <[email-masked]>
Date: Thu, 20 Nov 2008 17:59:37 +0100

Hi Nic,

Just to be sure we understand, can you please confirm that the following
definition corresponds to what you name “S2L sub-path diversity”:

For each leaf Ln the path from S to Ln in the primary P2MP LSP is Link (or
node or SRLG) diverse with the S to Ln path in the secondary P2MP LSP.

If this is correct I also think this is a good suggestion that would be
easily fulfilled by defining a new bit in the SVEC object in next draft
version.

BR

Fabien

  _____  

De : Nic Neate [mailto:[email-masked]] 
Envoyé : mercredi 19 novembre 2008 21:29
À : [email-masked]; [email-masked]
Cc : [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]
Objet : Comment on draft-ietf-pce-pcep-p2mp-extensions

Hi,

Nic

---

From: Nic Neate <[email-masked]>
Date: Thu, 20 Nov 2008 18:41:09 +0000

Exactly.  I agree that a new bit in the SVEC object is the way to do this.

Thanks,

Nic

________________________________
From: Fabien Verhaeghe [mailto:[email-masked]]
Sent: 20 November 2008 17:00
To: Nic Neate; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Comment on draft-ietf-pce-pcep-p2mp-extensions

Hi Nic,

Just to be sure we understand, can you please confirm that the following definition corresponds to what you name "S2L sub-path diversity":

For each leaf Ln the path from S to Ln in the primary P2MP LSP is Link (or node or SRLG) diverse with the S to Ln path in the secondary P2MP LSP.

If this is correct I also think this is a good suggestion that would be easily fulfilled by defining a new bit in the SVEC object in next draft version.

BR
Fabien

________________________________
De : Nic Neate [mailto:[email-masked]]
Envoyé : mercredi 19 novembre 2008 21:29
À : [email-masked]; [email-masked]
Cc : [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Objet : Comment on draft-ietf-pce-pcep-p2mp-extensions

Hi,

Nic

---

From: saquib khan <[email-masked]>
Date: Fri, 21 Nov 2008 08:39:15 +0530

Hi Nic,
If we consider S2L diversity for all the leaves in the tree, automatically
the complete tree will become diverse, then why do we require a new
diversity option?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Nic
Neate
Sent: Thursday, November 20, 2008 10:04 PM
To: Quintin Zhao; Aria - Adrian Farrel Personal
Cc: [email-masked]; 'Mohamad CHAITOU'; [email-masked];
[email-masked]
Subject: Re: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

Hi Quintin,

I don't think "partial path diversity for certain leaves" is quite the point
I was suggesting.

The idea of S2L sub-path diversity is that, when you're doing 1+1
protection, you don't need complete tree diversity.  It is sufficient just
to ensure that, for any given leaf, the S2L sub-paths to that leaf in the
two trees are diverse.  Then, following some network failure, traffic will
still be delivered to all leaves on at least one of the two trees.

Two P2MP LSPs going in opposite ways around a ring is the easiest way to
picture this.

Nic

-----Original Message-----
From: Quintin Zhao [mailto:[email-masked]]
Sent: 20 November 2008 16:16
To: Aria - Adrian Farrel Personal; Nic Neate
Cc: [email-masked]; [email-masked]; [email-masked];
'Mohamad CHAITOU'; [email-masked]; [email-masked];
[email-masked]
Subject: RE: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

Nic and Adrian,

Quintin

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]]
Sent: Wednesday, November 19, 2008 3:49 PM
To: Nic Neate; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

A
----- Original Message -----
From: "Nic Neate" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>

Hi,

Nic

---

From: Nic Neate <[email-masked]>
Date: Fri, 21 Nov 2008 16:19:58 +0000

Hi Saquib,

In S2L sub-path diversity, it is allowed for the sub-path to leaf A in the first tree to share resources with the sub-path to leaf B in the second tree.  So the complete trees are not (necessarily) diverse.

Nic

-----Original Message-----
From: saquib khan [mailto:[email-masked]]
Sent: 21 November 2008 03:09
To: Nic Neate; 'Quintin Zhao'; Aria - Adrian Farrel Personal
Cc: [email-masked]; 'Mohamad CHAITOU'; [email-masked]; [email-masked]
Subject: RE: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

Hi Nic,
If we consider S2L diversity for all the leaves in the tree, automatically the complete tree will become diverse, then why do we require a new diversity option?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Nic Neate
Sent: Thursday, November 20, 2008 10:04 PM
To: Quintin Zhao; Aria - Adrian Farrel Personal
Cc: [email-masked]; 'Mohamad CHAITOU'; [email-masked]; [email-masked]
Subject: Re: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

Hi Quintin,

Nic

-----Original Message-----
From: Quintin Zhao [mailto:[email-masked]]
Sent: 20 November 2008 16:16
To: Aria - Adrian Farrel Personal; Nic Neate
Cc: [email-masked]; [email-masked]; [email-masked]; 'Mohamad CHAITOU'; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

Nic and Adrian,

Quintin

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]]
Sent: Wednesday, November 19, 2008 3:49 PM
To: Nic Neate; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

A
----- Original Message -----
From: "Nic Neate" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, November 19, 2008 8:28 PM
Subject: [Pce] Comment on draft-ietf-pce-pcep-p2mp-extensions

Hi,

Nic