Subject: [Pce] [Technical Errata Reported] RFC7420 (4673)

From: RFC Errata System <[email-masked]>
Date: Wed, 20 Apr 2016 00:22:02 -0700 (PDT)

The following errata report has been submitted for RFC7420,
"Path Computation Element Communication Protocol (PCEP) Management Information Base (MIB) Module".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7420&eid=4673

--------------------------------------
Type: Technical
Reported by: Mahendra Singh Negi <[email-masked]>

Section: 4.1

Original Text
-------------
pcePcepSessState OBJECT-TYPE
       SYNTAX      INTEGER {
                      tcpPending(1),
                      openWait(2),
                      keepWait(3),
                      sessionUp(4)
                   }
       MAX-ACCESS  read-only
       STATUS      current
       DESCRIPTION
           "The current state of the session.

            The set of possible states excludes the idle state since
            entries do not exist in this table in the idle state."
       ::= { pcePcepSessEntry 3 }

Corrected Text
--------------
pcePcepSessState OBJECT-TYPE
       SYNTAX      INTEGER {
		      idle(0),
                      tcpPending(1),
                      openWait(2),
                      keepWait(3),
                      sessionUp(4)
                   }
       MAX-ACCESS  read-only
       STATUS      current
       DESCRIPTION
           "The current state of the session."
       ::= { pcePcepSessEntry 3 }	

Notes
-----
As per security consideration, if PCE needs to allow incomming connections from only known PCCs. 
Source addresses of PCCs are configured on PCE. If PCEP session on PCE goes down with configured PCCs. 
PCE needs to raise notification pcePcepSessDown (i.e. details mentioned below).
Issue is whiling sending the notification pcePcepSessDown, as session state (pcePcepSessState) defined in RFC doesn't include idle state.
I suggest to include idle(0) state for pcePcepSessState. 

   pcePcepSessDown NOTIFICATION-TYPE
       OBJECTS     {
                      pcePcepSessState,
                      pcePcepSessStateLastChange
                   }
       STATUS      current
       DESCRIPTION
           "This notification is sent when the value of
            pcePcepSessState leaves the sessionUp state."
       ::= { pcePcepNotifications 2 }

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7420 (draft-ietf-pce-pcep-mib-11)
--------------------------------------
Title               : Path Computation Element Communication Protocol (PCEP) Management Information Base (MIB) Module
Publication Date    : December 2014
Author(s)           : A. Koushik, E. Stephan, Q. Zhao, D. King, J. Hardwick
Category            : PROPOSED STANDARD
Source              : Path Computation Element
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Jonathan Hardwick <[email-masked]>
Date: Wed, 20 Apr 2016 07:40:24 +0000

Replying as co-author.

The scenario described below is certainly a valid one.  Assuming there is a PCE server which passively accepts incoming sessions from clients and sends notifications when those sessions go down, then the only state those sessions could possibly be in after going down is idle, because such sessions would not automatically restart.  Since the session state must be reported in the notification, we must include idle in the set of session states.

We originally omitted idle from the set because idle sessions do not appear in the pcePcepSessTable.  But we must have missed this requirement for the pcePcepSessDown Notification.

As such, I believe this errata should be verified.

Best regards
Jon

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: 20 April 2016 08:22
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Jonathan Hardwick <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Jonathan Hardwick <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC7420 (4673)

The following errata report has been submitted for RFC7420, "Path Computation Element Communication Protocol (PCEP) Management Information Base (MIB) Module".

Section: 4.1

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party (IESG) can log in to change the status and edit the report, if necessary.