Subject: [Pce] one clarification comment on draft-ananthakrishnan-pce-stateful-path-protection-01

From: "Zhangxian (Xian)" <[email-masked]>
Date: Wed, 6 Apr 2016 17:55:33 +0000

Hi,

     I think this is a useful draft to cover the missing piece of using stateful PCE for LSP recovery, taking advantage of the base PCEP ASSOCIATION draft.

    I have a minor comment on the Standby(S) bit introduced by the new TLV. Is it the same as the Secondary (S) bit defined in RFC4872 or not?

Regards,

Xian

________________________________
发件人: Pce [[email-masked]] 代表 Dhruv Dhody [[email-masked]]
发送时间: 2016年4月7日 1:01
收件人: [email-masked]
主题: [Pce] Etherpad

Hi,

Help out with notes at -

http://etherpad.tools.ietf.org:9000/p/notes-ietf-95-pce?useMonospaceFont=true

People raising question/presenters, please check.

Thanks!
Dhruv

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 6 Apr 2016 19:18:53 +0100

Agree, but i wonder whether we should go *all* the way.
 
RSVP-TE has the association (and extended association) object for a large set of
uses. It allows an many-to-many association of LSPs for reasons that go well
beyond path protection.
 
Can we consider replicating this function? All LSP my need path computation. The
computation may need to consider existing LSPs for different reasons depending
on the association (consider associated bidirectional LSPs where the two paths
want to be a coherent as possible). Sometimes the LSPs will be computed as a
batch, sometimes as a sequence. Sometimes the knowledge of the LSPs may already
be in the PCE and just an I-D is needed. Sometimes the knowledge is in the PCC
and the whole path has to be supplied.
 
While I completely believe that protection is the main trigger for looking at
this, perhaps we can make it generic so we don't ned to revisit it for each
association type?
 
Cheers,
Adrian
--
Support an author and your imagination.
Tales from the Wood - Eighteen new fairy tales.
http://www.feedaread.com/books/Tales-from-the-Wood-9781786100924.aspx
http://www.amazon.co.uk/Tales-Wood-Adrian-Farrel/dp/1786100924
Or buy from me direct.

From: Pce [mailto:[email-masked]] On Behalf Of Zhangxian (Xian)
Sent: 06 April 2016 18:56
To: [email-masked]; [email-masked]
Subject: [Pce] one clarification comment on
draft-ananthakrishnan-pce-stateful-path-protection-01
 
Hi, 
 
     I think this is a useful draft to cover the missing piece of using stateful
PCE for LSP recovery, taking advantage of the base PCEP ASSOCIATION draft.
 
    I have a minor comment on the Standby(S) bit introduced by the new TLV. Is
it the same as the Secondary (S) bit defined in RFC4872 or not?
 
Regards,
Xian
 
  _____  

Hi,
 
Help out with notes at - 

 
Thanks! 
Dhruv