Subject: [Pce] I-D Action: draft-ietf-pce-pceps-18.txt

From: [email-masked]
Date: Mon, 04 Sep 2017 20:16:57 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Path Computation Element WG of the IETF.

        Title           : Secure Transport for PCEP
        Authors         : Diego R. Lopez
                          Oscar Gonzalez de Dios
                          Qin Wu
                          Dhruv Dhody
	Filename        : draft-ietf-pce-pceps-18.txt
	Pages           : 25
	Date            : 2017-09-04

Abstract:
   The Path Computation Element Communication Protocol (PCEP) defines
   the mechanisms for the communication between a Path Computation
   Client (PCC) and a Path Computation Element (PCE), or among PCEs.
   This document describes the usage of Transport Layer Security (TLS)
   to enhance PCEP security, hence the PCEPS acronym proposed for it.
   The additional security mechanisms are provided by the transport
   protocol supporting PCEP, and therefore they do not affect the
   flexibility and extensibility of PCEP.

   This document updates RFC 5440 in regards to the PCEP initialization
   phase procedures.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pce-pceps/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-pce-pceps-18
https://datatracker.ietf.org/doc/html/draft-ietf-pce-pceps-18

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-pceps-18

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 5 Sep 2017 03:29:29 +0000

Hi WG, 

An update is made after discuss with Eric. Thanks Eric for continuing the discussion on your 'discuss'. 

The change made is in the case of TLS negotiation failure after both PCEP peers have sent the StartTLS message. 

OLD: 
   After the exchange of StartTLS messages, if the TLS negotiation fails
   for some reason (e.g. the required mechanisms for certificate
   revocation checking are not available), both peers SHOULD immediately
   close the connection.  Since the initiator has no way to know if the
   peer is willing to accept PCEP connection without TLS, based on the
   local policy, it MAY attempt to re-establish the PCEP session without
   TLS.  The attempt to re-establish the PCEP session without TLS SHOULD
   be limited to only once.
NEW:  
   After the exchange of StartTLS messages, if the TLS negotiation fails
   for some reason (e.g. the required mechanisms for certificate
   revocation checking are not available), both peers MUST immediately
   close the connection.
END

See diff at - https://www.ietf.org/rfcdiff?url1=draft-ietf-pce-pceps-16&url2=draft-ietf-pce-pceps-18

With this update all comments during IESG evaluation are handled. 

Thanks! 
Dhruv

> -----Original Message-----
> From: Pce [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: 05 September 2017 08:47
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Pce] I-D Action: draft-ietf-pce-pceps-18.txt
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 5 Sep 2017 18:00:55 +0000

Thanks Dhruv for holding the pen on this critical document for PCE and working with the IESG on their comments for improving the document!
Deborah

> From: Dhruv Dhody [mailto:[email-masked]]
> Sent: Monday, September 04, 2017 11:29 PM
> To: [email-masked]
> Cc: [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>; Eric
> Rescorla <[email-masked]>
> Subject: RE: [Pce] I-D Action: draft-ietf-pce-pceps-18.txt
> 
> Hi WG,
> 
> See diff at - https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_rfcdiff-3Furl1-3Ddraft-2Dietf-2Dpce-2Dpceps-2D16-26url2-
> 3Ddraft-2Dietf-2Dpce-2Dpceps-2D18&d=DwIFAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tVxrnFGyNsSVioJp_ul
> H_-lsuXd-
> o6ODUeSYNzXZM0Q&s=qbQiWHiY7dEFAIeOMS3wM7fBMMhozS05d9rnuozvhd
> Q&e=
> 
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dpce-
> 2Dpceps_&d=DwIFAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tVxrnFGyNsSVioJp_ul
> H_-lsuXd-o6ODUeSYNzXZM0Q&s=qyyOR8SD81Hnixb-
> MgME8Z7L0NovuKCzGNNt7PWYTZg&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dietf-2Dpce-2Dpceps-
> 2D18&d=DwIFAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tVxrnFGyNsSVioJp_ul
> H_-lsuXd-o6ODUeSYNzXZM0Q&s=TdxXKOIpYfAf6SBw-
> 7ZTgcGNc7BNXp8mmE2rARfT0B4&e=
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dpce-2Dpceps-
> 2D18&d=DwIFAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tVxrnFGyNsSVioJp_ul
> H_-lsuXd-o6ODUeSYNzXZM0Q&s=NH-
> P1MmkcSTlbBNCgMvFuEBLtNi3dA4EtBY3Pi7p26Q&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dpce-2Dpceps-
> 2D18&d=DwIFAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tVxrnFGyNsSVioJp_ul
> H_-lsuXd-o6ODUeSYNzXZM0Q&s=H9jEXpSdf44FK0d5-
> K0aFUdXiOi4CDCENXoZe983y40&e=
> >
> >
> > https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-
> 2Ddrafts_&d=DwIFAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tVxrnFGyNsSVioJp_ul
> H_-lsuXd-
> o6ODUeSYNzXZM0Q&s=PBKMbM2Wyf9AGDUgZVq8QoajUkbvqJMIxW9VWzMk
> dIQ&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_pce&d=DwIFAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tVxrnFGyNsSVioJp_ul
> H_-lsuXd-
> o6ODUeSYNzXZM0Q&s=6GAViva04B1Y4b4EJrfxhrRKeBUT36eiFTtplE3YHy4&e=

---

From: Qin Wu <[email-masked]>
Date: Wed, 6 Sep 2017 00:30:53 +0000

Applause,:-)

-Qin
-----邮件原件-----
发件人: Pce [mailto:[email-masked]] 代表 BRUNGARD, DEBORAH A
发送时间: 2017年9月6日 2:01
收件人: Dhruv Dhody; [email-masked]
抄送: [email-masked]
主题: Re: [Pce] I-D Action: draft-ietf-pce-pceps-18.txt

> The change made is in the case of TLS negotiation failure after both 
> PCEP peers have sent the StartTLS message.
> 
> OLD: