Subject: [Pce] WG Last Call on draft-ietf-pce-applicability-actn

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 8 Feb 2019 11:34:12 -0000

Hi WG,

draft-ietf-pce-applicability-actn seems to be ready to progress towards
publication.

This email starts a two week working group last call (ends on 23rd
February).

During this time, please read the draft and make comments for improvement.
If you then support its publication please let us know that you have read
the draft and support it. If you have any concerns, please let us know and
propose solutions.

Thanks,
Adrian

---

From: <[email-masked]>
Date: Tue, 12 Feb 2019 22:36:32 -0000

Hi All, 

Just saw the I-D hit WG LC and thought I would have a quick scan of the
latest version. 
	
Overall, a really useful document. It was intended to highlight the role of
the PCE (including ancillary components) in the context of ACTN, and it
delivers. The document is well written and easy to read, and certainly ready
to move forward. However, I did find a few minor NITS which I have listed
below. These can be fixed at some point in the process.  

Abstract 
s/is component /is a component/
---
1.1.3.  Relationship to PCE Based Central Control
s/The section 2.1.3 of /Section 2.1.3 of/
---
1.3 PCE and ACTN
s/describes how the PCE architecture /describes how PCE architecture/
---
2. Architectural Considerations
s/It should be noted that, this document /It should be noted that this
document/
---
2.1.  Multi Domain Coordination via Hierarchy
s/describes a hierarchy of PCE with Parent PCE coordinating /describes a
hierarchy of PCEs with the Parent PCE coordinating
s/multi-domain path computation function between Child PCE(s) /multi-domain
path computation function between Child PCEs.
---
3. Interface Considerations
s/In case of hierarchy of MDSC /In the case of hierarchy MDSCs
s/The Section 4 describes /Section 4 describes/
---
4.  Realizing ACTN with PCE (and PCEP)
s/each with its own PNC and a MDSC at top / each with its own PNC and an
MDSC on top
s/per the example in the Figure 2 /per the example in Figure 2/
s/Any change in the per-domain LSP are reported to the MDSC /Any change in
the per-domain LSP is reported to the MDSC/
s/Similarly PNC would convert the path received /Similarly, a PNC would
convert the path received/
---
6.  Security Considerations
s/It also list various security considerations /It also lists various
security considerations/
---	
Need to be consistent with the use of "Per Domain", "Per domain" and "per
domain" 
---
Need to be consistent with the use of "Child PCE" and "child pce"
---
Need to be consistent with the use of "multi-domain" and "multi domain",
including section titles ("2.1.  Multi Domain Coordination via Hierarchy")
---
A few plural instances should be fixed, I don't think the RFC editors like
the use of "(s)"
---

BR, Dan.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 20 Feb 2019 11:17:14 -0500

I agree with Daniel, with the nits fixed the draft is ready for publication.

Cheers,
Andy

On Tue, Feb 12, 2019 at 5:36 PM <[email-masked]> wrote:

> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>

---

From: Leeyoung <[email-masked]>
Date: Mon, 25 Feb 2019 23:48:56 +0000

Hi Dan,

Thanks for your comments. All the nits pointed out are corrected. We will upload the revision once we have resolved Adrian's second comments. 

Best regards,
Young

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 12, 2019 4:37 PM
To: [email-masked]
Subject: Re: [Pce] WG Last Call on draft-ietf-pce-applicability-actn

Hi All, 

Just saw the I-D hit WG LC and thought I would have a quick scan of the latest version. 
	
Overall, a really useful document. It was intended to highlight the role of the PCE (including ancillary components) in the context of ACTN, and it delivers. The document is well written and easy to read, and certainly ready to move forward. However, I did find a few minor NITS which I have listed below. These can be fixed at some point in the process.  

Abstract
s/is component /is a component/
---
1.1.3.  Relationship to PCE Based Central Control s/The section 2.1.3 of /Section 2.1.3 of/
---
1.3 PCE and ACTN
s/describes how the PCE architecture /describes how PCE architecture/
---
2. Architectural Considerations
s/It should be noted that, this document /It should be noted that this document/
---
2.1.  Multi Domain Coordination via Hierarchy s/describes a hierarchy of PCE with Parent PCE coordinating /describes a hierarchy of PCEs with the Parent PCE coordinating s/multi-domain path computation function between Child PCE(s) /multi-domain path computation function between Child PCEs.
---
3. Interface Considerations
s/In case of hierarchy of MDSC /In the case of hierarchy MDSCs s/The Section 4 describes /Section 4 describes/
---
4.  Realizing ACTN with PCE (and PCEP)
s/each with its own PNC and a MDSC at top / each with its own PNC and an MDSC on top s/per the example in the Figure 2 /per the example in Figure 2/ s/Any change in the per-domain LSP are reported to the MDSC /Any change in the per-domain LSP is reported to the MDSC/ s/Similarly PNC would convert the path received /Similarly, a PNC would convert the path received/
---
6.  Security Considerations
s/It also list various security considerations /It also lists various security considerations/
---	
Need to be consistent with the use of "Per Domain", "Per domain" and "per domain" 
---
Need to be consistent with the use of "Child PCE" and "child pce"
---
Need to be consistent with the use of "multi-domain" and "multi domain", including section titles ("2.1.  Multi Domain Coordination via Hierarchy")
---
A few plural instances should be fixed, I don't think the RFC editors like the use of "(s)"
---

BR, Dan.

---

From: Mahendra Singh Negi <[email-masked]>
Date: Tue, 26 Feb 2019 07:18:17 +0000

Hi Adrian,

I have read the document and support the publication.
To authors few references are missing in sections 1.1/1.1.2/1.1.3, in case not taken care.

Thanks,
Mahendra

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 08 February 2019 17:04
To: [email-masked]
Subject: [Pce] WG Last Call on draft-ietf-pce-applicability-actn

Hi WG,

draft-ietf-pce-applicability-actn seems to be ready to progress towards publication.

This email starts a two week working group last call (ends on 23rd February).

During this time, please read the draft and make comments for improvement.
If you then support its publication please let us know that you have read the draft and support it. If you have any concerns, please let us know and propose solutions.

Thanks,
Adrian