Subject: [Pce] RtgDir review: draft-ietf-pce-stateful-pce-p2mp-10.txt

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 18 Feb 2019 16:03:40 -0500

Hello,

I have been selected as the Routing Directorate reviewer for this draft.
The Routing Directorate seeks to review all routing or routing-related
drafts as they pass through IETF last call and IESG review, and sometimes
on special request. The purpose of the review is to provide assistance to
the Routing ADs. For more information about the Routing Directorate, please
see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it
would be helpful if you could consider them along with any other IETF Last
Call comments that you receive, and strive to resolve them through
discussion or by updating the draft.

Document: draft-ietf-pce-stateful-pce-p2mp-10.txt
Reviewer: Andy Malis
Review Date: 18 February 2019
IETF LC End Date: N/A (in preparation for IETF LC)
Intended Status: Standards Track

Summary:

This document is basically ready for publication, but has nits that should
be considered prior to publication.

Comments:

It was very easy to follow the draft. Excellent work by all involved.

Major issues:

No major issues found.

Minor Issues:

No minor issues found.

Nits:

1. Section 3.1, second paragraph:

Replace:
For P2MP this is an added advantage, where the size of message is much
larger.

With:
For P2MP, where the size of message is much larger, this is an added
advantage.

2. Section 5.1, fifth paragraph:

Replace:
Path Computation LSP Initiate Message (PCInitiate):  is a PCEP

With:
Path Computation LSP Initiate Message (PCInitiate): PCInitiate is a PCEP

3. Section 5.2, first paragraph:

Replace:
PCEP speakers advertise Stateful capability via STATEFUL-PCE-CAPABILITY TLV
in open message.

With:
PCEP speakers advertise Stateful capability via the STATEFUL-PCE-CAPABILITY
TLV in the OPEN object.

4. Section 5.2, third paragraph (N Flag): In two places, replace "changes"
with "change".

5. Section 5.3, first paragraph: Expand "LSR" (Label Switching Router) on
first use. It's not on the RFC Editor's list of well-known acronyms.

6. Section 5.3, second paragraph: Expand "PCED" (PCE Discovery TLV) on
first use.

7. Section 6.2, last paragraph: A right ")" is missing at the end of the
paragraph.

8. Section 6.5, first paragraph: In the second line, replace the comma with
a period and capitalize the following "this".

9. Section 6.5, last paragraph: A right ")" is missing at the end of the
paragraph.

10. Section 8, second paragraph: Add the word "The" to the start of the
paragraph.

11. Section 11.2, first paragraph. Change "and a registry was created" to
"and the STATEFUL-PCE-CAPABILITY TLV Flag Field subregistry was created"

12. Section 11.3, first paragraph: Change "and a registry was created" to
"and the LSP Object Flag Field subregistry was created"

Regards,
Andy

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 18 Feb 2019 22:03:57 -0000

Nice review, thanks Andy.

Adrian

From: Andrew G. Malis <[email-masked]> 
Sent: 18 February 2019 21:04
To: <[email-masked]> <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RtgDir review: draft-ietf-pce-stateful-pce-p2mp-10.txt

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Summary:

This document is basically ready for publication, but has nits that should be considered prior to publication.

Comments:

Major issues:

No major issues found.

Minor Issues:

No minor issues found.

Nits:

Replace:
For P2MP this is an added advantage, where the size of message is much larger.

With:
For P2MP, where the size of message is much larger, this is an added advantage.

Replace:

With:

Replace:
PCEP speakers advertise Stateful capability via STATEFUL-PCE-CAPABILITY TLV in open message.

With:
PCEP speakers advertise Stateful capability via the STATEFUL-PCE-CAPABILITY TLV in the OPEN object.

4. Section 5.2, third paragraph (N Flag): In two places, replace "changes" with "change".

5. Section 5.3, first paragraph: Expand "LSR" (Label Switching Router) on first use. It's not on the RFC Editor's list of well-known acronyms.

6. Section 5.3, second paragraph: Expand "PCED" (PCE Discovery TLV) on first use.

7. Section 6.2, last paragraph: A right ")" is missing at the end of the paragraph.

8. Section 6.5, first paragraph: In the second line, replace the comma with a period and capitalize the following "this".

9. Section 6.5, last paragraph: A right ")" is missing at the end of the paragraph.

10. Section 8, second paragraph: Add the word "The" to the start of the paragraph.

11. Section 11.2, first paragraph. Change "and a registry was created" to "and the STATEFUL-PCE-CAPABILITY TLV Flag Field subregistry was created"

12. Section 11.3, first paragraph: Change "and a registry was created" to "and the LSP Object Flag Field subregistry was created"

Regards,
Andy

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 19 Feb 2019 05:15:23 +0000

Hi Andy,

Thanks for your review. Your comments are incorporated in the -11 version.

The IETF datatracker status page for this draft is:

https://datatracker.ietf.org/doc/draft-ietf-pce-stateful-pce-p2mp/

A diff from the previous version is available at:

https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-stateful-pce-p2mp-11

Regards,

Dhruv

Dhruv Dhody
Lead Architect
Network Business Line
Huawei Technologies India Pvt. Ltd.
Survey No. 37, Next to EPIP Area, Kundalahalli, Whitefield
Bengaluru, Karnataka - 560066
Tel: + 91-80-49160700 Ext 71583 II Email: [email-masked]<mailto:[email-masked]>
[Huawei-small]
This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

From: Pce [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: 19 February 2019 02:34
To: <[email-masked]> <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Pce] RtgDir review: draft-ietf-pce-stateful-pce-p2mp-10.txt

Hello,

Summary:

Comments:

Major issues:

No major issues found.

Minor Issues:

No minor issues found.

Nits:

1. Section 3..1, second paragraph:

Replace:

With:

Replace:

With:

Replace:

With:

5.. Section 5.3, first paragraph: Expand "LSR" (Label Switching Router) on first use. It's not on the RFC Editor's list of well-known acronyms.

Regards,
Andy

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 19 Feb 2019 07:57:20 -0500

Dhruv,

That was quick! :-) All looks good except you missed two comments:

Thanks,
Andy

On Tue, Feb 19, 2019 at 12:15 AM Dhruv Dhody <[email-masked]> wrote:

> Tel: + 91-80-49160700 Ext 71583 II Email: [email-masked]
>
>
> *From:* Pce [mailto:[email-masked]] *On Behalf Of *Andrew G. Malis
> *Sent:* 19 February 2019 02:34
> *To:* <[email-masked]> <[email-masked]>
> *Cc:* [email-masked]; [email-masked];
> [email-masked]
> *Subject:* [Pce] RtgDir review: draft-ietf-pce-stateful-pce-p2mp-10.txt
>
>
>
> Hello,
>
> PCEP speakers advertise Stateful capability via the
> STATEFUL-PCE-CAPABILITY TLV in the OPEN object.
>
> 5.. Section 5.3, first paragraph: Expand "LSR" (Label Switching Router) on
> 8. Section 6.5, first paragraph: In the second line, replace the comma
> with a period and capitalize the following "this".
>

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 19 Feb 2019 20:34:47 +0530

Oops, I did overlook those two comments. Must be because of identical 7 &
9; making me thing as I was at 9 while i was working on 7.
Apologies, will post an update SOON.

Thanks!
Dhruv

On Tue, Feb 19, 2019 at 6:27 PM Andrew G. Malis <[email-masked]> wrote:

>> This document is basically ready for publication, but has nits that
>> should be considered prior to publication.
>>
>> Comments:
>>
>> 5.. Section 5.3, first paragraph: Expand "LSR" (Label Switching Router)
>> on first use. It's not on the RFC Editor's list of well-known acronyms.
>>