Subject: [Pce] WG Adoption Call for draft-negi-pce-segment-routing-ipv6

From: Dhruv Dhody <[email-masked]>
Date: Fri, 22 Feb 2019 12:17:08 +0530

Hi WG,

Please read & review draft-negi-pce-segment-routing-ipv6-04 [1] and
send your comments to the mailing list.

Should this draft be adopted by the PCE WG? Please state your reasons
- Why / why not?

What needs to be fixed before or after adoption?

Are you willing to work on this draft? Do you plan to implement it?

This poll will run until 8th March.

Thanks,
PCE Chairs

[1] https://datatracker.ietf.org/doc/draft-negi-pce-segment-routing-ipv6/?include_text=1

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 22 Feb 2019 09:51:45 -0500

Yes/support. This is a very important companion draft
to draft-ietf-pce-segment-routing.

Cheers,
Andy

On Fri, Feb 22, 2019 at 1:47 AM Dhruv Dhody <[email-masked]> wrote:

> [1]
> https://datatracker.ietf.org/doc/draft-negi-pce-segment-routing-ipv6/?include_text=1
>
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Mon, 25 Feb 2019 07:41:01 +0000

Support. 

This document specifies the extensions of SRv6 in PCEP, which is very import to SRv6 control plane.

After several revisions, the content of this draft has been mature and ready for WG adoption.

Thanks,
Cheng as co-author.

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Friday, February 22, 2019 2:47 PM
To: [email-masked]
Subject: [Pce] WG Adoption Call for draft-negi-pce-segment-routing-ipv6

Hi WG,

Please read & review draft-negi-pce-segment-routing-ipv6-04 [1] and send your comments to the mailing list.

Thanks,
PCE Chairs

---

From: Aijun Wang <[email-masked]>
Date: Mon, 25 Feb 2019 16:16:05 +0800

Yes/Support.

This draft give controller the capabilities to design the SRv6 Path via PCEP protocol.

Aijun Wang
China Telecom

> On Feb 22, 2019, at 22:51, Andrew G. Malis <[email-masked]> wrote:
> 
> Yes/support. This is a very important companion draft to draft-ietf-pce-segment-routing.
> 
> Cheers,
> Andy
> 
>

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 25 Feb 2019 09:21:08 -0800

I support the adoption and willing to work on it.

The Function Code section is not well specified and should refer to draft-filsfils-spring-srv6-network-programming that has requested new IANA sub-registry "SRv6 Endpoint Behaviors”.
In general it is unclear why do we need them and what does “maintainability” mean in that context.

Cheers,
Jeff

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 26 Feb 2019 06:41:21 +0000

Yes/support. This document defines necessary extensions for support of SRv6.

Best regards,
Jie

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Wed, 27 Feb 2019 14:15:16 +0000

Support! This is one of the building blocks for SRv6.

Thanks

Regards … Zafar

From: Pce <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Friday, February 22, 2019 at 1:47 AM
To: "[email-masked]" <[email-masked]>
Subject: [Pce] WG Adoption Call for draft-negi-pce-segment-routing-ipv6

Hi WG,

Thanks,
PCE Chairs

_______________________________________________
Pce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pce

---

From: Mahendra Singh Negi <[email-masked]>
Date: Thu, 28 Feb 2019 08:51:10 +0000

Support as co-author.  

This document defines required PCEP extensions to support SRv6 path provisioning by PCE (Controller), and is a necessary building block of SRv6 control plane.

Regards,
Mahendra

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: 22 February 2019 12:17
To: [email-masked]
Subject: [Pce] WG Adoption Call for draft-negi-pce-segment-routing-ipv6

Hi WG,

Thanks,
PCE Chairs

---

From: Khasanov Boris <[email-masked]>
Date: Thu, 28 Feb 2019 11:17:52 +0000

Hi all,
I reviewed the draft and personally support  WG adoption because it is very important work.

Few comments:

1) Jeff earlier provided the comments about Function Code section (page 11), I would like  to add mine: there are only End.DX6, End.DT6 functions - how about End.DT4, End.DX4?  VPNv4 is still very important, IMO.  In broader scope - how to encode much more functions from draft-filsfils-spring-srv6-network-programming as Jeff mentioned. 

2) Section 3.3.3.2 ERO processing
...
If a PCC receives a list of SRv6 segments, and the number of SRv6
   segments exceeds the SRv6 MSD that the PCC can impose on the packet
   (SRH), it MAY send a PCErr message with Error-Type = 10 ("Reception
   of an invalid object") and Error-Value = TBD ("Unsupported number of
   Segment ERO subobjects") as per [I-D.ietf-pce-segment-routing].

I personally doubt that '.. MAY send ..."  is a right way here due to possible bad consequences on forwarding plane without PCErr. IMO, again, it  needs to be at least should. Please consider pros and cons.

Thanks.

SY,
Boris   

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Friday, February 22, 2019 9:47 AM
To: [email-masked]
Subject: [Pce] WG Adoption Call for draft-negi-pce-segment-routing-ipv6

Hi WG,

Thanks,
PCE Chairs

---

From: Lizhenbin <[email-masked]>
Date: Fri, 1 Mar 2019 06:23:15 +0000

I support the adoption of the draft. It is important for the dynamic SRv6 TE with central control. 

Best Regards,
Zhenbin (Robin)

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Friday, February 22, 2019 2:47 PM
To: [email-masked]
Subject: [Pce] WG Adoption Call for draft-negi-pce-segment-routing-ipv6

Hi WG,

Thanks,
PCE Chairs