Subject: [Pce] Mirja Kühlewind's No Objection on draft-ietf-pce-wson-rwa-ext-11: (with COMMENT)

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 04 Feb 2019 09:04:06 -0800

Mirja Kühlewind has entered the following ballot position for
draft-ietf-pce-wson-rwa-ext-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pce-wson-rwa-ext/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I had some similar concerns as Benjamin but I think he listed them all. I some
more minor editorial comments to add:

1) sec 4.3:
  "an Error-value (Error-value=3) MUST be defined so that the PCE MUST
   send a PCErr message with a PCEP-ERROR Object. See Section 5.1 for
   the details."
This doesn't really make sense as normative "MUST"; I propose to change to
lower case "must".

2) sec 4.3:
"This TLV MAY appear more than once to be able to specify
   multiple restrictions."
How do you know how much restrictions will be there? Based on a length field in
the base protocol? Please clarify in the draft!

3) sec 4.3.2:
"Length (16 bits): It is the length in bytes of the entire label set
   field."
What is meant by "label set field" here? Please clarify in the draft or align
wording accordingly.

4) Error value 3 is missing in sec 8.8!

---

From: Leeyoung <[email-masked]>
Date: Thu, 7 Feb 2019 02:09:26 +0000

Hi Mirja,

Thanks for your comments. Please see in-line for my response to each of your comments. Please let me know if you have further comments.

Thanks & Best regards,
Young

-----Original Message-----

From: Mirja Kühlewind [mailto:[email-masked]]

Sent: Monday, February 4, 2019 11:04 AM

To: The IESG <[email-masked]>

Cc: [email-masked]; Daniele Ceccarelli <[email-masked]>; [email-masked]; [email-masked]; [email-masked]

Subject: Mirja Kühlewind's No Objection on draft-ietf-pce-wson-rwa-ext-11: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

COMMENT:

I had some similar concerns as Benjamin but I think he listed them all. I some more minor editorial comments to add:

1) sec 4.3:

   the details."

This doesn't really make sense as normative "MUST"; I propose to change to lower case "must".

YL>> Agree.

2) sec 4.3:

   multiple restrictions."

How do you know how much restrictions will be there? Based on a length field in the base protocol? Please clarify in the draft!

YL>> By the length field. I made it clear this TLV is the whole TLV (which has the length field).

3) sec 4.3.2:

   field."

What is meant by "label set field" here? Please clarify in the draft or align wording accordingly.

YL>> Yes, you are right. s/label set field/Wavelength Restriction field

YL>> Yes, I added this.