Subject: [PCN] RE: PCN dinner consensus

From: <[email-masked]>
Date: Wed, 19 Dec 2007 15:32:37 -0000

PCN-ers,
Several of us [cc'd] met over a couple of "corridor" meetings. We've
agreed a way forward until Philadelphia in terms of where we're going to
concentrate our particular efforts, in order to increase the chances of
success on the Milestone '(Pre-)Congestion Detection within a DiffServ
Domain' due March 2008.
 
Over the next few months, we will make the working assumption of the "CL
marking behaviour" and explain/test this assumption (eg with further
simulations):
* "CL marking" means threshold-marking (step) for admission control &
excess-rate-marking for flow termination. 
* Single Marking - this is potentially a migration step to CL. Explain
why SM is not enough (when is it enough?)
* 3SM - we believe that the overall behaviour in the 3SM draft can be
approximated with the CL marking + different edge behaviour. Explain how
(and what is lost). We had a good session to understand the pros/cons of
3SM in more detail, and what simuls might help on this. 
* LC-PCN - we believe that Affected Marking could in principle be added
to CL (or indeed to SM). Assess whether the benefit is worth the cost
(are any simulations possible?)
 
Results etc of course on list and perhaps as a Part B to
http://tools.ietf.org/wg/pcn/draft-charny-pcn-comparison-00.txt - in
order to help the decision what marking approach to standardise.
 
Note, this is just an unofficial understanding between some of us, in an
effort to increase the chances of the WG making a decision around the
next IETF (when the Milestone is due), and of course doesn't stop other
proposals and work. Hopefully the above captures what we agree (cc'd
people, please correct mistakes!).
 
Best wishes & have a nice Chistmas,
Phil 

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 19 Dec 2007 16:55:55 +0100

Hi Phil, Hi all

Thank you very much!

Regarding LC-PCN:
* it will be good to explain how the LC-PCN overall behaviour 
in PCN_iterior_nodes can be approximated using SM  or CL + different 
edge behaviour. 
* Affected Marking, agree to be added to SM and CL
* About probing, I think that it is usefull to investigate it, 
such that it could be used as an 
option for CL++ and SM++.

I would very much like to wish to you and to your families:

Merry Christmas and a Happy New Year

Best regards,
Georgios

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: woensdag 19 december 2007 16:33
> To: [email-masked]
> Cc: [email-masked]
> Subject: [PCN] RE: PCN dinner consensus
> 
> PCN-ers,
> Several of us [cc'd] met over a couple of "corridor" 
> meetings. We've agreed a way forward until Philadelphia in 
> terms of where we're going to concentrate our particular 
> efforts, in order to increase the chances of success on the 
> Milestone '(Pre-)Congestion Detection within a DiffServ 
> Domain' due March 2008.
>  
> Over the next few months, we will make the working assumption 
> of the "CL marking behaviour" and explain/test this 
> assumption (eg with further
> simulations):
> * "CL marking" means threshold-marking (step) for admission 
> control & excess-rate-marking for flow termination. 
> * Single Marking - this is potentially a migration step to 
> CL. Explain why SM is not enough (when is it enough?)
> * 3SM - we believe that the overall behaviour in the 3SM 
> draft can be approximated with the CL marking + different 
> edge behaviour. Explain how (and what is lost). We had a good 
> session to understand the pros/cons of 3SM in more detail, 
> and what simuls might help on this. 
> * LC-PCN - we believe that Affected Marking could in 
> principle be added to CL (or indeed to SM). Assess whether 
> the benefit is worth the cost (are any simulations possible?)
>  
> http://tools.ietf.org/wg/pcn/draft-charny-pcn-comparison-00.tx
t - in order to help the decision what marking approach to > standardise.
>  
> Note, this is just an unofficial understanding between some 
> of us, in an effort to increase the chances of the WG making 
> a decision around the next IETF (when the Milestone is due), 
> and of course doesn't stop other proposals and work. 
> Hopefully the above captures what we agree (cc'd people, 
> please correct mistakes!).
>

---

From: Bob Briscoe <[email-masked]>
Date: Wed, 19 Dec 2007 16:32:41 +0000

Georgios,

>option for CL++ and SM++.

In Vancouver there was a lot of discussion about how much the w-g will / 
won't discuss probing. See minutes posted by Steve Blake recently for the 
discussions.

Bob

____________________________________________________________________________
Bob Briscoe, <[email-masked]>      Networks Research Centre, BT Research
B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473 645196

---

From: <[email-masked]>
Date: Wed, 19 Dec 2007 18:22:22 -0000

> From: Georgios Karagiannis [mailto:[email-masked]]
> Sent: 19 December 2007 15:56
> To: Eardley,PL,Philip,CXR9 R; [email-masked]
> Cc: Briscoe,RJ,Bob,CXR9 R
> Subject: RE: [PCN] RE: PCN dinner consensus
> 
> Hi Phil, Hi all
> 
> Thank you very much!
> 
> Regarding LC-PCN:
Sure! - Personally I don't understand lc-pcn well enough to be able to
help with this. 

> * Affected Marking, agree to be added to SM and CL
it would be good if we could come up with any analysis /simulations to
get a better handle of how much benefit it would offer in what
circumstances. Any thoughts or work you've already done? That way we can
judge better whether or not it should be added. 

> option for CL++ and SM++.
Note the Chairs email about probing 

> Merry Christmas and a Happy New Year

and to you!

phil

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Thu, 20 Dec 2007 16:56:02 +0100

Hi Bob

Checking the minutes, the only things that I could find on probing were 
associated with the architecture draft. The architecture draft does not
exclude the use of probing.
Thus I do not see that probing is excluded from future PCN activities.

Best regards,
Georgios

> From: Bob Briscoe [mailto:[email-masked]] 
> Sent: woensdag 19 december 2007 17:33
> To: Georgios Karagiannis
> Cc: [email-masked]; [email-masked]
> >* About probing, I think that it is usefull to investigate it, such 
> >that it could be used as an option for CL++ and SM++.
> 
> In Vancouver there was a lot of discussion about how much the 
> w-g will / won't discuss probing. See minutes posted by Steve 
> Blake recently for the discussions.
> 
> 
> Bob
> 
>

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 20 Dec 2007 16:51:29 +0000

Georgios,

Quoting straw poll in notes:

>Steve: [...] How many think protocol work on probing should be done right 
>now? No one.
>
>Lars: how many think it should be done before arch draft WGLC? No one.

But you're right, probing is not excluded from future activities, just 
current ones.

Bob