Subject: [PCN] A two-layer approach for PCN

From: Michael Menth <[email-masked]>
Date: Tue, 11 Dec 2007 23:06:10 +0100

Hi all,

during last week's meeting I had discussions with many people regarding 
a separation of packet marking vs. admission control and flow 
termination aspects. The intention was to make the structure of PCN more 
obvious and to facilitate its adaptation to various network 
architectures. The following text reflects the outcome of these discussions.

Comments are welcome.

Regards,

    Michael

--

The pre-congestion notification (PCN) architecture consists of two 
different layers: the packet marking layer (PML) and the admission 
control and flow termination layer (ACFTL).
The packet marking layer (PML) describes how PCN-capable interior nodes 
meter and mark PCN packets. Within a single network only one packet 
marking layer (PML) MUST be deployed, i.e. PCN-capable interior nodes 
MUST implement the same metering and marking behavior for all links. The 
admission control and flow termination layer (ACFTL) describes how PCN 
edge nodes make use of the packet markings observed by the PCN egress 
node to decide whether new flows can be accepted or whether already 
admitted flows need to be terminated. The implementation of the 
admission control and flow termination layer (ACFTL) may take advantage 
of specific transport architectures and may be tailored for various 
signaling architectures with which it needs to interoperate. In contrast 
to the packet marking layer (PML), different instances admission control 
and flow termination layers (ACFTL) MAY be used in the same network as 
long as they interpret the semantics of the packet markings in the same 
way and don't lead to unfairness issues.

                       +---+---+---+---+
                       | A | A | . | A |
                       | C | C | . | C |
                       | F | F | . | F |
                       | T | T | . | T |
                       | L | L | . | L |
                       |   |   |   |   |
                       | 0 | 1 | . | n |
                       +---+---+---+---+
                       |      PML      |
                       +---------------+

Figure 1: Within a single network, only one packet marking layer (PML)
         MUST be deployed, but several admission control and flow
         termination layers (ACFTL) MAY coexist.

In the following, the concepts of the packet marking layer (PML) and 
admission control and flow termination layer (ACFTL) are briefly 
illustrated.

4 examples of mutually exclusive interior node behaviors for 
implementation of the PML:

a) Ramp marking based on the admissible rate and excess-rate marking 
based on the supportable rate (CL proposal)
b) Threshold marking based on the admissible rate and excess-rate 
marking with marking frequency reduction based on the supportable rate 
(3sm proposal)
c) Threshold marking based on the admissible rate and excess-rate 
marking based on the supportable rate (behavioral intersection of CL and 
3sm proposal)
d) Excess rate marking based on the admissible rate (Single Marking 
proposal)

Note that only one packet marking layer (PML) can be deployed within a 
single network.

3 examples for different edge node behaviors for implementation of the 
admission control and flow termination layer (ACFTL) based on the packet 
marking layer b) above:

 o E3Tunnel
   Given: edge-to-edge MPLS tunnels;
   Egress node measures CLE for tunnel and depending on that value, it 
sends an "admission-stop" or "admission-continue" message to the 
corresponding ingress node that then stops or continues admitting 
further flows.
   Flows are terminated when one of its packets was ET-marked.
 o End2PS
   Given: end-to-end on-path signalling protocol;
   PCN egress node is a RSVP capable node and returns PATHERR if first 
PATH msg was "admission-stop" marked; PCN ingress node accepts all flows 
whose RESV messages come through. 
   Flows are terminated when one of its packets was ET-marked: the PCN 
egress node sends a RESVTEAR message to the PCN ingress.
 o Centralized node
   Given: centralized node (CN) in charge of admitting or terminating flows;
   Upon a new flow arrival, the CN issues an admission request to PCN 
ingress node for a future data flow with an indicated source-destination 
tuple;
   CN sends a probe packet to the PCN egress node which returns the 
probe to the CN; the CN rejects the flow if probe was marked and admits 
it if probe was unmarked.
   Flows are terminated when one of its packets was ET-marked. The PCN 
egress node sends the marked packet to the CN which terminated the 
corresponding flow.

These admission control and flow termination layers (ACFTL) MAY 
simultaneously be applied in the same network. Similar methods can be 
defined based on the other packet marking layers (PML) defined above.

Within the current charter, only one packet marking layer (PML) should 
be standardized as well as only one admission control and flow 
termination layer (ACFTL), presumably for ingress-egress aggregates. 
However, it is desirable that the architecture is extensible towards 
other admission control and flow termination layers (ACFTL) to address 
the need of various network architectures (e.g., without explicit 
aggregates, with multipath routing, with centralized control nodes, ...) 
that need QoS support in the future.

Note: this text does not contradict the current version of the 
architecture draft. Essentially, the packet marking behavior of interior 
nodes is put into a packet marking layer and the admission control and 
flow termination behavior of edge nodes is put into an admission control 
and flow termination layer. The two-layer approach just makes the idea 
more explicit that different edge node behaviors may be defined for a 
single interior node behavior and that several edge node behaviors may 
coexist in the same network if necessary.

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: "Geib, Ruediger" <[email-masked]>
Date: Wed, 12 Dec 2007 09:12:49 +0100

Hello Michael,

your proposal is in principle allright with me. If felt to be 
useful by others to, I don't object to making it part of a 
suitable WG document.

One concern and a second question for clarification:

- does there need to be a little text covering a multi domain
  PML case? This case would require interoperable ACFTL, I 
  assume.

Your text on MPLS:
' o E3Tunnel
    Given: edge-to-edge MPLS tunnels;
    Egress node measures CLE for tunnel and depending on 
    that value,...'

If you measure CLE for a tunnel at the egress, you assume 
presence of a RSVP TE signaled tunnel. I assume. If so, I'd 
appreciate the text mentioning RSVP TE explicitely.

Regards,

Rudiger

|-----Original Message-----
|From: Michael Menth [mailto:[email-masked]]
|Sent: Tuesday, December 11, 2007 11:06 PM
|To: pcn
|Subject: [PCN] A two-layer approach for PCN
|
|
|Hi all,
|
|during last week's meeting I had discussions with many people 
|regarding 
|a separation of packet marking vs. admission control and flow 
|termination aspects. The intention was to make the structure 
|of PCN more 
|obvious and to facilitate its adaptation to various network 
|architectures. The following text reflects the outcome of 
|these discussions.
|
|Comments are welcome.
|
|Regards,
|
|    Michael
|
|--
|
|The pre-congestion notification (PCN) architecture consists of two 
|different layers: the packet marking layer (PML) and the admission 
|control and flow termination layer (ACFTL).
|The packet marking layer (PML) describes how PCN-capable 
|interior nodes 
|meter and mark PCN packets. Within a single network only one packet 
|marking layer (PML) MUST be deployed, i.e. PCN-capable interior nodes 
|MUST implement the same metering and marking behavior for all 
|links. The 
|admission control and flow termination layer (ACFTL) describes how PCN 
|edge nodes make use of the packet markings observed by the PCN egress 
|node to decide whether new flows can be accepted or whether already 
|admitted flows need to be terminated. The implementation of the 
|admission control and flow termination layer (ACFTL) may take 
|advantage 
|of specific transport architectures and may be tailored for various 
|signaling architectures with which it needs to interoperate. 
|In contrast 
|to the packet marking layer (PML), different instances 
|admission control 
|and flow termination layers (ACFTL) MAY be used in the same network as 
|long as they interpret the semantics of the packet markings in 
|the same 
|way and don't lead to unfairness issues.
|
|
|                       +---+---+---+---+
|                       | A | A | . | A |
|                       | C | C | . | C |
|                       | F | F | . | F |
|                       | T | T | . | T |
|                       | L | L | . | L |
|                       |   |   |   |   |
|                       | 0 | 1 | . | n |
|                       +---+---+---+---+
|                       |      PML      |
|                       +---------------+
|
|Figure 1: Within a single network, only one packet marking layer (PML)
|         MUST be deployed, but several admission control and flow
|         termination layers (ACFTL) MAY coexist.
|
|In the following, the concepts of the packet marking layer (PML) and 
|admission control and flow termination layer (ACFTL) are briefly 
|illustrated.
|
|4 examples of mutually exclusive interior node behaviors for 
|implementation of the PML:
|
|a) Ramp marking based on the admissible rate and excess-rate marking 
|based on the supportable rate (CL proposal)
|b) Threshold marking based on the admissible rate and excess-rate 
|marking with marking frequency reduction based on the supportable rate 
|(3sm proposal)
|c) Threshold marking based on the admissible rate and excess-rate 
|marking based on the supportable rate (behavioral intersection 
|of CL and 
|3sm proposal)
|d) Excess rate marking based on the admissible rate (Single Marking 
|proposal)
|
|Note that only one packet marking layer (PML) can be deployed within a 
|single network.
|
|
|3 examples for different edge node behaviors for implementation of the 
|admission control and flow termination layer (ACFTL) based on 
|the packet 
|marking layer b) above:
|
| o E3Tunnel
|   Given: edge-to-edge MPLS tunnels;
|   Egress node measures CLE for tunnel and depending on that value, it 
|sends an "admission-stop" or "admission-continue" message to the 
|corresponding ingress node that then stops or continues admitting 
|further flows.
|   Flows are terminated when one of its packets was ET-marked.
| o End2PS
|   Given: end-to-end on-path signalling protocol;
|   PCN egress node is a RSVP capable node and returns PATHERR if first 
|PATH msg was "admission-stop" marked; PCN ingress node accepts 
|all flows 
|whose RESV messages come through. 
|   Flows are terminated when one of its packets was ET-marked: the PCN 
|egress node sends a RESVTEAR message to the PCN ingress.
| o Centralized node
|   Given: centralized node (CN) in charge of admitting or 
|terminating flows;
|   Upon a new flow arrival, the CN issues an admission request to PCN 
|ingress node for a future data flow with an indicated 
|source-destination 
|tuple;
|   CN sends a probe packet to the PCN egress node which returns the 
|probe to the CN; the CN rejects the flow if probe was marked 
|and admits 
|it if probe was unmarked.
|   Flows are terminated when one of its packets was ET-marked. The PCN 
|egress node sends the marked packet to the CN which terminated the 
|corresponding flow.
|
|These admission control and flow termination layers (ACFTL) MAY 
|simultaneously be applied in the same network. Similar methods can be 
|defined based on the other packet marking layers (PML) defined above.
|
|Within the current charter, only one packet marking layer (PML) should 
|be standardized as well as only one admission control and flow 
|termination layer (ACFTL), presumably for ingress-egress aggregates. 
|However, it is desirable that the architecture is extensible towards 
|other admission control and flow termination layers (ACFTL) to address 
|the need of various network architectures (e.g., without explicit 
|aggregates, with multipath routing, with centralized control 
|nodes, ...) 
|that need QoS support in the future.
|
|Note: this text does not contradict the current version of the 
|architecture draft. Essentially, the packet marking behavior 
|of interior 
|nodes is put into a packet marking layer and the admission control and 
|flow termination behavior of edge nodes is put into an 
|admission control 
|and flow termination layer. The two-layer approach just makes the idea 
|more explicit that different edge node behaviors may be defined for a 
|single interior node behavior and that several edge node behaviors may 
|coexist in the same network if necessary.
|
|-- 
|Dr. Michael Menth, Assistant Professor
|University of Wuerzburg, Institute of Computer Science
|Am Hubland, D-97074 Wuerzburg, Germany, room B206
|phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
|mailto:[email-masked]
|http://www3.informatik.uni-wuerzburg.de/research/ngn
|
|
|
|_______________________________________________
|PCN mailing list
[email-masked]
|https://www1.ietf.org/mailman/listinfo/pcn
|

---

From: Michael Menth <[email-masked]>
Date: Wed, 12 Dec 2007 09:45:19 +0100

Hi Ruediger,

>   PML case? This case would require interoperable ACFTL, I 

Well, so far, we haven't really considered interdomain-PCN and it is not 
yet clear how and whether it works and the two-layer description is 
orthogonal to the aspect of interdomain-PCN. Nevertheless, 
interdomain-PCN would require a single packet marking layer (PML) and 
admission control and flow termination layers (ACFTL) at the end (?) 
nodes that make consistent use of the packet markings. That is probably 
what you mean and I share your view. However, I don't know how these 
ACFTL look like.

> appreciate the text mentioning RSVP TE explicitely.

This does not hold only for RSVP TE tunnels, other tunnels, e.g. 
manually configured tunnels are also appropriate as long as they are 
carried over a single (explicit) path. But E3Tunnel is just an example 
anyway.

Regards,

    Michael

---

From: "Geib, Ruediger" <[email-masked]>
Date: Wed, 12 Dec 2007 10:33:16 +0100

Hi Michael,

|> Your text on MPLS:
|> ' o E3Tunnel
|>     Given: edge-to-edge MPLS tunnels;
|>     Egress node measures CLE for tunnel and depending on 
|>     that value,...'
|>
|> If you measure CLE for a tunnel at the egress, you assume 
|> presence of a RSVP TE signaled tunnel. I assume. If so, I'd 
|> appreciate the text mentioning RSVP TE explicitely.
|>   
|
|This does not hold only for RSVP TE tunnels, other tunnels, e.g. 
|manually configured tunnels are also appropriate as long as they are 
|carried over a single (explicit) path. But E3Tunnel is just an example 
|anyway.

My point is the distinction from Label Switched Paths established 
by LDP. LDP sets up multipoint to point tunnels. Your text describes 
a solution valid for point to point tunnels, doesn't it? If yes, may 
be a sentence mentioning that this scenario holds for point to point 
tunnels may be helpful.

Regards,

Rudiger

|> |-----Original Message-----
|> |From: Michael Menth [mailto:[email-masked]]
|> |Sent: Tuesday, December 11, 2007 11:06 PM
|> |To: pcn
|> |Subject: [PCN] A two-layer approach for PCN
|> |
|> |
|> |Hi all,
|> |
|> |during last week's meeting I had discussions with many people 
|> |regarding 
|> |a separation of packet marking vs. admission control and flow 
|> |termination aspects. The intention was to make the structure 
|> |of PCN more 
|> |obvious and to facilitate its adaptation to various network 
|> |architectures. The following text reflects the outcome of 
|> |these discussions.
|> |
|> |Comments are welcome.
|> |
|> |Regards,
|> |
|> |    Michael
|> |
|> |--
|> |
|> |The pre-congestion notification (PCN) architecture consists of two 
|> |different layers: the packet marking layer (PML) and the admission 
|> |control and flow termination layer (ACFTL).
|> |The packet marking layer (PML) describes how PCN-capable 
|> |interior nodes 
|> |meter and mark PCN packets. Within a single network only one packet 
|> |marking layer (PML) MUST be deployed, i.e. PCN-capable 
|interior nodes 
|> |MUST implement the same metering and marking behavior for all 
|> |links. The 
|> |admission control and flow termination layer (ACFTL) 
|describes how PCN 
|> |edge nodes make use of the packet markings observed by the 
|PCN egress 
|> |node to decide whether new flows can be accepted or whether already 
|> |admitted flows need to be terminated. The implementation of the 
|> |admission control and flow termination layer (ACFTL) may take 
|> |advantage 
|> |of specific transport architectures and may be tailored for various 
|> |signaling architectures with which it needs to interoperate. 
|> |In contrast 
|> |to the packet marking layer (PML), different instances 
|> |admission control 
|> |and flow termination layers (ACFTL) MAY be used in the same 
|network as 
|> |long as they interpret the semantics of the packet markings in 
|> |the same 
|> |way and don't lead to unfairness issues.
|> |
|> |
|> |                       +---+---+---+---+
|> |                       | A | A | . | A |
|> |                       | C | C | . | C |
|> |                       | F | F | . | F |
|> |                       | T | T | . | T |
|> |                       | L | L | . | L |
|> |                       |   |   |   |   |
|> |                       | 0 | 1 | . | n |
|> |                       +---+---+---+---+
|> |                       |      PML      |
|> |                       +---------------+
|> |
|> |Figure 1: Within a single network, only one packet marking 
|layer (PML)
|> |         MUST be deployed, but several admission control and flow
|> |         termination layers (ACFTL) MAY coexist.
|> |
|> |In the following, the concepts of the packet marking layer 
|(PML) and 
|> |admission control and flow termination layer (ACFTL) are briefly 
|> |illustrated.
|> |
|> |4 examples of mutually exclusive interior node behaviors for 
|> |implementation of the PML:
|> |
|> |a) Ramp marking based on the admissible rate and 
|excess-rate marking 
|> |based on the supportable rate (CL proposal)
|> |b) Threshold marking based on the admissible rate and excess-rate 
|> |marking with marking frequency reduction based on the 
|supportable rate 
|> |(3sm proposal)
|> |c) Threshold marking based on the admissible rate and excess-rate 
|> |marking based on the supportable rate (behavioral intersection 
|> |of CL and 
|> |3sm proposal)
|> |d) Excess rate marking based on the admissible rate (Single Marking 
|> |proposal)
|> |
|> |Note that only one packet marking layer (PML) can be 
|deployed within a 
|> |single network.
|> |
|> |
|> |3 examples for different edge node behaviors for 
|implementation of the 
|> |admission control and flow termination layer (ACFTL) based on 
|> |the packet 
|> |marking layer b) above:
|> |
|> | o E3Tunnel
|> |   Given: edge-to-edge MPLS tunnels;
|> |   Egress node measures CLE for tunnel and depending on 
|that value, it 
|> |sends an "admission-stop" or "admission-continue" message to the 
|> |corresponding ingress node that then stops or continues admitting 
|> |further flows.
|> |   Flows are terminated when one of its packets was ET-marked.
|> | o End2PS
|> |   Given: end-to-end on-path signalling protocol;
|> |   PCN egress node is a RSVP capable node and returns 
|PATHERR if first 
|> |PATH msg was "admission-stop" marked; PCN ingress node accepts 
|> |all flows 
|> |whose RESV messages come through. 
|> |   Flows are terminated when one of its packets was 
|ET-marked: the PCN 
|> |egress node sends a RESVTEAR message to the PCN ingress.
|> | o Centralized node
|> |   Given: centralized node (CN) in charge of admitting or 
|> |terminating flows;
|> |   Upon a new flow arrival, the CN issues an admission 
|request to PCN 
|> |ingress node for a future data flow with an indicated 
|> |source-destination 
|> |tuple;
|> |   CN sends a probe packet to the PCN egress node which returns the 
|> |probe to the CN; the CN rejects the flow if probe was marked 
|> |and admits 
|> |it if probe was unmarked.
|> |   Flows are terminated when one of its packets was 
|ET-marked. The PCN 
|> |egress node sends the marked packet to the CN which terminated the 
|> |corresponding flow.
|> |
|> |These admission control and flow termination layers (ACFTL) MAY 
|> |simultaneously be applied in the same network. Similar 
|methods can be 
|> |defined based on the other packet marking layers (PML) 
|defined above.
|> |
|> |Within the current charter, only one packet marking layer 
|(PML) should 
|> |be standardized as well as only one admission control and flow 
|> |termination layer (ACFTL), presumably for ingress-egress 
|aggregates. 
|> |However, it is desirable that the architecture is 
|extensible towards 
|> |other admission control and flow termination layers (ACFTL) 
|to address 
|> |the need of various network architectures (e.g., without explicit 
|> |aggregates, with multipath routing, with centralized control 
|> |nodes, ...) 
|> |that need QoS support in the future.
|> |
|> |Note: this text does not contradict the current version of the 
|> |architecture draft. Essentially, the packet marking behavior 
|> |of interior 
|> |nodes is put into a packet marking layer and the admission 
|control and 
|> |flow termination behavior of edge nodes is put into an 
|> |admission control 
|> |and flow termination layer. The two-layer approach just 
|makes the idea 
|> |more explicit that different edge node behaviors may be 
|defined for a 
|> |single interior node behavior and that several edge node 
|behaviors may 
|> |coexist in the same network if necessary.
|> |
|> |-- 
|> |Dr. Michael Menth, Assistant Professor
|> |University of Wuerzburg, Institute of Computer Science
|> |Am Hubland, D-97074 Wuerzburg, Germany, room B206
|> |phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
|> |mailto:[email-masked]
|> |http://www3.informatik.uni-wuerzburg.de/research/ngn
|> |
|> |
|> |
|> |_______________________________________________
|> |PCN mailing list
|> [email-masked]
|> |https://www1.ietf.org/mailman/listinfo/pcn
|> |
|>   
|
|-- 
|Dr. Michael Menth, Assistant Professor
|University of Wuerzburg, Institute of Computer Science
|Am Hubland, D-97074 Wuerzburg, Germany, room B206
|phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
|mailto:[email-masked]
|http://www3.informatik.uni-wuerzburg.de/research/ngn
|
|

---

From: Michael Menth <[email-masked]>
Date: Wed, 12 Dec 2007 11:01:26 +0100

Hi Ruediger,

please see inline!

> be a sentence mentioning that this scenario holds for point to point 

Ok, now I see your point. You are right: multipoint-to-point tunnels set 
up by LDP do not match the E3Tunnel example since these tunnel 
structures are not (single)edge-to-(single)edge. In general, with 
multipoint-to-point tunnels it becomes harder than with point-to-point 
tunnels to map the packets at the PCN egress node  to the corresponding 
PCN ingress node, I think.

Regards,

    Michael

---

From: <[email-masked]>
Date: Thu, 13 Dec 2007 15:25:10 -0000

Michael

Michael,
Thanks for this. I'll work some clarification into the Arch draft on the
lines of the first half of your email (probably without introducing any
new terms & abbreviations).

The second part about examples of marking and edge behaviours I don't
think is needed, as already elsewhere or planned to be. The marking
behaviour is hinted at in the doc, and is captured fully in the charny
comparison draft. The edge behaviours again I think is hinted at, and
will come out further during work on that milestone.
Your comments made me realise that the list of bullets (in the Intro fo
the draft) preceded by "Several deployment models are possible:"
actually includes several different types of things - different
signalling architectures, diff OAM issues, diff data plane issues. So
I'll try & tidy this all up and also mention the 3 'edge behaviour'
cases you talk about (though probably in less detail)

Next version of arch draft will be until after Christmas, probably end
of Jan. 

Ps In the meantime, we're also thinking more about ECN-PCN interactions,
so there should be some better text about that as well.

Thanks
Phil/

> -----Original Message-----
> From: Michael Menth [mailto:[email-masked]]
> Sent: 11 December 2007 22:06
> To: pcn
> Subject: [PCN] A two-layer approach for PCN
> 
> Hi all,
>