Subject: [PCN] possibilities of combining LC-PCN and SM (in at least PCN-interior nodes)

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 6 Feb 2008 14:26:23 +0100

Hi all

After having some discussion off line with Anna, I think that it would be
possible to at least
combine the SM and LC-PCN features in the PCN-interior nodes!

Please note that the below description does not describe how the use of the
probing functionality 
during admission control and the use of affected marking for ECMP solution
during flow termination 
should be performed. These two features can be added as optional, later on.

* U is specified as in the SM draft!
* N is specified as in the LC-PCN draft

* Features in the PCN_interior_node:
------------------------
The excess rate measurement is done in a similar way as is
done for SM, but the measurement should be done before drop 
but PCN_marking should be done after drop. 
This means that marked packets are preferentially not dropped.

Furthermore the constant N should be used such that the
marked excess rate can represent also high level of excess rate. The
calculated excess rate should be divided by N (when N>=1)

This can be implemented in SM by marking every N-th packet (or rather byte)
instead 
of marking each packet (or byte)

* Features in the PCN_egress_node
------------------------
The admission decision is similar to SM, based on the CLE, by measuring
the rate of the received PCN_marked packets and by multiplying it by
N. When CLE higher than a predefined/preconfigured threshold, e.g.,
1% then in admission state.

The PCN_egress_node informs the PCN_ingress node that the
requesting flow is admitted or rejected (if in admission control state)
The above feature is not an SM feature.

When CLE is above a predefined/preconfigured percentage, e.g., 10%,
then the PCN_egress_node goes in flow termination state.

Note that this state does not exist for SM at the egress.

The calculated excess rate above the flow termination
threshold is used to calculate how many flows should be terminated. Before 
calculating the number of flows to be terminated the calculated 
excess rate above the flow termination threshold have to be divided with the
constant U. 

For the flows that should be terminated the PCN_egress_node informs
the PCN_ingress_node to terminate them.

* Features in the PCN_ingress_node
------------------------
In Admission control:
-----------------
Admits or rejects the flow depending on the sent report by
the egress
This feature is not a SM feature

In Flow termination:
--------------------
The flows that are termination notified by the PCN_egress node have
to be terminated by PCN_ingress node. In addition the PCN_ingress
node informs the associated flow sender about the problem.
This feature is not a SM feature

Best regards,
Georgios

_______________________________________________
PCN mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/pcn

---

From: "Anna Charny (acharny)" <[email-masked]>
Date: Wed, 6 Feb 2008 10:36:48 -0500

Hi Georgios,

Some questions below:

1) Is marking every Nth packet at the interior node any different from
Joe's slow-down S factor he uses for termination in 3sm? 

2) Suppose configured ( admission) threshold is 0.3 of the link speed,
and U is 5/3 (so it effectively brings the implicit termination
threshold to 0.5 of the link speed). Suppose the load on the link is
exactly equal to link speed, and for the moment assume you mark ever
packet (so N=1).  Then 0.7 of all traffic will be marked.  When you
divide it by U at the egress, you will end up deciding that your
effective termination threshold is 21/50, wherease you wanted it to be
0.5?
Not sure I understand exactly how it all works together?

3) What happens if some of the marked traffic gets dropped?  

4) Could you summarize performance or other benefit of the proposed
mechanism compared to SM and other proposed mechanisms?

5) will there be an update on the LC-PCN draft?

Thank you,
Anna 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Georgios Karagiannis
> Sent: Wednesday, February 06, 2008 8:26 AM
> To: [email-masked]
> Subject: [PCN] possibilities of combining LC-PCN and SM (in 
> at leastPCN-interior nodes)
> 
> Hi all
> 
> After having some discussion off line with Anna, I think that 
> it would be possible to at least combine the SM and LC-PCN 
> features in the PCN-interior nodes!
> 
> Please note that the below description does not describe how 
> the use of the probing functionality during admission control 
> and the use of affected marking for ECMP solution during flow 
> termination should be performed. These two features can be 
> added as optional, later on.
> 
> 
> 
> marked excess rate can represent also high level of excess 
> rate. The calculated excess rate should be divided by N (when N>=1)
> 
> This can be implemented in SM by marking every N-th packet 
> (or rather byte) instead of marking each packet (or byte)
> 
>

---

From: <[email-masked]>
Date: Wed, 6 Feb 2008 15:43:29 -0000

Hi Georgios

Your email looks interesting, but I am struggling. I thought that lc-pcn
did admission-marking, termination-marking & affected-marking. However,
below it sounds like you're now just doing single-marking &
affected-marking??? Are you simply saying that affected marking could be
added to SM, just as it could be added to AM/TM?? (if so, my reaction
is: sure. The pros and cons of doing this look the same in both cases to
me.)

I'm trying to understand if you've come up with new behaviour (at
ingress/edge) or have just discovered a 1:1 mapping between lc-pcn &
single marking. All the things you mention as "not a SM feature" seem
not significant to me (eg " PCN_ingress node informs the associated flow
sender about the problem" - well, this could be done with any PCN
mechanism, but is really in scope of signalling protocol & out of scope
of pcn mechanism)

Is there a revised lc-pcn description that clears up some of the issues
raised with the previous version?

Thanks
phil

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Georgios Karagiannis
> Sent: 06 February 2008 13:26
> To: [email-masked]
> Subject: [PCN] possibilities of combining LC-PCN and SM (in at
leastPCN-
> interior nodes)
> Please note that the below description does not describe how the use
of
> the
> should be performed. These two features can be added as optional,
later
> on.
> excess rate above the flow termination threshold have to be divided
with
> the

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 6 Feb 2008 17:14:02 +0100

Hi Phil

LC-PCN does AM/TM and affected marking.
 
After I had some discussions I with Anna, I thought that 
we came up with a 1:1 mapping between SM and LC-PCN. 
However, from the reply of Anna, I can conclude that 
this might not be the case!

I have to find out if Anna and I (off line) 
could come to such a 1:1 mapping!

Regarding LC-PCN, I think that currently are no any open issues!

I thought that all issues were worked out already in version 02!

Best regards,
Georgios

> From: [email-masked] [mailto:[email-masked]] 
> Sent: woensdag 6 februari 2008 16:43
> To: [email-masked]; [email-masked]
> Subject: RE: [PCN] possibilities of combining LC-PCN and SM 
> (in at leastPCN-interior nodes)
> 
> Hi Georgios
> 
> Your email looks interesting, but I am struggling. I thought 
> that lc-pcn did admission-marking, termination-marking & 
> affected-marking. However, below it sounds like you're now 
> just doing single-marking & affected-marking??? Are you 
> simply saying that affected marking could be added to SM, 
> just as it could be added to AM/TM?? (if so, my reaction
> ingress/edge) or have just discovered a 1:1 mapping between 
> lc-pcn & single marking. All the things you mention as "not a 
> SM feature" seem not significant to me (eg " PCN_ingress node 
> informs the associated flow sender about the problem" - well, 
> this could be done with any PCN mechanism, but is really in 
> scope of signalling protocol & out of scope of pcn mechanism)
> 
> Is there a revised lc-pcn description that clears up some of 
> the issues raised with the previous version?
> 
> Thanks
> phil
> 
> > After having some discussion off line with Anna, I think 
> that it would
> be
> > possible to at least
> > The excess rate measurement is done in a similar way as is done for 
> > SM, but the measurement should be done before drop but PCN_marking 
> > should be done after drop.
> marked excess 
> > rate can represent also high level of excess rate. The calculated 
> > excess rate should be divided by N (when N>=1)
> > 
> (or rather
> > byte)
> > N. When CLE higher than a predefined/preconfigured 
> threshold, e.g., 1% 
> > then in admission state.
> > 
> requesting 
> > flow is admitted or rejected (if in admission control
> state)
> > The calculated excess rate above the flow termination threshold is 
> > used to calculate how many flows should be terminated.
> Before
> > calculating the number of flows to be terminated the 
> calculated excess 
> > rate above the flow termination threshold have to be divided
> with
> > the
> > constant U.
> > 
> > 
> > The flows that are termination notified by the PCN_egress 
> node have to 
> > be terminated by PCN_ingress node. In addition the PCN_ingress node 
> > informs the associated flow sender about the problem.