Subject: [PCN] Fwd: I-D Action:draft-chan-pcn-encoding-comparison-02.txt

From: "Kwok-Ho Chan" <[email-masked]>
Date: Fri, 08 Feb 2008 00:24:10 -0500

Hi all:
Please notice the posting of the new PCN Encoding Comparison draft.
With moving of some of the text into the appendix, there are about
10 pages of main text in this latest version.
Please review and provide comments on the list.

Thank you and have a Wonderful Chinese New Year!
(Thur Feb 7, 2008 first day of the Chinese New Year)
-- Kwok --

>X-Virus-Scanned: amavisd-new at amsl.com
>X-Original-To: [email-masked]
>Delivered-To: [email-masked]
>To: [email-masked]
>Cc:
>From: [email-masked]
>Subject: I-D Action:draft-chan-pcn-encoding-comparison-02.txt
>Date: Thu,  7 Feb 2008 15:45:01 -0800 (PST)
>X-BeenThere: [email-masked]
>X-Mailman-Version: 2.1.9
>Reply-To: [email-masked]
>List-Id: <i-d-announce.ietf.org>
>List-Unsubscribe: <http://www.ietf.org/mailman/listinfo/i-d-announce>,
>  <mailto:[email-masked]?subject=unsubscribe>
>List-Archive: <http://www.ietf.org/pipermail/i-d-announce>
>List-Post: <mailto:[email-masked]>
>List-Help: <mailto:[email-masked]?subject=help>
>List-Subscribe: <http://www.ietf.org/mailman/listinfo/i-d-announce>,
>  <mailto:[email-masked]?subject=subscribe>
>Sender: [email-masked]
>X-Spam-Tests: MIME_BOUND_NEXTPART=0.106,NO_REAL_NAME=0.178,TO_CC_NOT_NORTEL=1
>X-Spam-Checker-Version: SpamAssassin 3.0.4 (2005-06-05) on ertph000.nortel.com
>X-Spam-Score: 1.3
>X-DNSBL-Score: 0
>X-SMTP-HELO: core3.amsl.com
>X-SMTP-MAIL-FROM: [email-masked]
>X-SMTP-RCPT-TO: 
>[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked]
>X-SMTP-PEER-INFO: core3.amsl.com [64.170.98.86]
>X-SMTP-REASON: PASSED
>X-SMTP-ID: 1202428538.03026353
>X-OriginalArrivalTime: 07 Feb 2008 23:55:39.0513 (UTC) 
>FILETIME=[F0E61690:01C869E4]
>
>A New Internet-Draft is available from the on-line Internet-Drafts 
>directories.
>
>         Title           : Pre-Congestion Notification Encoding Comparison
>         Author(s)       : K. Chan, et al.
>         Filename        : draft-chan-pcn-encoding-comparison-02.txt
>         Pages           : 28
>         Date            : 2008-02-07
>
>A number of mechanisms have been proposed to support differential
>Qualiy of Service for packets in the Internet.  DiffServ is an
>example of such a mechanism.  However, the level of assurance that
>can be provided with DiffServ without substantial over-provisioning
>is limited.  Pre-Congestion Notification (PCN) uses path congestion
>information across a PCN region to enable per-flow admission control
>to provide the required service guarantees for the admitted traffic.
>While admission control will protect the QoS under normal operating
>conditions, an additional flow termination mechanism is necessary to
>cope with extreme events (e.g. route changes due to link or node
>failure).
>
>In order to allow the PCN mechanisms to work it is necessary for IP
>packets to be able to carry the pre-congestion information to the PCN
>egress nodes.  This document explores different ways in which this
>information can be encoded into IP packets.  This document does not
>choose the encoding but provide guidance and recommendation based on
>different criteria.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-chan-pcn-encoding-comparison-02.txt
>
>To remove yourself from the I-D Announcement list, send a message to
>[email-masked] with the word unsubscribe in the body of
>the message.
>You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
>to change your subscription settings.
>
>Internet-Drafts are also available by anonymous FTP. Login with the
>username "anonymous" and a password of your e-mail address. After
>logging in, type "cd internet-drafts" and then
>         "get draft-chan-pcn-encoding-comparison-02.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>         [email-masked].
>In the body type:
>         "FILE /internet-drafts/draft-chan-pcn-encoding-comparison-02.txt".
>
>NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
>
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>
>Content-Type: text/plain
>Content-ID: <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-chan-pcn-encoding-comparison-02.txt
>
>
><ftp://ftp.ietf.org/internet-drafts/draft-chan-pcn-encoding-comparison-02.txt>
>_______________________________________________
>I-D-Announce mailing list
>[email-masked]
>http://www.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
PCN mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/pcn

---

From: "Kwok-Ho Chan" <[email-masked]>
Date: Mon, 11 Feb 2008 08:57:53 -0500

Hi all:
We are trying to have this draft be a PCN WG draft.

Please let us know what improvements are needed:
- for this draft to be a PCN WG draft and forward beyond WG draft.

And are there additional area this draft should address (or not address).

Thanks!
-- Kwok --

At 12:24 AM 2/8/2008, Kwok-Ho Chan wrote:
> >X-Spam-Tests: 
> MIME_BOUND_NEXTPART=0.106,NO_REAL_NAME=0.178,TO_CC_NOT_NORTEL=1
> >[email-masked],[email-masked],[email-masked],khchan@norte 
> l.com,[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked]