Subject: [PCN] (new) possibilities of combining LC-PCN and SM (in at least PCN-interior nodes)

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 15 Feb 2008 11:51:28 +0100

Dear all 

I have tried here, to write an updated version of the LC-PCN algorithm,
which can bring 
the SM (Single marking) and LC-PCN (Load Control -PCN) solutions closer to
each other!

Please note that the LC-PCN authors are willing to update the current
version of the LC-PCN draft
according to the below updated algorithm and to submit it to the IETF before
the deadline of 
25 February!

New description
-------------

Please note that the below description does not describe how the use of the
probing functionality 
during admission control and the use of affected marking for ECMP solution
during flow 
termination should be performed. These two features can be added as
optional, later on.

* U is specified as in the SM draft!
* N is specified as in the LC-PCN draft

* Features in the PCN_interior_node:
------------------------
The excess rate measurement is done in a similar way as is done for SM, but
the measurement should 
be done before drop but PCN_marking should be done after drop. 
This means that marked packets are preferentially not dropped.

Furthermore the constant N should be used such that the marked excess rate
can represent also 
high level of excess rate. The calculated excess rate should be divided by N
(when N>=1)

This can be implemented in SM by marking every N-th packet (or rather byte)
instead 
of marking each packet (or byte)

* Features in the PCN_egress_node
------------------------

**** Admission control:
--------------------

The admission decision is similar to SM, based on the CLE, by measuring the
rate of 
the received PCN_marked packets and by multiplying it by N. When CLE higher
than a 
predefined/preconfigured threshold, e.g., 1% then in admission state. 
See Section 2.4.1 in:
http://www.ietf.org/internet-drafts/draft-charny-pcn-single-marking-03.txt

Note that the CLE is calculated as given in Section 11.3. Appendix, in:
http://www.watersprings.org/pub/id/draft-briscoe-tsvwg-cl-architecture-04.tx
t

The PCN_egress_node informs the PCN_ingress node that the requesting flow is
admitted or 
rejected (if in admission control state).
Note that the above feature is not an SM feature.

***** Flow Termination:
-------------

In order to detect the trigger for flow termination, we use the solution 
proposed in Section 2.4.2 in the SM draft:
http://www.ietf.org/internet-drafts/draft-charny-pcn-single-marking-03.txt

The PCN_egress guard/activates the flow termination control with a trigger 
computed from the ratio of measured marked and unmarked traffic rates. Note
that 
before using the above ratio to calculate the trigger, the rate of the 
marked traffic, is multiplied by N.

Note that:

If (U * admission control threshold) at the PCN_interior nodes is configured
to be lower
than the packet dropping threshold at the PCN_interior node, then the
PCN_egress_node
can e.g., calculate the flow termination trigger in the following way:

If (marked_rate/unmarked_rate)  >=  (U - 1) 
THEN the flow termination trigger should be activated.

If (U * admission control threshold) at the PCN_interior nodes is configured
to be equal or higher
than the packet dropping threshold at the PCN_interior node, then the
PCN_egress_node
can e.g., calculate the flow termination trigger in the following way:

If (marked_rate/(unmarked_rate + marked_rate)) >=  (U - 1) 
THEN the flow termination trigger should be activated.

When this trigger is detected then the egress has to store the value of the 
absolute rate of the marked_rate traffic, say: 
PCN_upper_rate_egress

The excess rate that is above this threshold, say incoming_PCN_marking_rate 
is used to calculate the number of flows to be terminated, say: 
terminated_bandwidth.
The calculation of terminated_bandwidth is done in a similar way as 
described in Section 4.2.3 in current version of 
the LC-PCN draft.

For the flows that should be terminated the PCN_egress_node informs 
the PCN_ingress_node to terminate them.

* Features in the PCN_ingress_node
------------------------------------

****** Admission control:
-----------------
Admits or rejects the flow depending on the sent report by the egress.
This feature is not a SM feature

****** Flow termination:
--------------------
The flows that are termination notified by the PCN_egress node have to be 
terminated by PCN_ingress node. In addition the PCN_ingress node informs 
the associated flow sender about the problem.
This feature is not a SM feature.

------------------------------------------------------------

Important: Note that if probing and affected marking options are used then:

* Probing should be accomplished in the same way as described currently in
the LC-PCN draft.

* Affected Marking is used at the PCN_interior nodes in the same way as is 
currently described in LC-PCN.
At the egress, Affected Marked packets are used to select the 
flows that have to be terminated, and to calculate the flow termination
trigger, instead of using the PCN unmarked packets.

Best regards,
Georgios

_______________________________________________
PCN mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/pcn

---

From: "Anna Charny (acharny)" <[email-masked]>
Date: Fri, 15 Feb 2008 09:19:31 -0500

Georgios,

This seems to be a blend of SM and 3 SM functionality - right?  Would it
be correct to summarize this proposal as follows:

1) excess rate marking with a slowdown (as in 3sm)
2) single marking thresholds and single marking codepoint as in SM
3) preference to drop unmarked rather than marked packets (SM prefers
preferential drop of marked packets)
4) use of marked traffic rate (times the slowdown factor) vs unmarked
traffic rate at the egress to compute the amount of traffic to be
dropped (equivalent to what SM does when no loss,  not equivalent in the
presence of loss); the trigger is as in SM.
5) termintation and admission decisions done at the egress, and
signaling tells the ingress specific fows to terminate (or to stop/start
admitting). This seems to be as in 3SM.

Did I miss any other differences?

What do you see as the benefits of this proposal compared to CL, SM and
3SM?

Have any performance studies been done?

Thank you,
Anna 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Georgios Karagiannis
> Sent: Friday, February 15, 2008 5:51 AM
> To: [email-masked]
> Subject: [PCN] (new) possibilities of combining LC-PCN and SM 
> (in at leastPCN-interior nodes)
> 
> Dear all 
> 
> I have tried here, to write an updated version of the LC-PCN 
> algorithm, which can bring the SM (Single marking) and LC-PCN 
> (Load Control -PCN) solutions closer to each other!
> 
> Please note that the LC-PCN authors are willing to update the 
> current version of the LC-PCN draft according to the below 
> updated algorithm and to submit it to the IETF before the deadline of
> 25 February!
> 
> 
> New description
> -------------
>

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 15 Feb 2008 15:47:51 +0100

Hi Anna

I have not studied points 1) to 5) in detail, so I may be wrong 
in my following answers.

I think that I can agree with points 1) to 4). Regarding point 5) I do think
that 
the admission and termination decissions and calculations of the excess rate

is different than the ones specified in 3SM.

The main differeces between LC-PCN and CL/SM are:

* LC_PCN measures the excess rate that is used to provide admission control
and flow termination decissions.
CL and SM measure the troughput to calculate the number of flows that can be
terminated.

* In LC_PCN the admission control and flow termination decissions are done
by the PCN_egress!
  In CL and SM the admission control and flow termination decissions are
done by the 
PCN_egress and PCN_ingress!

The benefit of taking the decissions by the PCN_egress instead of the
PCN_ingress is that 
measurements and decissions can be done in one place/location. Thus one
entity, that in this case is the PCN_egress
can take all the required decissions. In the situations of CL and SM both
the PCN_egress and PCN_ingress are needed
to provide the same decissions.

* LC-PCN describes in detail how probing and Affected marking features can
be used.

Regarding, the main differences between LC_PCN and 3SM, in order to be able
to do that
I will have to study the last version of 3SM in more detail.
However, the differences are related to the way of how the excess rate is
used to provide admission control
and to selectthe number of flows that can be terminated. 

Regarding simulations, we have some old simulations that do not take into
account all 
PCN related requirements and asuumptions.
We need tyo redo these simulations!
It will be great if we could discuss all the simulation related issues in
Philadelphia!

Please note that I will be able to come to the 71st IETF in Philadelphia!

We will try to update the draft in time and submit it before the 25th of
February!

Bst regards,
Georgios

> From: Anna Charny (acharny) [mailto:[email-masked]] 
> Sent: vrijdag 15 februari 2008 15:20
> To: Georgios Karagiannis; [email-masked]
> Subject: RE: [PCN] (new) possibilities of combining LC-PCN 
> and SM (in at leastPCN-interior nodes)
> 
> Georgios,
> 
> This seems to be a blend of SM and 3 SM functionality - 
> right?  Would it be correct to summarize this proposal as follows:
> 
> 3) preference to drop unmarked rather than marked packets (SM 
> prefers preferential drop of marked packets)
> 4) use of marked traffic rate (times the slowdown factor) vs 
> unmarked traffic rate at the egress to compute the amount of 
> traffic to be dropped (equivalent to what SM does when no 
> loss,  not equivalent in the presence of loss); the trigger 
> is as in SM.
> 5) termintation and admission decisions done at the egress, 
> and signaling tells the ingress specific fows to terminate 
> (or to stop/start admitting). This seems to be as in 3SM.
> 
> What do you see as the benefits of this proposal compared to 
> CL, SM and 3SM?
> 
> > Subject: [PCN] (new) possibilities of combining LC-PCN and 
> SM (in at 
> > leastPCN-interior nodes)
> > 
> > Dear all
> > 
> > algorithm, which can bring the SM (Single marking) and LC-PCN (Load 
> > Control -PCN) solutions closer to each other!
> > 
> > version of the LC-PCN draft according to the below updated 
> algorithm 
> > and to submit it to the IETF before the deadline of
> > 25 February!
> > 
> > 
> > New description
> > -------------
> > 
> > Please note that the below description does not describe 
> how the use 
> > of the probing functionality during admission control and 
> the use of 
> > affected marking for ECMP solution during flow termination 
> should be 
> > performed. These two features can be added as optional, later on.
> > 
> > 
> > The excess rate measurement is done in a similar way as is done for 
> > SM, but the measurement should be done before drop but PCN_marking 
> > should be done after drop.
> > Furthermore the constant N should be used such that the 
> marked excess 
> > rate can represent also high level of excess rate. The calculated 
> > excess rate should be divided by N (when N>=1)
> > 
> > This can be implemented in SM by marking every N-th packet 
> (or rather 
> > byte) instead of marking each packet (or byte)
> > 
> > 
> > The admission decision is similar to SM, based on the CLE, by 
> > measuring the rate of the received PCN_marked packets and by 
> > multiplying it by N.
> > When CLE higher
> > than a
> > The PCN_egress_node informs the PCN_ingress node that the 
> requesting 
> > flow is admitted or rejected (if in admission control state).
> > In order to detect the trigger for flow termination, we use the 
> > solution proposed in Section 2.4.2 in the SM draft:

---

From: Michael Menth <[email-masked]>
Date: Mon, 18 Feb 2008 16:33:30 +0100

Hi Georgios,

> to provide the same decissions.

Is that what we called direct and indirect measured rate termination in 
Section 5 of our performance draft?
http://www.ietf.org/internet-drafts/draft-menth-pcn-performance-01.txt

Further details see Section 4 of
http://www3.informatik.uni-wuerzburg.de/staff/menth/Publications/Menth07-PCN-Eval.pdf

Regards,

    Michael

>> Behalf Of 
>>> Georgios Karagiannis
>>> Please note that the LC-PCN authors are willing to update 
>>>       
>> the current 
>>     
>>> predefined/preconfigured threshold, e.g., 1% then in 
>>>       
>> admission state. 
>>     
>>> See Section 2.4.1 in:
>>> http://www.ietf.org/internet-drafts/draft-charny-pcn-single-ma
>>>       
>> rking-03.txt
>>     
>>> http://www.watersprings.org/pub/id/draft-briscoe-tsvwg-cl-arch
>>>       
>> itecture-04.tx
>>     
>>> t
>>>
>>>
>>>
>>> http://www.ietf.org/internet-drafts/draft-charny-pcn-single-ma
>>>       
>> rking-03.txt
>>     
>>> than the packet dropping threshold at the PCN_interior 
>>>       
>> node, then the
>>     
>>> PCN_egress_node
>>> can e.g., calculate the flow termination trigger in the 
>>>       
>> following way:
>>     
>>> than the packet dropping threshold at the PCN_interior 
>>>       
>> node, then the
>>     
>>> PCN_egress_node
>>> can e.g., calculate the flow termination trigger in the 
>>>       
>> following way:
>>     
>>> Admits or rejects the flow depending on the sent report by 
>>>       
>> the egress.
>>     

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn