Subject: [PCN] Fwd: [NSIS] Status update about GIST

From: "[email-masked]" <[email-masked]>
Date: Wed, 28 May 2008 09:37:52 -0400

There had been a discussion on the use of RAO on this list prior to  
the Philly IETF, so its probably constructive to forward the following  
from the NSIS list.

-ken

Begin forwarded message:

> From: "Hancock, Robert" <[email-masked]>
> Date: May 28, 2008 8:40:37 AM EDT
> To: <[email-masked]>, <[email-masked]>, <[email-masked] 
> >
> Subject: Re: [NSIS] Status update about GIST
>
> john,
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of [email-masked]
>> Sent: 28 May 2008 03:19
>> To: [email-masked]; [email-masked]
>> Subject: Re: [NSIS] Status update about GIST
>>
>> Martin,
>>
>> Does this mean that the use RAO is basically thought of as a bad  
>> thing
>> by the IESG?
>
> my interpretation of the discussion is that:
>
> IF your protocol
> * uses RAO, and
> * has any likelihood of significant deployment on the Internet
>  (where "significant" is defined as "more than RSVP for QoS")
> THEN
> * it will be experimental
>
> ... at least for IPv4. the IPv6 case is (at least to me) much
> less clear cut: theoretically/architecturally they should be
> the same, but the practical/engineering issues are quite different.
>
> one of the routing ADs is going to write a draft explaining this.
>
> robert h.
>
>>
>> John
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of
>> ext Martin Stiemerling
>> Sent: Tuesday, May 27, 2008 6:36 PM
>> To: nsis
>> Subject: [NSIS] Status update about GIST
>>
>> Hi all,
>>
>> It has been a bit silent the last weeks about what is
>> actually happening
>> with GIST. You might still remember that GIST go sent to the IESG and
>> underwent the IESG review and discussion.
>>
>> The GIST spec got quite an amount of ABSTAINS during the IESG
>> review and
>> therefore is blocked. Most of the IESG members have had concerns  
>> about
>> GIST and this led to the ABSTAINS.
>>
>> However, to get things progressed, Magnus initiated a joint telechat
>> between the IESG, Robert, Henning and me to discuss the ABSTAINS. The
>> call took place on Thursday, May 15, 5:30 pm CEST. Here is
>> brief summary
>> (that reassembles my memory):
>>
>> The discussion with the IESG centered around the Router Alert
>> Options in
>> IPv4 but also touching IPv6. The general concern about thiss is that
>> NSIS could lead to a flood of IP packets including IP RAO options and
>> that this could effect existing RSVP-TE deployments, plus all current
>> routers (as IP options go to the slow path), and finally that packets
>> with RAO options are anyhow filtered at the edges of the
>> Internet. This
>> cause most of the ABSTAINS and the call for GIST being pushed to the
>> experimental track instead the standards track.
>>
>> The issues associated with RAO were discussed for quite some while (I
>> remember 1 hours or so) and we couldn't find any agreement
>> for the IESG
>> on staying with RAO as part of the GIST spec AND going for standards
>> track. The envisioned solutions to this is, revert to packet  
>> filtering
>> mechanism (e.g. 5-tuple) to intercept GIST packets, instead of RAO,  
>> in
>> the GIST specification. This would be allowed to go GIST as standard
>> track. The RAO part will be cut out of the GIST spec and pushed to a
>> separate document. This new document will go on experimental track.
>>
>> This splitting will also effect the NSLPs, as they are also
>> definin RAO
>> usage.
>>
>>  Martin
>>
>>
>>
>> [email-masked]
>>
>> NEC Laboratories Europe - Network Research Division NEC
>> Europe Limited |
>> Registered Office: NEC House, 1 Victoria Road, London W3 6BL |
>> Registered in England 2832014
>> _______________________________________________
>> nsis mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/nsis
>> _______________________________________________
>> nsis mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/nsis
>>
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nsis

_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: "Hancock, Robert" <[email-masked]>
Date: Wed, 28 May 2008 14:47:02 +0100

ken,
 
indeed - i'd forgotten the PCN discussions on this.
 
however, it's worth pointing out that there's potentially a difference
of applicability of the argument in the PCN case. In my understanding of
PCN, it will only get implemented in a per-operator-domain-internal
fashion, so an operator will be free to deploy PCN or not depending on
their confidence in the RAO implementations of their current routers;
and deploying PCN in one domain won't cause RAO-related problems for
anyone else.
 
whether or not that's a real difference i can't say. but my
recommendation would be:
- make sure that any base spec does not depend on RAO
- for anything that does depend on RAO, ask for AD guidance early (e.g.
now)
 
robert h.

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
	Sent: 28 May 2008 14:38
	To: [email-masked]
	Subject: [PCN] Fwd: [NSIS] Status update about GIST

	There had been a discussion on the use of RAO on this list prior
to the Philly IETF, so its probably constructive to forward the
following from the NSIS list. 

	-ken

	Begin forwarded message:

		From: "Hancock, Robert" <[email-masked]>
		Date: May 28, 2008 8:40:37 AM EDT
		To: <[email-masked]>,
<[email-masked]>, <[email-masked]>
		Subject: Re: [NSIS] Status update about GIST

		john, 

			-----Original Message-----

			From: [email-masked]
[mailto:[email-masked]] On 

			Sent: 28 May 2008 03:19

			Martin,

			Does this mean that the use RAO is basically
thought of as a bad thing

			by the IESG?

		IF your protocol
		* uses RAO, and
		* has any likelihood of significant deployment on the
Internet
		 (where "significant" is defined as "more than RSVP for
QoS")
		THEN 
		* it will be experimental
		
		... at least for IPv4. the IPv6 case is (at least to me)
much
		less clear cut: theoretically/architecturally they
should be
		the same, but the practical/engineering issues are quite
different.
		
		one of the routing ADs is going to write a draft
explaining this.
		
		robert h.
		
		[[reh]] [other stuff snipped]