Subject: [PCN] comment about edge bahviour of draft-satoh-pcn-st-marking-01

From: SATOH Daisuke <[email-masked]>
Date: Mon, 23 Mar 2009 15:58:19 +0900

Hi Phil,

> 
> hi daisuke
> 
> quick email about this, maybe more when more time to type
> 
> looking at teh edge behaviour of your proposal.
> 
> as regards admission control, it seems to me this must be identical to SM. the marking is identical 
> 

I think so although I have not think of it deeply yet.

> as reagrds termination of flows, this is different in 2 ways
> 
> 1. you have a clearer signal that terminatin may be needed nb "may" - as you mark 100% if the link is above its pcn-sustainable-rate.
> 
> 2. you terminate slower, rather than in one shot.
> 
> i dont know whether 1 is significant. after all, even in SM it's only an indication that termiantion may be needed - you still measure rates etc to actually decide how much to terminate. and in your case it's still an indiaction - you can devise scenarios where termiatnion isnt actually needed. 
> 

1 is significant not to occur unnecessary termination.

> 2 is a different approach. there are clearly trade-offs to how fast you terminate and the damger of over-termination. the approach descried in the cl (& SM] draft is at one extreme - termiante in one shot. your approach seems rather slow [we talked about 1 sec as target time to do termination] - but this could be faster with termianting more in each step. or terminate 50% in teh first step, then 25%, then 12% etc. may well be worth exploring some of this more. 
> 

Our algorithm has tradeoff between accuracy of termination and termination time.
If the value of y is very big, the accuracy is worse.

> in your simualtions, i dont understand the results for when the link is very highly overloaded. i wondered if your CL/SM simulations had included that excess-traffic-marked pkts should not be metered by the excess-tr-meter? [at least your algorithm doesnt seem to do this, so wondered if you'd not added this into the CL simulations?] [this would explain why your CL/SM results over terminate singificantly when the link is very highly overloaded]
> 

Do you mean already excess-traffic-marked pkts should not be metered?

In our simulation, already excess-traffic-marked pkts is not metered. Therefore, over termination is worse at upstream bottleneck link in the multi-bottleneck case.
Accuracy of termination in the downstream link is good.

Regards,
Daisuke

---

From: <[email-masked]>
Date: Mon, 23 Mar 2009 17:55:33 -0000

________________________________

From: [email-masked] on behalf of SATOH Daisuke
Sent: Mon 23/03/2009 06:58
To: [email-masked]
Subject: [PCN] comment about edge bahviour of draft-satoh-pcn-st-marking-01

Hi Phil,

[phil] this is not clear. it's just a trigger that termination may be needed; it's not actually a decision to do termination [well certainly it isnt a decision in SM; i'm unclear from your work whether you're guaranteed to do some termination once you get the trigger]

[phil] please clarify [1] what's in your algorithm & in its simulation [2] what's in your simulation of CL/SM.  i'm having to guess what "In our simulation" refers to.

thanks, phil

Regards,
Daisuke
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn