Subject: [PCN] comment on marking bahviour goal of draft-satoh-pcn-st-marking-01

From: SATOH Daisuke <[email-masked]>
Date: Mon, 23 Mar 2009 15:28:02 +0900

Hi Phil,

> series of emails coming up [over next day[ about this.
>  
> first, wanted to look at teh goal of your marking behaviour,as shown in figure 2. [edge behaviour reaction coming up in other emails]
> no marking beow rate-1
> linearly increase marking as pcn-traffic-rate on a link increases from rate-1 to rate-2
> above rate-2, a sudden jump in marking, so mark all pkts
>  

This shape is not so essential. In admission, it is essential that threshold marking or similar marking such as fractional marking is used. Although packets are all marked by ordinary threshold marking,  threshold marking with high threshold and fractional marking is partially marked to distinct if PCN traffic rate is greater than PCN-admissible-rate or PCN-supportable-rate. All the three have the same mechanism to distinct if PCN traffic rate is greater than PCN-admissible-rate or not. 
Excess traffic marking may make similar shape of marking graph but it has different mechanism to do.

> i beleive that this behaviour is actually essentially already allowed by the WG marking behaviour draft:
> run excess trafic marker, with pcn-excess-rate set to rate-1
> run threshold marker with pcn-threshold-rate set to rate-2
> actually mark pkt to PCN-marked if either meter indicatres to do so.
>  
> the only change needed is to delete one sentence in S2.4 of the WG doc ["The PCN-excess-rate is greateer than [or equal to] the pcn-threshold-rate"]. 
> at first glance, i'm ok with making this deletion. also, the "Note" para at teh end of S2.5 would be better moved into the Appednix and very slightly re-phrased.
>  
> anyway, i think this means that no changes are needed to the marking beh draft [beyond the one noted above] and none are needed to the WG encoding draft 
>  
> do you agree?
>  
> thanks
> phil

No. If excess-traffic marking is adopted as admission of our algorithm, synchronization is not avoidable and performance of admission is the same as SM and simplisity of implementation of our algorithm is less than that of SM. Furthermore, I believe it is impossible to distinct if PCN rate is greater than PCN-supportable-rate or not because we cannot make gap of marking ratio at PCN-supportable-rate.

Best regards,
Daisuke

---

From: <[email-masked]>
Date: Mon, 23 Mar 2009 17:51:27 -0000

dont completely follow your email.
 
i chatted with bob & i beleive i was a bit wrong in way i described your algorithm. the crucial thing in Figure 2 of your draft is that the marking rate has a "jump" at the lower threshold (AR in the pic). this jump enables edge to more clearly realise that admission control is needed (when compared to SM, ie excess rate marking, when increase from 0). i dont understand relevance of syncronisation.

________________________________

From: [email-masked] on behalf of SATOH Daisuke
Sent: Mon 23/03/2009 06:28
To: [email-masked]
Subject: [PCN] comment on marking bahviour goal ofdraft-satoh-pcn-st-marking-01

Hi Phil,

Best regards,
Daisuke

_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn