Subject: Re: [PCN] Corridor discussion about draft-satoh

From: SATOH Daisuke <[email-masked]>
Date: Fri, 27 Mar 2009 04:59:37 +0900

Hi All,

> 
> 
> > 
> > 
> > Hi All,
> > 
> > 
> > On Thu, 26 Mar 2009 16:20:17 +0900
> > SATOH Daisuke <daisuke.satoh at ntt-at.co.jp> wrote:
> > 
> > > Hi Phil,
> > >
> > >
> > >
> > > > We had a long discussion yesterday about draft-satoh's & the WG draft's marking behaviours. I wanted to email two high level things that I concluded, without getting into the particular details of the satoh proposal.
> > > >
> > > > 
> > > >
> > > > Draft-pcn-marking-behaviour sets out with a goal in mind. This was to come up with something that works reasonably well in a variety of scenarios:
> > > >
> > > > -          if your network has 3 encoding states (not PCN-marked, and 2 states for PCN-marking), then you can get both accurate admission control (via threshold-markings) and accurate flow termination control (via excess-traffic-markings).
> > > >
> > > > -          If your network has 2 encoding states (no PCN-marked; PCN-marked) then you have 3 choices: either have accurate admission control (via threshold-markings; and do something else for flow termination); or accurate flow termination control (via excess-traffic-markings; and do something else for admission control); or do both (the single marking idea - but pay the penalty of less accurate admission control when small numbers of flows on the ingress-egress-aggregate).
> > > >
> > >
> > >
> > >
> > > I believe PCN WG has decided 2 encoding states as standard and 3
> > > encoding states as experimental. Do I misunderstand?
> > >
> > >
> > > > 
> > > >
> > > > Draft-satoh has a different goal in mind. This is to come up with something that works as well as possible for a scenario where you know you need both admission control and flow termination and where you know you only have 2 encoding states (no PCN-marked; PCN-marked). Now we can argue about whether this particular scenario is better achieved by the single marking draft or by the draft-satoh approach (not clear either way to me), and this is a discussion worth having, at least for academic interest. But from the point of view of the WG I don't think this comparison matters:
> > > >
> > > > -          it's clear that the draft-satoh approach doesn't give as good performance as {draft-pcn-marking-behaviour + 3 encoding states}
> > > >
> > >
> > >
> > > Actually, STM (my proposal) is slightly less accurate than CL in
> > > admission control. However, it is better than CL in flow termination
> > > when the load is 2x supportable rate without packet loss.
> > > I wrote in this ML and explain the mechanism and the reason why accuracy
> > > of flow termination in CL is low when the load is 2x supportable rate. I
> > > believe CL must know the order of packets at the bottleneck link in
> > > order to achieve accurate termination. Getting information of the order
> > > of packets at the bottleneck link is almost impossible.
> > >
> > >
> > 
> > 
> > Sorry, I do not write the reason why CL degraded when the load is 2x supportable
> > rate in this ML.
> > 
> > 
> > 
> > Why is the performance of CL degraded?
> > Because choosing appropriate flows to terminate is very difficult. When
> > PCN rate has to be half by termination, average PCN rate becomes about half
> > by one shot of termination because the SAR is accurate. But PCN rate
> > after the termination becomes more burst than PCN traffic before
> > termination. So some packets are still excess-traffic marked. Then CL
> > calculates SAR again. This SAR is smaller than the first SAR because PCN
> > traffic is bursty and unmarkedrate is less than supportable rate.
> > Because SAR is smaller, some flows are terminated. This cycle is
> > repeated. As a result, over termination occurrs.
> > 
> > 
> > When the traffic is highly overloaded, more higher overloaded traffic in
> > a short interval exists. An ingress terminates flows based on SAR. I
> > believe SAR itself is accurate. If an ingress can terminate flows so
> > that variance of traffic rate is enough small, CL always terminates
> > flows accurately. However, it is very difficult. When the traffic is not
> > so highly overloaded, the variance is small. When the traffic is highly
> > overloaded, high traffic rate keeps in a short interval and very low
> > traffic rate is generated in a short interval by termination. The
> > average is SAR but traffic after termination becomes bursty.
> > 
> > If the traffic is bursty and the average rate is about
> > PCN-supportable-rate, SAR is less than PCN-supportable-rate. This is the
> > mechanism of over termination of CL when the traffic is highly
> > overloaded.
> > 
> > These are my understanding. I have not confirmed it by simulation yet.
> > 
> > [phil] i dont agree with your analysis. after termination from 2* overload to 1.25* overload, why is the traffic any more bursty than if you started with 1.25* overload?????
> > 
> 
> We compare original 1.25*supportable rate (SR) with 1.25 SR after
> termination.
> 
> The traffic after termination has very bursty traffic in a short
> period because traffic before termination stays in a short period even
> after termination. This high rate state does not exist in the original
> 1.25 SR traffic. But both rate is the same. Thus the traffic after
> termination has traffic with lower rate than the original 1.25*SR in a
> short period. Therefore traffic after termination includes both higher
> and lower rate than the original 1.25*SR. Traffic after termination is
> more bursty than the original 1.25*SR traffic.
> 
> 
> 
> 
> 
> 
> 
> 
> > Solution is terminating flows that generate very highly overloaded.
> > However, this overload is produced by superposition. An ingress cannot
> > detect this information.
> > 
> > [phil] i'm susipicious this is a simulation artefact, where you've got synrhonisation so that some flows get lots of marking and some get little. however, even if this is the case this shouldnt make any difference to the burstiness of the traffic before and after one round of termination. 
> > 
> 
> The explanation is above.
> 
> 
> > 
> > Or I guess the first termination is accurate. If CL does not use SAR
> > after the first termination, the performance may be improved.
> > 
> > 
> > 
> > Why is the performance of STM actually better than CL at high overloads?
> > 
> > Because STM terminates flows little by little until 100% packets are not
> > marked by using threshold marking. It does not use SAR.
> > 
> > [phil] you're talking about edge behaviour. you're free to do an edge behaviour that terminates little-by-little with the WG marking behaviour. you dont have to do the SAR one-shot termination - this is just the example edge behaviour that the old CL draft describes. 
> > 
> > so your comments dont seem relevant to the marking behaviour draft. rather we need to analyse them further as part of writing the edge behaviour drafts.
> > 
> 

I pointed out the problem of termination using SAR. SAR is strongly
connected to excess-traffic-marking that is defined in marking behaviour
draft. So I believe it is not necessarily only an issue of edge behaviour.

> 
> 
> Would you wait for last call by you see the result of simulation of my
> new termination?
> 
> I want you not to exclude marking behaviour that my algorithm needs in
> the current situation.
> 
> > 
> > >
> > >
> > > I think it is not late to WG Last Call after solving the above problem.
> > >
> > >
> > >
> > > > -          draft-satoh can't be modified for a situation when there's a 3rd encoding state.
> > > >
> > > > 
> > > >
> > > > The second high level point I wanted to raise is that the draft-satoh work is "in progress". For instance, Daisuke agrees that the marking algorithm described in the draft is too complicated to implement, and has talked about a marking algorithm with 'two steps' [traffic rate above AR, jump to marking say 10% pkts; traffic rate above SR, jump to marking all pkts]. Daisuke also has ideas for improvements for modified behaviour around the sustainable rate. But this is all stuff that needs to be refined, simulated, compared etc. it is clear that there is substantial effort to get any such new proposal in a similar state to what's in draft-pcn-marking-behaviour - what's in the WG draft hasn't changed at all since the -00 version, and in fact for a long time before that.
> > > >
> > 
> > Actually my marking algorithm is more complicated than SM. But I do not
> > know whether it is too complicate to implement.
> > 
> > [phil] sorry, i misunderstood you. but you've changed your proposal to being 'two steps' - not yet simualted - and have furtjher changes to it in mind, 
> > 
> > 
> > > > 
> > > >
> > > > So there seem to me two choices. One option is that we change our minds & decide that we will optimise for the case where there's only one state for PCN-marking & the operator ewants both adm ctrl & flow termination - then we need to wait for revisions to draft-satoh, compare it with the SM approach, etc - most optimistically in a year's time we'd be in the same position we were perhaps 18months ago for draft-pcn-marking-behaviour. The second choice is that we go forward now with draft-pcn-marking-behaviour - with this choice, there is no benefit to waiting yet further, let's WG last call and get done.
> > > >
> > > > 
> > > >
> > > > You can probably guess which option I prefer!!
> > > >
> > > > 
> > > >
> > > > Thanks
> > > >
> > > > phil
> > > >
> > > > 
> > > >
> > > > -          
> > > >
> > > > -          available. But I don't think this is a discussion worth having's performance compares with the performance of
> > >
> > >
> > 
> 
> 

Best regards,
Daisuke

---

From: <[email-masked]>
Date: Thu, 26 Mar 2009 20:29:58 -0000

SAR is strongly

[phil] alternative edge behaviours with draft-ietf-pcn's marking behaviour:
- measure SAR & ingress rate, terminate in one shot (as per the old CL draft)
- as above, but only terminate 50% in first shot
- measure marked flow rate, terminate this much
- terminate some of the flows that are marked
- etc