Subject: [PCN] comment on marking bahviour goal of draft-satoh-pcn-st-marking-01

From: <[email-masked]>
Date: Sun, 22 Mar 2009 15:44:01 -0000

series of emails coming up [over next day[ about this.
 
first, wanted to look at teh goal of your marking behaviour,as shown in figure 2. [edge behaviour reaction coming up in other emails]
no marking beow rate-1
linearly increase marking as pcn-traffic-rate on a link increases from rate-1 to rate-2
above rate-2, a sudden jump in marking, so mark all pkts
 
i beleive that this behaviour is actually essentially already allowed by the WG marking behaviour draft:
run excess trafic marker, with pcn-excess-rate set to rate-1
run threshold marker with pcn-threshold-rate set to rate-2
actually mark pkt to PCN-marked if either meter indicatres to do so.
 
the only change needed is to delete one sentence in S2.4 of the WG doc ["The PCN-excess-rate is greateer than [or equal to] the pcn-threshold-rate"]. 
at first glance, i'm ok with making this deletion. also, the "Note" para at teh end of S2.5 would be better moved into the Appednix and very slightly re-phrased.
 
anyway, i think this means that no changes are needed to the marking beh draft [beyond the one noted above] and none are needed to the WG encoding draft 
 
do you agree?
 
thanks
phil

---

From: <[email-masked]>
Date: Sun, 22 Mar 2009 15:50:32 -0000

hi daisuke

i red teh draft and looked at your slides about syncronisation. unfortunately i still dont understand at all. i'm not even sure whether you're trying to get rid of synchonrisation or not (note the argument in one of anna's drafts that synchonisation actually helps). if you are trying to get rid of it, i beleive that this can be done as a local optimisation that still meets the WG marking behaviour draft. ie occasionly you randomly decide not to mark this pkt (as indicated by the state of the meters) but instead mark the next pkt [i'd argue that this would be "functionally equiavelent" within the meaning of the draft, which implies through the examples that 2 markers have functionally equivalent behaviour if they mark identical pkts or shifted by one]

anyway, i think syncronisation is something we're going to have to discuss face-to-face!

thans

phil

---

From: <[email-masked]>
Date: Sun, 22 Mar 2009 16:02:25 -0000

hi daisuke

quick email about this, maybe more when more time to type

looking at teh edge behaviour of your proposal.

as regards admission control, it seems to me this must be identical to SM. the marking is identical 

as reagrds termination of flows, this is different in 2 ways

1. you have a clearer signal that terminatin may be needed nb "may" - as you mark 100% if the link is above its pcn-sustainable-rate.

2. you terminate slower, rather than in one shot.

i dont know whether 1 is significant. after all, even in SM it's only an indication that termiantion may be needed - you still measure rates etc to actually decide how much to terminate. and in your case it's still an indiaction - you can devise scenarios where termiatnion isnt actually needed. 

2 is a different approach. there are clearly trade-offs to how fast you terminate and the damger of over-termination. the approach descried in the cl (& SM] draft is at one extreme - termiante in one shot. your approach seems rather slow [we talked about 1 sec as target time to do termination] - but this could be faster with termianting more in each step. or terminate 50% in teh first step, then 25%, then 12% etc. may well be worth exploring some of this more. 

in your simualtions, i dont understand the results for when the link is very highly overloaded. i wondered if your CL/SM simulations had included that excess-traffic-marked pkts should not be metered by the excess-tr-meter? [at least your algorithm doesnt seem to do this, so wondered if you'd not added this into the CL simulations?] [this would explain why your CL/SM results over terminate singificantly when the link is very highly overloaded]

thanks

phil