Subject: [PCN] Corridor discussion about draft-satoh

From: <[email-masked]>
Date: Wed, 25 Mar 2009 21:59:15 -0000

We had a long discussion yesterday about draft-satoh's & the WG draft's marking behaviours. I wanted to email two high level things that I concluded, without getting into the particular details of the satoh proposal. 

Draft-pcn-marking-behaviour sets out with a goal in mind. This was to come up with something that works reasonably well in a variety of scenarios:

-          if your network has 3 encoding states (not PCN-marked, and 2 states for PCN-marking), then you can get both accurate admission control (via threshold-markings) and accurate flow termination control (via excess-traffic-markings).

-          If your network has 2 encoding states (no PCN-marked; PCN-marked) then you have 3 choices: either have accurate admission control (via threshold-markings; and do something else for flow termination); or accurate flow termination control (via excess-traffic-markings; and do something else for admission control); or do both (the single marking idea - but pay the penalty of less accurate admission control when small numbers of flows on the ingress-egress-aggregate).

Draft-satoh has a different goal in mind. This is to come up with something that works as well as possible for a scenario where you know you need both admission control and flow termination and where you know you only have 2 encoding states (no PCN-marked; PCN-marked). Now we can argue about whether this particular scenario is better achieved by the single marking draft or by the draft-satoh approach (not clear either way to me), and this is a discussion worth having, at least for academic interest. But from the point of view of the WG I don't think this comparison matters:

-          it's clear that the draft-satoh approach doesn't give as good performance as {draft-pcn-marking-behaviour + 3 encoding states}

-          draft-satoh can't be modified for a situation when there's a 3rd encoding state.

The second high level point I wanted to raise is that the draft-satoh work is "in progress". For instance, Daisuke agrees that the marking algorithm described in the draft is too complicated to implement, and has talked about a marking algorithm with 'two steps' [traffic rate above AR, jump to marking say 10% pkts; traffic rate above SR, jump to marking all pkts]. Daisuke also has ideas for improvements for modified behaviour around the sustainable rate. But this is all stuff that needs to be refined, simulated, compared etc. it is clear that there is substantial effort to get any such new proposal in a similar state to what's in draft-pcn-marking-behaviour - what's in the WG draft hasn't changed at all since the -00 version, and in fact for a long time before that. 

So there seem to me two choices. One option is that we change our minds & decide that we will optimise for the case where there's only one state for PCN-marking & the operator ewants both adm ctrl & flow termination - then we need to wait for revisions to draft-satoh, compare it with the SM approach, etc - most optimistically in a year's time we'd be in the same position we were perhaps 18months ago for draft-pcn-marking-behaviour. The second choice is that we go forward now with draft-pcn-marking-behaviour - with this choice, there is no benefit to waiting yet further, let's WG last call and get done. 

You can probably guess which option I prefer!!

Thanks

phil

-           

-          available. But I don't think this is a discussion worth having's performance compares with the performance of

---

From: <[email-masked]>
Date: Wed, 25 Mar 2009 22:33:18 -0000

I definitely support advancing the marking behaviour draft as quickly as possible. We are already running late even on the revised timetable for PCN and I don't want the WG to effectively fail... Two things I suggest:
 
1) add a section to marking behaviour draft explaining that it isn't intended to stop other alternatives from coming along in the future
 
2) allow work on the Satoh proposal to continue with an initial aim of becoming experimental (sort of similar to the approach we are using with the encoding)
 
Toby

________________________________

From: [email-masked] on behalf of [email-masked]
Sent: Wed 3/25/2009 21:59
To: [email-masked]
Subject: [PCN] Corridor discussion about draft-satoh

Thanks

phil

-          

_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: <[email-masked]>
Date: Wed, 25 Mar 2009 23:24:30 -0000

re 1 - i'm not sure the value of this. of course, it's possible for any rfc to get updated later.
 
re 2 - yes. but note that producing an experiomental proposal is outside is the charter

From: Moncaster,T,Toby,CXR9 R
Sent: Wed 25/03/2009 22:33
To: Eardley,PL,Philip,CXR9 R; [email-masked]
Subject: RE: [PCN] Corridor discussion about draft-satoh

 
 
Toby

Thanks

phil

-