Subject: [PCN] Extension encodings to WG docs?

From: <[email-masked]>
Date: Tue, 17 Mar 2009 08:48:38 -0000

Hi

Toby tells me that the baseline encoding is ready for WG last call (I
agree) - we should confirm this in SF.

This could suggest that we could be ready to take forward one or more of
the extension encodings. IE turn 1+ into WG docs as the next step to
seeing how many we want to go forward with towards rfc.

Do you agree?

I think there are 3 plausible candidates, and I'm inclined to think it's
worth taking all 3 to WG status

Do you agree?

      +--------+--------------+-------------+-------------+---------+
      |  DSCP  | 00 <Not-ECT> | 10 <ECT(0)> | 01 <ECT(1)> | 11 <CE> |
      +--------+--------------+-------------+-------------+---------+
      | DSCP n |    Not-PCN   |      NM     |     ThM     |   ETM   |
      +--------+--------------+-------------+-------------+---------+
                       Table 1: 3-in-1 PCN Encoding

      +--------+--------------+-------------+-------------+---------+
      |  DSCP  | Not-ECT (00) | ECT(0) (10) | ECT(1) (01) | CE (11) |
      +--------+--------------+-------------+-------------+---------+
      | DSCP 1 |    Not-PCN   |      NM     |      CU     |   ThM   |
      | DSCP 2 |    Not-PCN   |      CU     |      CU     |   ETM   |
      +--------+--------------+-------------+-------------+---------+
                 Table 1: 3-state Encoding three 

          +------------------+---------+---------+---------+----+
          |       DSCP       |    00   |    10   |    01   | 11 |
          +------------------+---------+---------+---------+----+
          | PCN-enabled DSCP | not-PCN | not-ExM | Not-EhM |  M |
          +------------------+---------+---------+---------+----+
           Table 1: PSDM Encoding field

http://tools.ietf.org/html/draft-briscoe-pcn-3-in-1-encoding-00

http://tools.ietf.org/html/draft-moncaster-pcn-3-state-encoding-01 

http://tools.ietf.org/html/draft-menth-pcn-psdm-encoding-00 

thanks

phil

---

From: <[email-masked]>
Date: Tue, 17 Mar 2009 09:59:14 -0000

inline...
 
Toby

________________________________

>From: [email-masked] on behalf of [email-masked]
>Sent: Tue 3/17/2009 08:48
>To: [email-masked]
>Subject: [PCN] Extension encodings to WG docs?
>
>

>Toby tells me that the baseline encoding is ready for WG last call (I agree) - we should confirm this in SF.

>This could suggest that we could be ready to take forward one or more of the extension encodings. IE turn 

>1+ into WG docs as the next step to seeing how many we want to go forward with towards rfc.

>Do you agree?

Yes! (obviously....)

>I think there are 3 plausible candidates, and I'm inclined to think it's worth taking all 3 to WG status

>Do you agree?

Yes. This way we are giving options to implementers and then natural selection will lead to the best 

getting adopted. Remember the idea was that all these experimental extensions should have EXP 

status... Also recall that section 5 of http://tools.ietf.org/wg/pcn/draft-ietf-pcn-baseline-encoding/

includes rules for experimental extensions to follow...

It would be nice if there could be a 10 minute discussion of this in the meeting next week...

---

From: <[email-masked]>
Date: Tue, 17 Mar 2009 11:27:27 +0100

Hi Phil,
 
your proposal is allright with me.
 
Regards,
 
Rudiger

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, March 17, 2009 9:49 AM
To: [email-masked]
Subject: [PCN] Extension encodings to WG docs?

Hi

This could suggest that we could be ready to take forward one or more of the extension encodings. IE turn 1+ into WG docs as the next step to seeing how many we want to go forward with towards rfc.

Do you agree?

Do you agree?

 

thanks

phil

---

From: Michael Menth <[email-masked]>
Date: Wed, 18 Mar 2009 14:49:59 +0100

Hi Phil,

2x agree.

Michael

[email-masked] schrieb:
> agree) – we should confirm this in SF.
>
> This could suggest that we could be ready to take forward one or more 
> of the extension encodings. IE turn 1+ into WG docs as the next step 
> to seeing how many we want to go forward with towards rfc.
>
> Do you agree?
>
> I think there are 3 plausible candidates, and I’m inclined to think 
> it’s worth taking all 3 to WG status
>
> Do you agree?
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> PCN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcn
>   

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn