Subject: [pcp] Question on requesting external IP address in PCP

From: Dong Zhang <[email-masked]>
Date: Thu, 21 Oct 2010 12:00:15 +0800

Hi Dan,

In PCP request, a *requested external IP address* field is included.

I'm concerned that how the PCP client knows the external IP address. Generally, for a lage scale nat (e.g. CGN, AFTR, NAT64), it always has an IPv4 address pool. If the PCP client fills the field above in PCP request, it should use the public address in the right range which lsn has.

NAT-PMP has a round-trip exchange for noticing the external address. In NAT-PMP scenario, the external address is the public address of the CPE or home gateway. There is only one generally. However, there will be a group of addreesses in PCP scenario and there is no external address request process.

Additionally, if an application takes advantage of PCP to create a port forwarding, does it care the external address which will be used? I think any address is ok and choosing a port is more meaningful. I mean maybe choosing an address from the pool of NAT actively is not important. You only need to know which address is allocated to you. It's enough.

Perhaps the requesting of external IP address can be deleted. Maybe I am not right.

Thanks a lot.

2010-10-21 

Dong Zhang

---

From: Francis Dupont <[email-masked]>
Date: Thu, 21 Oct 2010 14:43:00 +0200

In your previous mail you wrote:
   
   Hi Dan,

=> IMHO you refer to the base-00 document which is only a place holder
or to an obsolete one.

   You only need to know which address is allocated to you. It's enough.

=> it is not true: users expect some stability from the external IP
address with many meanings for 'stability'. A *requested* external
IP address can provide a quick way to raise an error on external
IP address mismatch.
 And to have similar layout for request and response, in particular
the same length for the mandatory part, is a *good* idea.

Regards

[email-masked]

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 21 Oct 2010 08:45:54 -0700

> -----Original Message-----
> From: Dong Zhang [mailto:[email-masked]]
> Sent: Wednesday, October 20, 2010 9:00 PM
> To: dwing
> Cc: pcp
> Subject: Question on requesting external IP address in PCP
> 
> Hi Dan,
> 
> I'm concerned that how the PCP client knows the external IP address.

On an initial request, it wouldn't know.  So it could set that field
to zero or could set that field to any value.  If the PCP server 
*can* fulfill the requested-external-ip-address it will; if it can't,
it won't.  This is similar to requested-external-port.

> Generally, for a lage scale nat (e.g. CGN, AFTR, NAT64), it always has
> an IPv4 address pool. If the PCP client fills the field above in PCP
> request, it should use the public address in the right range which lsn
> has.
> 
> NAT-PMP has a round-trip exchange for noticing the external address. In
> NAT-PMP scenario, the external address is the public address of the CPE
> or home gateway. There is only one generally. However, there will be a
> group of addreesses in PCP scenario and there is no external address
> request process.

NAT-PMP's external address request process does not work with an 
address pool, because it requires either (a) state on the PCP server 
or (b) assigning a user to the same IP address from that pool [instead
of assigning the user to the least-used/least-busy IP address in the 
pool].

> Additionally, if an application takes advantage of PCP to create a port
> forwarding, does it care the external address which will be used? 

Depends on the application.  Some applications want or need multiple
ports assigned to the same external IP address.  Best example is RTP
and RTCP, which need to be on the same IP address (due to limits of
SDP signaling used by SIP, SAP, and RTSP).  I expect there are other
applications with similar requirement, but don't know any others
off-hand.

> I
> think any address is ok and choosing a port is more meaningful. I mean
> maybe choosing an address from the pool of NAT actively is not
> important. You only need to know which address is allocated to you.
> It's enough.

In that case the requested-external-ip-address could be 0, or could
be the assigned-external-ip-address.

-d

> ________________________________
> 
> Dong Zhang
>

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 21 Oct 2010 09:23:34 -0700

> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, October 21, 2010 5:43 AM
> To: Dong Zhang
> Cc: dwing; pcp
> Subject: Re: [pcp] Question on requesting external IP address in PCP
> 
> 

Both draft-wing-pcp-proposed-packet-format-00 and draft-wing-pcp-base-00
have a requested-external-ip-address field.

-d

---

From: Dong Zhang <[email-masked]>
Date: Fri, 22 Oct 2010 11:27:03 +0800

Hi Dan,

>it won't.  This is similar to requested-external-port.
Yes, it is feasible of behavior like this. Perhaps giving some words on this point is a little bit clearer.
>applications with similar requirement, but don't know any others
I see, agree.
Thanks for your patient explanation. 

>> Perhaps the requesting of external IP address can be deleted. Maybe I

------------------				 
Dong Zhang
Huawei Symantec Technologies Co., Ltd
TEL：86-10-62721287
FAX：86-10-62721347
ADDRESS：3rd Floor,Section D, Keshi Building, No.28, Xinxi Rd., Shangdi, Haidian Dist., Beijing, China. 100085 

***********************************************************************************
This email and its attachments contain confidential information from HUAWEI SYMANTEC, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
**********************************************************************************
2010-10-22

---

From: Dong Zhang <[email-masked]>
Date: Fri, 22 Oct 2010 12:07:55 +0800

Hi Francis,

>=> IMHO you refer to the base-00 document which is only a place holder
Yes, I read the base-00 and pcp-02 in softwire.

>the same length for the mandatory part, is a *good* idea.
mmm, some application needs to apply the same external address, which is a primary reason.
Of course, what you said makes sense as well.

Thank you.

------------------				 
Dong Zhang
2010-10-22