Subject: [pcp] On the interaction between PCP sever and NAT (or multiple NATs)

From: "宋林健" <[email-masked]>
Date: Thu, 14 Oct 2010 11:36:52 +0800

Hi,ALL

	 In "draft-wing-softwire-port-control-protocol-02" the Fig.2 shows that the NAT devices can work with separate PCP Server. But I only find the detailed specification between the PCP server and clients. The interation between PCP server and NAT is obscure and the suggested xml-style communication is not clear. How dose it works? Based on TCP,UDP or other mature transmission technology? what information should it contain ?

Below is some question and considerations on the interation between PCP sever and NAT. Comments and suggestions are welcome and appreciated.

1.Is the interation between PCP server and NAT private or public ?  In another word,is it possible that PCP server and NAT are producted by differnt network equipment vendors. IF we expect two devices from different vendors can work together without trouble, the specification of the interation is necessary.

2. In the PCP draft, NAT device only receives address binding information from PCP server. Is there any message that NAT should tell PCP server? Intuitively, PCP server should detect the failure of NAT device, expecially in multiple NATs scenario. Tranditional  echo or 'hello' protocol is available. on the purpose redundancy and load-balancing the NAT group id and the current load is expected to be known by PCP server. (plz see 3)

3. Can a single PCP server interact with multiple NATs? Because the reliability is very important for CGN devices, mulitple NATs is highly desireable for both load balacing and redundancy. If the multiple NAT scenario makes sense in PCP context, the specification of the interation should be more carefully designed.
plz see http://tools.ietf.org/html/draft-xu-behave-stateful-nat-standby-04 and http://tools.ietf.org/html/draft-wang-behave-nat64-load-balancer-02 for more information    

4.TCP or UDP? I'm not sure about that part. If reliable connection is need between PCP server and NAT ,TCP is prefered.

Best regards.   2010-10-14

********************************************************
*    Linjian Song ,Ph.D candidate                      *
*    Department of Computer Science & Technology       *
*    Tsinghua University, Beijing, P.R.China(100084)   *
*    Tel: (8610)-62795818-6864                         *
*    Email: [email-masked]      *
********************************************************

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 13 Oct 2010 21:08:49 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> ???
> Sent: Wednesday, October 13, 2010 8:37 PM
> To: pcp
> Subject: [pcp] On the interaction between PCP sever and NAT (or
> multiple NATs)
> 
> Hi,ALL
> 
> 	 In "draft-wing-softwire-port-control-protocol-02" the Fig.2
> shows that the NAT devices can work with separate PCP Server. But I
> only find the detailed specification between the PCP server and
> clients. The interation between PCP server and NAT is obscure and the
> suggested xml-style communication is not clear. How dose it works?
> Based on TCP,UDP or other mature transmission technology? what
> information should it contain ?

Undefined.  The PCP server and NAT could be implemented in the same
device (which I expect will be common), and share whatever 
data structures are necessary between them using whatever they
find natural (perhaps a socket-based API, perhaps shared memory,
etc.).  If PCP server and NAT are implemented in separate devices,
it would be a proprietary protocol between the PCP server and
the NAT(s).

> Below is some question and considerations on the interation between PCP
> sever and NAT. Comments and suggestions are welcome and appreciated.
> 
> 1.Is the interation between PCP server and NAT private or public ?  In
> another word,is it possible that PCP server and NAT are producted by
> differnt network equipment vendors. IF we expect two devices from
> different vendors can work together without trouble, the specification
> of the interation is necessary.

It's a private interface.

-d

> 2. In the PCP draft, NAT device only receives address binding
> information from PCP server. Is there any message that NAT should tell
> PCP server? Intuitively, PCP server should detect the failure of NAT
> device, expecially in multiple NATs scenario. Tranditional  echo or
> 'hello' protocol is available. on the purpose redundancy and load-
> balancing the NAT group id and the current load is expected to be known
> by PCP server. (plz see 3)
>
> 3. Can a single PCP server interact with multiple NATs? Because the
> reliability is very important for CGN devices, mulitple NATs is highly
> desireable for both load balacing and redundancy. If the multiple NAT
> scenario makes sense in PCP context, the specification of the
> interation should be more carefully designed.
> plz see http://tools.ietf.org/html/draft-xu-behave-stateful-nat-
> standby-04 and http://tools.ietf.org/html/draft-wang-behave-nat64-load-
> balancer-02 for more information
>
> 4.TCP or UDP? I'm not sure about that part. If reliable connection is
> need between PCP server and NAT ,TCP is prefered.
>
> 
> 
> 
> 
> 
> Best regards.   2010-10-14
> 
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp