Subject: Re: [pcp] #28: UPnP/NAT-PMP Interop functionality in base spec or separate specs

From: Paul Selkirk <[email-masked]>
Date: Fri, 25 Feb 2011 19:04:42 +0000

>     As of -05, the UPnP interworking details were removed from the base
>     document.  The bast document now points to http://tools.ietf.org/html
>     /draft-bpw-pcp-upnp-igd-interworking
> 
>     Closed.

The UPnP IGD IWF document needs to be adopted as a WG document.
I think the chairs can do this by fiat.

There is no NAT-PMP IWF document.  It should be easy to write, and
Francis has volunteered to edit it.

There should also be a PCP IWF (aka proxy in this case) document.
(Note there are some open problems to implement one, so this is not
only about completing the IWF document set.)

				paul

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 25 Feb 2011 18:20:38 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Paul Selkirk
> Sent: Friday, February 25, 2011 11:05 AM
> To: [email-masked]
> Subject: Re: [pcp] #28: UPnP/NAT-PMP Interop functionality in base spec
> or separate specs
> 

I hope they do that soon.  

Same with the DHCP document.

> only about completing the IWF document set.)

I would consider that a higher priority than NAT-PMP->PCP, myself,
because it is necessary for the Dual-Stack Lite B4 element, a home
NAT with CGN ("NAT444"), and probably some other scenarios.

-d