Subject: [pcp] #42: PEER OpCode: remove internal-ip-address, introduce THIRD_PARTY OpCode

From: "pcp issue tracker" <[email-masked]>
Date: Sat, 26 Feb 2011 02:15:53 -0000

#42: PEER OpCode: remove internal-ip-address, introduce THIRD_PARTY OpCode

 Currently, the PEER OpCodes contain an internal IP address in their
 payloads.  They are not necessary (the common case being where
 an application is trying to determine the lifetime of the
 NAT/firewall mappings).  It seems PEER has even _less_ use for
 3rd party query/control than MAP.  Like MAP, 3rd party query/
 control is only necessary when PCP is being proxied _and_ when
 the user's CPE is not a NAT (i.e., Dual-Stack Lite).

 I suggest that internal-ip-address be removed from the PEER OpCodes
 entirely, and use a separate THIRD_PARTY option. This would bring
 PEER and MAP to function the same way.

-- 
-----------------------------+----------------------------------------------
 Reporter:  dwing@…          |       Owner:     
     Type:  defect           |      Status:  new
 Priority:  major            |   Milestone:     
Component:  base             |     Version:     
 Severity:  -                |    Keywords:     
-----------------------------+----------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/42>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 01 Mar 2011 00:00:38 -0000

Changes (by dwing@…):

  * status:  new => closed
  * resolution:  => fixed

Comment:

 I have received no feedback on this.  I will go ahead with this change.

-- 
-----------------------------+----------------------------------------------
 Reporter:  dwing@…          |        Owner:        
     Type:  defect           |       Status:  closed
 Priority:  major            |    Milestone:        
Component:  base             |      Version:        
 Severity:  -                |   Resolution:  fixed 
 Keywords:                   |  
-----------------------------+----------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/42#comment:1>
pcp <http://tools.ietf.org/pcp/>