Subject: [pcp] February interim meeting info

From: Dave Thaler <[email-masked]>
Date: Mon, 21 Feb 2011 19:44:37 +0000

Thanks to Dan Wing for providing WebEx hosting again...

Topic: PCP Working Group

Date: Tuesday, February 22, 2011

Time: 7:00 am, Pacific Standard Time (San Francisco, GMT-08:00) Meeting Number: 200 288 330 Meeting Password: ietf

-------------------------------------------------------

To join the online meeting (Now from mobile devices!)

-------------------------------------------------------

1. Go to

https://cisco.webex.com/ciscosales/j.php?ED=160191142&UID=0&PW=NNTUxMDhjZmNh

&RT=MiM0

2. Enter your name and email address.

3. Enter the meeting password: ietf

4. Click "Join Now".

To view in other time zones or languages, please click the link:

https://cisco.webex.com/ciscosales/j.php?ED=160191142&UID=0&PW=NNTUxMDhjZmNh

&ORT=MiM0

----------------------------------------------------------------

ALERT:Toll-Free Dial Restrictions for (408) and (919) Area Codes

----------------------------------------------------------------

The affected toll free numbers are: (866) 432-9903 for the San Jose/Milpitas area and (866) 349-3520 for the RTP area.

Please dial the local access number for your area from the list below:

- San Jose/Milpitas (408) area: 525-6800

- RTP (919) area: 392-3330

-------------------------------------------------------

To join the teleconference only

-------------------------------------------------------

1. Dial into Cisco WebEx (view all Global Access Numbers at http://cisco.com/en/US/about/doing_business/conferencing/index.html

2. Follow the prompts to enter the Meeting Number (listed above) or Access Code followed by the # sign.

San Jose, CA: +1.408.525.6800 RTP: +1.919.392.3330

US/Canada: +1.866.432.9903 United Kingdom: +44.20.8824.0117

India: +91.80.4350.1111 Germany: +49.619.6773.9002

Japan: +81.3.5763.9394 China: +86.10.8515.5666

-------------------------------------------------------

For assistance

-------------------------------------------------------

1. Go to https://cisco.webex.com/ciscosales/mc

2. On the left navigation bar, click "Support".

You can contact me at:

[email-masked]<mailto:[email-masked]>

1-408-853 4197

To add this meeting to your calendar program (for example Microsoft Outlook), click this link:

https://cisco.webex.com/ciscosales/j.php?ED=160191142&UID=0&ICS=MI&LD=1&RD=2

&ST=1&SHA2=6qSGHu/bnx5ltYGa/lWS6UVH6i9ma8Svt6Y1WyeEMO0=&RT=MiM0

The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://cisco.webex.com/ciscosales/systemdiagnosis.php

Sign up for a free trial of WebEx

http://www.webex.com/go/mcemfreetrial

http://www.webex.com

CCP:+14085256800x200288330#

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: <[email-masked]>
Date: Tue, 22 Feb 2011 12:19:58 +0800

Hello Dan,

The requested lifetime field is missing in the MAP OpCode Request
format, in Figure9.   

Xiaohong

________________________________

*	From: Internet-Drafts at ietf.org
<mailto:[email-masked]>  
*	To: i-d-announce at ietf.org <mailto:[email-masked]>

*	Cc: pcp at ietf.org <mailto:[email-masked]>  
*	Date: Mon, 21 Feb 2011 19:15:01 -0800 
*	List-id: PCP wg discussion list <pcp.ietf.org> 

________________________________

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Port Control Protocol Working Group of
the IETF.

	Title           : Port Control Protocol (PCP)
	Author(s)       : D. Wing, et al.
	Filename        : draft-ietf-pcp-base-05.txt
	Pages           : 55
	Date            : 2011-02-21

Port Control Protocol allows a host to control how incoming IPv6 or
IPv4 packets are translated and forwarded by a network address
translator (NAT) or simple firewall to an IPv6 or IPv4 host, and also
allows a host to optimize its NAT keepalive messages.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pcp-base-05.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

	<ftp://ftp.ietf.org/internet-drafts/draft-ietf-pcp-base-05.txt>
<ftp://ftp.ietf.org/internet-drafts/draft-ietf-pcp-base-05.txt>

---

From: Jacni Qin <[email-masked]>
Date: Tue, 22 Feb 2011 14:52:06 +0800

On Tue, Feb 22, 2011 at 12:19 PM, <[email-masked]> wrote:

>  Hello Dan,
>
>
>
> The requested lifetime field is missing in the MAP OpCode Request format,
> in Figure9.
>
Jacni>: The lifetime field was removed from the common header...

>
>
> Xiaohong
>
> ------------------------------
>
>    - *From*: Internet-Drafts at ietf.org <[email-masked]>
>    - *To*: i-d-announce at ietf.org <[email-masked]>
>    - *Cc*: pcp at ietf.org <[email-masked]>
>    - *Date*: Mon, 21 Feb 2011 19:15:01 -0800
>    - *List-id*: PCP wg discussion list <pcp.ietf.org>
>
>  ------------------------------
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Port Control Protocol Working Group of the IETF.
>
>
> A URL for this Internet-Draft is:http://www.ietf.org/internet-drafts/draft-ietf-pcp-base-05.txt
>
> Internet-Drafts are also available by anonymous FTP at:ftp://ftp.ietf.org/internet-drafts/
>
>  <ftp://ftp.ietf.org/internet-drafts/draft-ietf-pcp-base-05.txt><ftp://ftp.ietf.org/internet-drafts/draft-ietf-pcp-base-05.txt>
>
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp
>
>

---

From: <[email-masked]>
Date: Tue, 22 Feb 2011 14:59:54 +0800

On Tue, Feb 22, 2011 at 12:19 PM, <[email-masked]>
wrote:

		Hello Dan,

		The requested lifetime field is missing in the MAP
OpCode Request format, in Figure9.   

	 I was not talking about the common header and the figure 9 is
about MAP OpCode Request header.

		Xiaohong

		*	From: Internet-Drafts at ietf.org
<mailto:[email-masked]>  
		*	To: i-d-announce at ietf.org
<mailto:[email-masked]>  
		*	Cc: pcp at ietf.org <mailto:[email-masked]>  
		*	Date: Mon, 21 Feb 2011 19:15:01 -0800 
		*	List-id: PCP wg discussion list <pcp.ietf.org> 

		A New Internet-Draft is available from the on-line
Internet-Drafts directories.
		This draft is a work item of the Port Control Protocol
Working Group of the IETF.

		Port Control Protocol allows a host to control how
incoming IPv6 or
		IPv4 packets are translated and forwarded by a network
address
		translator (NAT) or simple firewall to an IPv6 or IPv4
host, and also
		allows a host to optimize its NAT keepalive messages.

		
		
		Below is the data which will enable a MIME compliant
mail reader
		implementation to automatically retrieve the ASCII
version of the
		Internet-Draft.

---

From: Jacni Qin <[email-masked]>
Date: Tue, 22 Feb 2011 15:07:16 +0800

On Tue, Feb 22, 2011 at 2:59 PM, <[email-masked]> wrote:

>  On Tue, Feb 22, 2011 at 12:19 PM, <[email-masked]>wrote:
>
>   Hello Dan,
>>
>>
>>
>  I was not talking about the common header and the figure 9 is about MAP
> OpCode Request header.
>
> Jacni>: Sorry, I read your carelessly. Without it, the client can't easily
delete a given mapping.

---

From: <[email-masked]>
Date: Tue, 22 Feb 2011 15:13:21 +0800

On Tue, Feb 22, 2011 at 2:59 PM,
<[email-masked]> wrote:

		On Tue, Feb 22, 2011 at 12:19 PM,
<[email-masked]> wrote:

				Hello Dan,

				The requested lifetime field is missing
in the MAP OpCode Request format, in Figure9.   

			Jacni>: The lifetime field was removed from the
common header... 
			 
			 I was not talking about the common header and
the figure 9 is about MAP OpCode Request header.

	Jacni>: Sorry, I read your carelessly. Without it, the client
can't easily delete a given mapping. 
	 
	Yes, that's why it made me suprised when the first time I
noticed it,but I guess it's just a typo because there is an explaination
of the requested lifetime field right after the figure 9.  

				Xiaohong

				*	From: Internet-Drafts at
ietf.org <mailto:[email-masked]>  
				*	To: i-d-announce at ietf.org
<mailto:[email-masked]>  
				*	Cc: pcp at ietf.org
<mailto:[email-masked]>  
				*	Date: Mon, 21 Feb 2011 19:15:01
-0800 
				*	List-id: PCP wg discussion list
<pcp.ietf.org> 

				A New Internet-Draft is available from
the on-line Internet-Drafts directories.
				This draft is a work item of the Port
Control Protocol Working Group of the IETF.

					Title           : Port Control
Protocol (PCP)
					Author(s)       : D. Wing, et
al.
					Filename        :
draft-ietf-pcp-base-05.txt
					Pages           : 55
					Date            : 2011-02-21
				
				Port Control Protocol allows a host to
control how incoming IPv6 or
				IPv4 packets are translated and
forwarded by a network address
				translator (NAT) or simple firewall to
an IPv6 or IPv4 host, and also
				allows a host to optimize its NAT
keepalive messages.

				
				Internet-Drafts are also available by
anonymous FTP at:
				ftp://ftp.ietf.org/internet-drafts/
				
				Below is the data which will enable a
MIME compliant mail reader
				implementation to automatically retrieve
the ASCII version of the
				Internet-Draft.

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 22 Feb 2011 08:25:04 -0800

> -----Original Message-----
> From: [email-masked] [mailto:xiaohong.deng@orange-
> ftgroup.com]
> Sent: Monday, February 21, 2011 11:13 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [pcp] I-D Action:draft-ietf-pcp-base-05.txt
> 
> 
> 
> 				The requested lifetime field is missing in
the
> MAP OpCode Request format, in Figure9.
> 
> 
> 			 I was not talking about the common header and the
> figure 9 is about MAP OpCode Request header.
> 
> 	Yes, that's why it made me suprised when the first time I noticed
> it,but I guess it's just a typo because there is an explaination of the
> requested lifetime field right after the figure 9.

Thanks for catching it.  It was an editing error.  Figure 9 should have
included a 'requested lifetime'.  The corrected packet layout is:

   0                   1                   2                   3
   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
  |  Protocol     |          Reserved (24 bits)                   |
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
  :                                                               :
  : Requested external IP address (32 or 128, depending on OpCode):
  :                                                               :
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
  |                       Requested Lifetime                      |
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
  |        internal port          |   requested external port     |
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

               Figure 9: MAP OpCode Request Packet Format

This will be fixed in -06.

-d