Subject: [pcp] maximum lifetime

From: Francis Dupont <[email-masked]>
Date: Fri, 22 Apr 2011 14:18:17 +0200

The current base spec in section 8.6 page 34 RECOMMEND a maximum
assigned lifetime of 24 hours. It makes sense for PCP itself
but is not compatible with UPnP IGD 2:
 - I don't consider IGD 1 as it will be replaced by IGD 2
  and about this particular point one can easily argue it was
  broken and fixed by IGD 2.

 - maximum IGD 2 PortMappingLeaseDuration is 604800 seconds
  (i.e., 7 days)

 - when a UPnP IGD 2 IWF creates an explicit dynamic mapping
  for a long lifetime, it renews the PCP mapping before it
  expires to make its apparent (to the IGD control point)
  lifetime equals to the PortMappingLeaseDuration

 - now if such a renewal PCP request fails the IWF has no
  way to recover.

So I ask a new ticket to discuss about:
 - to increase the RECOMMEND maximum value at at least 7 days

 - to explain this value in order to make implementors or
  managers who could want to use a lower value aware of
  the consequences on UPnP IGD 2 IWF.

Regards

[email-masked]

---

From: <[email-masked]>
Date: Fri, 22 Apr 2011 14:40:13 +0200

Hi Francis,

Wouldn't be more appropriate to discuss this point in the UPnP/PCP IWF document rather than the base PCP spec? 

Note that recommending a longer lifetime would have some side effects such as maintaining stale mappings for a long period (i.e., consume per-user quota).

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Francis Dupont
Envoyé : vendredi 22 avril 2011 14:18
À : [email-masked]
Objet : [pcp] maximum lifetime

Regards

[email-masked]
_______________________________________________
pcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcp

---

From: Francis Dupont <[email-masked]>
Date: Fri, 22 Apr 2011 14:52:17 +0200

In your previous mail you wrote:

   Wouldn't be more appropriate to discuss this point in the UPnP/PCP
   IWF document rather than the base PCP spec?
   
=> the recommendation is in the base spec.

Perhaps you mean the explaination should be in the UPnP IGD IWF
document and base spec should only refer to it? If the ticket
is addressed the common way you are losing your time...

   Note that recommending a longer lifetime would have some side
   effects such as maintaining stale mappings for a long period (i.e.,
   consume per-user quota).
   
=> I know: this is why I said it makes sense for PCP itself.

Regards