Subject: [pcp] PCP Error Recovery

From: Stuart Cheshire <[email-masked]>
Date: Fri, 01 Apr 2011 08:07:19 -0700

I just submitted draft-cheshire-pcp-recovery-00.txt. Please review and send comments (you only have to read pages 2 and 3; the rest is boilerplate). I'd like to WG Last-Call this along with draft-ietf-pcp-base in two weeks.

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* www.stuartcheshire.org

---

From: Reinaldo Penno <[email-masked]>
Date: Fri, 1 Apr 2011 15:15:26 -0400

Hi Stuart,

We had this in the first version of the base draft (based on NAT-PMP) but
relying on Multicast was considered a roadblock. Was any change/consensus in
the meeting about this?

Thanks,

Reinaldo

On 4/1/11 8:07 AM, "Stuart Cheshire" <[email-masked]> wrote:

> I just submitted draft-cheshire-pcp-recovery-00.txt. Please review and send
> comments (you only have to read pages 2 and 3; the rest is boilerplate). I'd
> like to WG Last-Call this along with draft-ietf-pcp-base in two weeks.
> 
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Stuart Cheshire <[email-masked]>
Date: Sat, 02 Apr 2011 00:12:06 -0700

> relying on Multicast was considered a roadblock. Was any change/consensus in

It's not relying on multicast. It says "MAY".

A typical home gateway (DHCP+NAT) serving clients on a local link MAY notify clients by sending a multicast.

If some scenarios (e.g. DS-Lite?) cannot make use of multicast, does that mean no one should be allowed to?

In any case, according to some points of view a DS-Lite AFTR will exclusively utilize battery-backed double-redundant persistent storage which can never lose state, so it will never need to notify clients of a reset, so in practice it may only be consumer-grade home gateways that need to do this anyway.