Subject: [pcp] Merging UNAUTH_TARGET_ADDRESS with NOT_AUTHORIZED

From: Simon Perreault <[email-masked]>
Date: Wed, 20 Apr 2011 09:35:40 -0400

Hi,

I was wondering why there are two error codes for doing basically the
same thing. Why is it important for the client to know what caused the
authorization failure? Couldn't we eliminate UNAUTH_TARGET_ADDRESS and
return NOT_AUTHORIZED instead?

Thanks,
Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 20 Apr 2011 11:07:04 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Simon Perreault
> Sent: Wednesday, April 20, 2011 6:36 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [pcp] Merging UNAUTH_TARGET_ADDRESS with NOT_AUTHORIZED
> 
> Hi,
> 

UNAUTH_TARGET_ADDRESS is only returned if the address in THIRD_PARTY
is being refused.  NOT_AUTHORIZED isn't tied to THIRD_PARTY, and would
be returned for other reasons.  The separation is intended to allow
better handling of authorization failures specific to third-party
mapping requests.

-d

> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp