Subject: [pcp] Comments on draft-cheshire-pcp-recovery-02

From: Dave Thaler <[email-masked]>
Date: Mon, 31 Oct 2011 18:00:20 +0000

Two comments:

1) This draft uses port 5350 rather than the existing PCP port 5351.
It contains no justification that I saw as to why it cannot use the same port number.
Port space is scarce, so this should either justify why it needs two, or else
(my preference) use the same port number as PCP.

2) It says "MUST inform PCP clients of this fact by
multicasting the UDP packet shown below on all multicast-capable
interfaces".   The implication is that it must do so even if it has some way to
know (e.g. a CGN being manually configured with that topological knowledge)
that there are no PCP clients on that interface, which results in extra overhead.
I wanted to point this out in case anyone felt this is an issue and there is some
reason to change to a SHOULD.   I'm personally fine either way.

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of RJ
> Atkinson
> Sent: Friday, October 28, 2011 3:01 AM
> To: [email-masked]
> Subject: Re: [pcp] WG last call on draft-ietf-pcp-base-16.txt
> 
> 
> On 26  Oct 2011, at 00:44 , Paul Selkirk wrote:
> > OTOH, a) if we define it for IPv4 multicast, someone will surely and
> > immediately request it for IPv6 multicast;
> 
> As you predicted, in this morning's email, Keith Moore expressed interest in
> IPv6.
> 
> However, Stuart released draft-cheshire-pcp-recovery-02 overnight.
> The revised I-D text is IP version agnostic, including language about link-local
> all-nodes multicast for both IPv4 and IPv6.
> 
> So the concern quoted at top is resolved at this point.
> 
> If other specific issues/concerns exist with draft-cheshire-pcp-recovery, please
> make those issues/concerns known to the whole PCP WG list, ideally with some
> concrete suggestions on how to resolve any issues/concerns.
> 
> Yours,
> 
> Ran
> 
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Reinaldo Penno <[email-masked]>
Date: Mon, 31 Oct 2011 21:17:08 -0400

You are not alone. I support a 'qualified' SHOULD.

I pointed out in the thread that one of the requirements for recovery
multicast working efficiently was that PCP Server and BNG/Edge router/NAT
needed to be the same device so it knows through which interfaces to
multicast the recovery packet.

" Well, multicast recovery is applicable if several conditions are met:

....

4 - Finally, PCP Server (which sends the multicast packet), NAT (controlled
    device) and BNG/GGSN (which knows the interface to send multicast
    packet) should ideally be the same device which might be the case or
    not."

In the worst (but simpler) case firewall/NAT router would send packet on all
(possibly thousands of interfaces). Still works but it will trigger an
avalanche of renewal that the PCP Server will need to handle. Apart from
that, text is okay.

Thanks,

Reinaldo