Subject: [pcp] minor incoherence in base 14 9.3

From: Francis Dupont <[email-masked]>
Date: Thu, 13 Oct 2011 23:56:10 +0200

In base 14 section 9.3:

   o  The PREFER_FAILURE option is included in the request and the
      Suggested External Address is not assignable to the PCP client.

=> even I believe this should stand it is not (yet) compatible
with the current definition of PREFER_FAILURE and BTW there is
no (yet) a corresponding error...

Regards

[email-masked]

PS: BTW IMHO it is already covered by:

   o  The Suggested External Address and Port is otherwise prohibited by
      the PCP server's policy.

which is a previous item of the list...

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 13 Oct 2011 15:47:12 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Francis Dupont
> Sent: Thursday, October 13, 2011 2:56 PM
> To: [email-masked]
> Subject: [pcp] minor incoherence in base 14 9.3
> 
> In base 14 section 9.3:
> 

How is it incompatible with the current definition of PREFER_FAILURE?

> which is a previous item of the list...

-d

> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Francis Dupont <[email-masked]>
Date: Fri, 14 Oct 2011 10:54:26 +0200

=> there is no CANNOT_PROVIDE_EXTERNAL_ADDRESS...
BTW if you add it (and I strongly support this) it should take
precedence over CANNOT_PROVIDE_EXTERNAL_PORT as usually
it is useless to get the port without the address.

Regards

PS: precedence here is about the rule order.

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 14 Oct 2011 09:12:25 -0700

> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, October 14, 2011 1:54 AM
> To: Dan Wing
> Cc: [email-masked]
> Subject: Re: [pcp] minor incoherence in base 14 9.3
> 
> 

Is there value in two different errors for cannot-provide-external-address
and cannot-provide-external-port, rather than a single error
CANNOT_PROVIDE_EXTERNAL (which could cover both inability to get the
requested external address and inability to get external port)?  Having one
error also eliminates the problem of which error takes precedence when both
the port and the external address cannot be assigned.

-d