Subject: [pcp] section 8

From: Tina TSOU <[email-masked]>
Date: Fri, 14 Oct 2011 23:17:43 +0000

Hi,
In section 8, it reads:
  "It is REQUIRED that the PCP-controlled device assign the same
   external IP address to PCP-created explicit dynamic mappings and to
   implicit dynamic mappings for a given Internal Host.  In the absence
   of a PCP option indicating otherwise, it is REQUIRED that PCP-created
   explicit dynamic mappings be assigned the same external IP address."
It is not consistent with what we have discussed in the mailing list below. And it is a bit ambiguous in reading.

How about changing the second sentence from on of the 4 candidates as below?

Alternative 1:
PCP client should request same external IP address for an application if there is already any existing explicit mapping for that application.

Alternative 2:
PCP client should request the same external IP address if there are existing explict mappings, unless there is explicit reasons of not doing so, e.g. http://tools.ietf.org/html/draft-penno-pcp-zones-00

Alternative 3:
It is indicated by the PCP client that PCP-created explicit dynamic mappings be assigned the same external IP address, unless there are explicit reasons of not doing so, e.g. http://tools.ietf.org/html/draft-penno-pcp-zones-00"

Alternative 4:
It is indicated by the PCP client that PCP-created explicit dynamic mappings be assigned the same external IP address, unless a PCP option indicates different external IP address

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

---

From: Francis Dupont <[email-masked]>
Date: Sat, 15 Oct 2011 13:47:45 +0200

In your previous mail you wrote:

   Hi,
   In section 8, it reads:
     "It is REQUIRED that the PCP-controlled device assign the same
      external IP address to PCP-created explicit dynamic mappings and to
      implicit dynamic mappings for a given Internal Host.  In the absence
      of a PCP option indicating otherwise, it is REQUIRED that PCP-created
      explicit dynamic mappings be assigned the same external IP address."
   It is not consistent with what we have discussed in the mailing list below. And i
  t is a bit ambiguous in reading.

   Alternative 1:
   PCP client should request same external IP address for an application if there is
   already any existing explicit mapping for that application.
   
=> the section 8 rule is per subscriber+host so the alternative should be too.

   Alternative 2:
   PCP client should request the same external IP address if there are existing expl
  ict mappings, unless there is explicit reasons of not doing so, e.g. http://tools.
  ietf.org/html/draft-penno-pcp-zones-00
   
=> same issue

   Alternative 3:
   It is indicated by the PCP client that PCP-created explicit dynamic mappings be a
  ssigned the same external IP address, unless there are explicit reasons of not doi
  ng so, e.g. http://tools.ietf.org/html/draft-penno-pcp-zones-00"
   
=> same issue

   Alternative 4:
   It is indicated by the PCP client that PCP-created explicit dynamic mappings be a
  ssigned the same external IP address, unless a PCP option indicates different exte
  rnal IP address
   
=> same issue   
   
I can't see the problem, the text says all mappings (even there is nothing
about static mappings, is there a problem to add them?) get the same external
IP address if there is no option indicating otherwise.
BTW IWFs work far better if the affinity is per subscriber.

IMHO the best should be to make the affinity larger, i.e., per subscriber
and for all mappings, but at a lower level, i.e., with a RECOMMEND/SHOULD
in place of the current REQUIRE/MUST.

Regards

[email-masked]

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 17 Oct 2011 16:32:54 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Tina TSOU
> Sent: Friday, October 14, 2011 4:18 PM
> To: [email-masked]
> Subject: [pcp] section 8
> 
> Hi,
> In section 8, it reads:
> It is not consistent with what we have discussed in the mailing list
> below. And it is a bit ambiguous in reading.

The text allows draft-penno-pcp-zones, provided that draft-penno-pcp-zones
defines and a PCP option (which it does) and the PCP request uses 
that option (which is up to the PCP client, of course).

I don't see the ambiguity in the existing text.  What is the problem?

-d

> PCP client should request same external IP address for an application
> if there is already any existing explicit mapping for that application.
> 
> Alternative 2:
> PCP client should request the same external IP address if there are
> existing explict mappings, unless there is explicit reasons of not
> doing so, e.g. http://tools.ietf.org/html/draft-penno-pcp-zones-00
> 
> Alternative 3:
> It is indicated by the PCP client that PCP-created explicit dynamic
> mappings be assigned the same external IP address, unless there are
> explicit reasons of not doing so, e.g.
> http://tools.ietf.org/html/draft-penno-pcp-zones-00"
> 
> Alternative 4:
> It is indicated by the PCP client that PCP-created explicit dynamic
> mappings be assigned the same external IP address, unless a PCP option
> indicates different external IP address
> 
> 
> 
> Best Regards,
> Tina TSOU
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Tina TSOU <[email-masked]>
Date: Tue, 18 Oct 2011 13:23:41 +0000

Francis,
Reply inline:
________________________________________
发件人: [email-masked] [[email-masked]] 代表 Francis Dupont [[email-masked]]
发送时间: 2011年10月15日 19:47
到: Tina TSOU
Cc: [email-masked]
主题: Re: [pcp] section 8

   Hi,
   In section 8, it reads:

   Alternative 1:

=> the section 8 rule is per subscriber+host so the alternative should be too.
[TT] Do you mean that section 8 has defined the same external IP address per subscriber+host, and we don't need to propose the alternative texts? 
If so, could you please point out the texts for me? Thanks.

   Alternative 2:

=> same issue

   Alternative 3:

=> same issue

   Alternative 4:

=> same issue

[TT] From the current texts, it is easily understood that the address is allocated by PCP server.
However,  the same external IP address for one application is required by the PCP client.

[TT] Agree.

Regards

---

From: Francis Dupont <[email-masked]>
Date: Tue, 18 Oct 2011 16:48:30 +0200

I don't include the gb2312/base64 full text...

=> the section 8 rule is per subscriber+host so the alternative should be too.
[TT] Do you mean that section 8 has defined the same external IP
address per subscriber+host, and we don't need to propose the
alternative texts?

=> what I mean is this is not an alternative but a deep change.
And BTW I am not in its favor, I already consider the section 8 rule
far too permissive (I want an unique per subscriber and long term
external address).

Regards

---

From: Tina TSOU <[email-masked]>
Date: Thu, 20 Oct 2011 08:36:31 +0000

How about
In the absence of a PCP option indicating otherwise, it is REQUIRED that PCP-created explicit dynamic mappings be assigned the same external IP address as requested by PCP client.

Best Regards,
Tina TSOU

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, October 18, 2011 4:49 PM
To: Tina TSOU
Cc: [email-masked]
Subject: Re: [pcp] section 8

Regards

---

From: Francis Dupont <[email-masked]>
Date: Thu, 20 Oct 2011 11:31:37 +0200

How about
   In the absence of a PCP option indicating otherwise, it is REQUIRED
   that PCP-created explicit dynamic mappings be assigned the same
   external IP address as requested by PCP client.
   
=> IMHO this is useless as the PREFER_FAILURE in base 15 (IMHO again)
provides this.
   
Regards