Subject: Re: [pcp] Using dynamically assigned port numbers with static URLs

From: Masataka Ohta <[email-masked]>
Date: Wed, 02 Nov 2011 18:17:42 +0900

Keith Moore wrote:

> Port mapping NATs should also be considered at EOL.
> I understand that the motivation for creating PCP was
> LSNs and the loss of UPnP/NAT-PMP capability,

> but PCP is useful even without port-mapping NATs.

It is not a valid argument against having servers behind LSNs.

> We should not be destroying a valuable capability to
> explicitly specify port numbers

As owners of domains in URLs have control over SRV contents
and the URLs, the domain owners can choose to have SRVs
with port numbers of 0:

   _<scheme>._<proto>.<hostname> SRV <priority> <weight>
                                        0 <target>

then, the current URL syntax of "a valuable capability to
explicitly specify port numbers" is maintained.

> and have those literal
> port numbers mean what they say, just because of LSNs.

The draft can be modified so.

But, as long as the owners of the domains in the URLs
can understand the meaning of the URLs, let the domain
owners choose.

						Masataka Ohta

---

From: Keith Moore <[email-masked]>
Date: Wed, 2 Nov 2011 08:30:39 -0400

> explicitly specify port numbers" is maintained.

Don't make the mistake of assuming that "owners of domains" are responsible for maintenance of the hosts.

Retroactively applying SRV records to existing services, or URI types, is an Extremely Bad Idea.  It would break valuable functionality and complicate the architecture in the long term for a very dubious gain in the short term.   It's unacceptable.

> can understand the meaning of the URLs, let the domain

DNS is already too out of sync with reality.  Domain owners are often in a very poor position to know what's going on with hosts.   Giving them yet another way to break hosts is not a good idea.

Keith

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 03 Nov 2011 10:28:23 +0900

Keith Moore wrote:

> Don't make the mistake of assuming that "owners of domains"
> are responsible for maintenance of the hosts.

The assumption is not that the domain owners and the server
maintainers are identical.

The assumption, instead, is that the domain owners and the
server maintainers are identical *OR* cooperate.

> Retroactively applying SRV records to existing services, or
> URI types, is an Extremely Bad Idea.  It would break
> valuable functionality and complicate the architecture
> in the long term

For example?

So far, your statement is abstract nonsense.

> DNS is already too out of sync with reality.  Domain owners
> are often in a very poor position to know what's going on
> with hosts.

If it's not another abstract nonsense, it is a serious
problem for entire DNS protocol, not limited to SRV.

If you want your statement seriously considered, tell it to
DNSEXT or DNSOP with real world examples.

						Masataka Ohta

---

From: Keith Moore <[email-masked]>
Date: Wed, 2 Nov 2011 22:05:12 -0400

> server maintainers are identical *OR* cooperate.

Not a valid assumption, in general.  To the extent that it's valid, it's valid only for a small number of public-facing resources.

> So far, your statement is abstract nonsense.

Complicating the architecture, I hope, is self explanatory.

Breaking valuable functionality, I've already explained.    Being able to specify the actual port number used on the wire is valuable functionality.

In addition, remapping port numbers in URLs means that those URLs will be valid, or not, depending on whether the software that parses the URL understands the SRV hack.   So that breaks compatibility with existing implementations.

There's a reason why SRV records only apply to protocols that are defined to use them.

> problem for entire DNS protocol, not limited to SRV.

It is a serious problem for the entire DNS protocol.  But you don't have to make it worse by increasing dependence on an already bad situation.

> DNSEXT or DNSOP with real world examples.

Those people are generally more aware of the problems.

Keith

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 03 Nov 2011 11:51:51 +0900

Keith Moore wrote:

The only example you can show is:

> In addition, remapping port numbers in URLs means that those
> URLs will be valid, or not, depending on whether the software
> that parses the URL understands the SRV hack.   So that
> breaks compatibility with existing implementations.

Domains with SRV RRs may have no address RRs or, for some
applications including http, may have address RRs of a server
to tell old implementations that SRV is used with appropriate
indirectionns.

> Breaking valuable functionality, I've already explained.

Does it mean that you are breaking valuable functionality
of Internet mails by not wrapping lines properly?

						Masataka Ohta