Subject: Re: [pcp] Fwd: New Version Notification for draft-chen-pcp-authentication-sim-00.txt

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 21 Jul 2014 14:17:14 +0000

> -----Original Message-----
> From: GangChen [mailto:[email-masked]]
> Sent: Friday, July 04, 2014 3:41 PM
> To: [email-masked]
> Subject: [pcp] Fwd: New Version Notification for draft-chen-pcp-authentication-
> sim-00.txt
> 
> WG,
> 
> I have submitted a draft to describe the consideration of PCP authentication
> with (U)SIM support. The process is detailed in EAP and GBA framework.

Interesting draft. This solves the problem that for PCP authentication to work in Mobile networks, PCP client does not have use username and password but only use SIM credentials (EAP-SIM).  Other operators like Deutsche-Telekom are already using SIM authentication for ISP offered services (Slide 11 http://www.gsma.com/personaldata/wp-content/uploads/2014/03/OpenID-Connect-at-Deutsche-Telekom-Torsten-Lodderstedt.pdf)

-Tiru

> Thank you for the comments in advance.
> 
> Best Regards
> 
> Gang
> 
> ---------- Forwarded message ----------
> From: [email-masked]
> Date: Fri, 04 Jul 2014 03:03:05 -0700
> Subject: New Version Notification for draft-chen-pcp-authentication-sim-00.txt
> To: Gang Chen <[email-masked]>
> 
> 
> A new version of I-D, draft-chen-pcp-authentication-sim-00.txt
> has been successfully submitted by Gang Chen and posted to the IETF repository.
> 
> Name:		draft-chen-pcp-authentication-sim
> Revision:	00
> Title:		(U)SIM based PCP Authentication
> Document date:	2014-07-03
> Group:		Individual Submission
> Pages:		8
> URL:
> http://www.ietf.org/internet-drafts/draft-chen-pcp-authentication-sim-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-chen-pcp-authentication-sim/
> Htmlized:       http://tools.ietf.org/html/draft-chen-pcp-authentication-sim-00
> 
> 
> Abstract:
>    With (U)SIM support, PCP authentication could leverage the
>    credentials stored in (U)SIM.  The document details PCP
>    authentication considerations based on (U)SIM support.  The
>    authentication procedures in EAP and GBA framework have been
>    specifically elaborated.  In order to complete the process, new code
>    and option are also proposed.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: GangChen <[email-masked]>
Date: Wed, 23 Jul 2014 19:46:58 +0800

2014-07-21 22:17 GMT+08:00, Tirumaleswar Reddy (tireddy) <[email-masked]>:
> Interesting draft. This solves the problem that for PCP authentication to
> work in Mobile networks, PCP client does not have use username and password
> but only use SIM credentials (EAP-SIM).  Other operators like
> Deutsche-Telekom are already using SIM authentication for ISP offered
> services (Slide 11
> http://www.gsma.com/personaldata/wp-content/uploads/2014/03/OpenID-Connect-at-Deutsche-Telekom-Torsten-Lodderstedt.pdf)

Thank you for the comments. I would like to further highlight the
technical advantage using GBA to PCP. The thought is to leverage the
deployed GBA infrastructure. AFAIK, GBA is indispensable to the mobile
operators, who like to offer voice service in the LTE age. It's
low-cost and lightweight implementation to the PCP server.(only one
simply message extension makes it work, as draft proposed at Section
3).

BRs

Gang

>> Htmlized:
>> http://tools.ietf.org/html/draft-chen-pcp-authentication-sim-00
>>
>>
>> Abstract:

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 31 Jul 2014 17:32:07 +0000

> Sent: Wednesday, July 23, 2014 5:17 PM
> To: Tirumaleswar Reddy (tireddy)
> Cc: [email-masked]
> Subject: Re: [pcp] Fwd: New Version Notification for draft-chen-pcp-
> authentication-sim-00.txt
> 
> >> I have submitted a draft to describe the consideration of PCP
> >> authentication with (U)SIM support. The process is detailed in EAP
> >> and GBA framework.
> >
> > Interesting draft. This solves the problem that for PCP authentication
> > to work in Mobile networks, PCP client does not have use username and
> > password but only use SIM credentials (EAP-SIM).  Other operators like
> > http://www.gsma.com/personaldata/wp-content/uploads/2014/03/OpenID-
> Con
> > nect-at-Deutsche-Telekom-Torsten-Lodderstedt.pdf)
> 
> Thank you for the comments. I would like to further highlight the technical
> advantage using GBA to PCP. The thought is to leverage the deployed GBA
> infrastructure. AFAIK, GBA is indispensable to the mobile operators, who like to
> offer voice service in the LTE age. It's low-cost and lightweight implementation
> to the PCP server.(only one simply message extension makes it work, as draft
> proposed at Section 3).

The other technique mentioned in the draft is using HTTP authentication and not EAP. 

1. what is the need for this mechanism when EAP-SIM can be used ?
2. It deviates from REQ-6 of fate sharing http://tools.ietf.org/html/draft-reddy-pcp-auth-req-04 that was discussed in the WG sometime back.

-Tiru

> >> Please note that it may take a couple of minutes from the time of
> >> submission until the htmlized version and diff are available at
> >> tools.ietf.org.
> >>
> >> The IETF Secretariat
> >>
> >
> >