Subject: Re: [Pearg] draft-irtf-pearg-censorship review

From: Joseph Lorenzo Hall <[email-masked]>
Date: Mon, 18 May 2020 16:43:17 +0000

Thanks, Chris! … one last thing and I’ll peel off a new version shortly:

On Apr 30, 2020, at 7:00 PM, Christopher Wood <[email-masked]<mailto:[email-masked]>> wrote:

* Section 4.2.3: It's probably worth mentioning QUIC here, especially as it complicates this type of attack. It might also be worth citing recent research [3] on off-path TCP attacks, noting that the censor need not be on-path to interfere with service.

(That off-path paper is awesome! Had not seen that.)

Cool, that makes sense about QUIC. I don't have a good feel for what to
write here. How does this feel, "Note, the increasingly popular QUIC
protocol is based on UDP, a connection-less transport protocol, so
cannot be attacked using TCP RST packet injection."

That seems a bit weird... but it sounds like there may be more under
the surface to your comment so please suggest how that text above could
be better cleaned up?

I'd probably just say something like, "QUIC is not vulnerable to these types of injection attacks. See {{quic-draft}} for more details."

Done.

* Section 3.2.1: The [Verkamp-2012] reference seems broken.

Hmmm, I don't see this. The link works (
https://www.usenix.org/system/files/conference/foci12/foci12-final1.pdf
) and the reference is rendering correctly.

Oh, sorry, the link is working, it's the reference in the document (the forward pointer to the references section) that's broken (not clickable):

  https://tools.ietf.org/html/draft-irtf-pearg-censorship-02#section-3.2.1

I can’t reproduce this locally. The HTML output on my side has the correct anchor, etc. I’ll upload a new version to the datatracker and see if that fixes it… if not, I’ll dig deeper and see if it’s MT’s markdown tool or datatracker, etc.

best, Joe

--
Joseph Lorenzo Hall, Senior Vice President, Strong Internet
[email-masked]<mailto:[email-masked]> | +1-703-483-9504
internetsociety.org<http://internetsociety.org> | @internetsociety
pgp: https://josephhall.org/gpg-key
3CA28D7B9F6DDBD34B1016075F86698740A9A871

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Mon, 18 May 2020 16:52:00 +0000

On May 18, 2020, at 12:43 PM, Joseph Lorenzo Hall <[email-masked]<mailto:[email-masked]>> wrote:
* Section 3.2.1: The [Verkamp-2012] reference seems broken.

Ok, whatever was doing this is no longer doing this. The Verkamp cite is now clickable in both the datatracker and tools HTML versions:

https://datatracker.ietf.org/doc/html/draft-irtf-pearg-censorship-03#section-3.2.1
https://tools.ietf.org/html/draft-irtf-pearg-censorship-03#section-3.2.1

best, Joe