Subject: Re: [Pearg] I-D Action: draft-irtf-pearg-censorship-04.txt

From: Vittorio Bertola <[email-masked]>
Date: Tue, 4 Aug 2020 17:25:41 +0200 (CEST)

> Il 13/07/2020 20:46 [email-masked] ha scritto:
> 
>  
> A New Internet-Draft is available from the on-line Internet-Drafts directories.

Before I forget - since we said we'd discuss it on the list - I have an idea to address the ongoing disagreement on the meaning of "censorship". We could replace the initial definition of censorship with a brief discussion on the fact that there is no agreement in the I*TF community on what it means, and that different people use the term, in broader or narrower terms, to identify:

1. any blocking of content
2. any blocking of content except when done for technical and network security reasons (botnets, malware etc)
3. only the blocking of political content opposing a country's regime

So for a significant part of the Internet community these techniques can be used for legitimate purposes other than censorship, and this should be acknowledged from the beginning, agreeing that not everyone using these techniques is a censor or accepts to be depicted like that.

Then, it seems to me (though I haven't gone through the draft checking each and every reference) that almost all examples in the draft relate to authoritarian countries and to the narrow definition #3. This leaves us with a number of possibilities:
- complete the survey with examples of the other uses of these techniques, while mentioning that these are not considered censorship by everyone;
- only limit the survey to the examples that fall in #3, as these are unanimously considered to be censorship;
- something in the middle, e.g. leave some examples of "non-political censorship" (such as the EU examples at the end of page 16) but mention that they are not generally considered to be cases of censorship.

I would be happy to work on text, but first I'd like to see if this approach would make sense for everyone.

-- 
Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Mallory Knodel <[email-masked]>
Date: Tue, 4 Aug 2020 11:38:57 -0400

> So for a significant part of the Internet community these techniques can be used for legitimate purposes other than censorship, and this should be acknowledged from the beginning, agreeing that not…

It's been said in this thread that censorship can be legitimate or 
illegitimate.

It shouldn't be the aim of this draft to talk about the censors at all, 
nor how they'd like to be depicted. The draft is about the techniques.

-Mallory

-- 
Mallory Knodel
CTO, Center for Democracy and Technology
gpg fingerprint :: E3EB 63E0 65A3 B240 BCD9 B071 0C32 A271 BD3C C780

---

From: Amelia Andersdotter <[email-masked]>
Date: Tue, 4 Aug 2020 18:13:06 +0200

> - something in the middle, e.g. leave some examples of "non-political censorship" (such as the EU examples at the end of page 16) but mention that they are not generally considered to be cases of c…

Pretty much all of those examples have been extremely contentious
precisely because they risk over-blocking and are rarely accompanied by
robust due-process mechanisms. So much so that the Council of Europe
Human Rights Commissioner at one point in 2014 specifically addressed
the unsuitability of governments dumping responsibility for censorship
on private sector parties in order to avoid accountability for solving
underlying problems of crime or injustice.

A large part of the reason I believe that this draft is important is
that there have been a lot of efforts, especially in jurisdictions where
I have done a lot of work (broadly European Union countries), to
privatise assessments of the morality, legality or suitability of
internet-accessible resources, in a way that specifically removes public
accountability and foreseeability.

The fact that governments have acted in a way which shifts
accountability/responsibility on to actors who are doing important work
here at I*TF means that it's important to have a framework for the I*TF
to deal with that accountability. The right way forward is then *not* to
say that specifically the situations where such accountability and
responsibility has been shifted to the private sector, are those
situations which we should be excluding from this work (I don't think).

But the intent here is not to discourage anyone from following locally
applicable laws and regulations. 

best regards,

Amelia

-- 
^\...~...~...~...~...~.../^
Amelia Andersdotter
Director of Strategic Initiatives, CENTR
www.centr.org
^\...~...~...~...~...~.../^

---

From: Vittorio Bertola <[email-masked]>
Date: Tue, 4 Aug 2020 18:59:05 +0200 (CEST)

> Il 04/08/2020 17:38 Mallory Knodel <[email-masked]> ha scritto:
> 
>  

But not in the draft, as far as I can recall.

> nor how they'd like to be depicted. The draft is about the techniques.

The point is whether we can ever come to consensus on this draft and turn it into an RFC, which in my opinion is going to be hard if some IETF participants have to accept to be labelled as "censors" for using the techniques in the draft to, say, block access to phishing websites, or execute a court order.

On Amelia's comment - I agree, but my observation is related to types of blocked content, not to who is blocking them. Of course political censorship is still political censorship even if private parties do it, and in Italy there have been troubling cases of Facebook closing down the pages of legitimate (though personally disgusting) political parties without any kind of public scrutiny. Also, it makes sense to request accountability in any use of these techniques, to make sure that they are not surreptitiously used for political purposes. Still, this does not mean that blocking malware is censorship.

---

From: Mallory Knodel <[email-masked]>
Date: Tue, 4 Aug 2020 13:02:35 -0400

> But not in the draft, as far as I can recall.
It's out of scope to define censorship from scratch, and it references a 
wikipedia page that says this very thing in the first para.
> The point is whether we can ever come to consensus on this draft and turn it into an RFC, which in my opinion is going to be hard if some IETF participants have to accept to be labelled as "censors…

Consensus isn't required for an IRTF RFC. Again, the draft doesn't label 
censors; it's a draft about techniques.

-Mallory

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 4 Aug 2020 10:15:08 -0700

On Tue, Aug 4, 2020 at 9:59 AM Vittorio Bertola <vittorio.bertola=
[email-masked]> wrote:

> > > So for a significant part of the Internet community these techniques
> can be used for legitimate purposes other than censorship, and this should
> be acknowledged from the beginning, agreeing that not everyone using these
> techniques is a censor or accepts to be depicted like that.
> >
> The point is whether we can ever come to consensus on this draft and turn
> it into an RFC, which in my opinion is going to be hard if some IETF
> participants have to accept to be labelled as "censors" for using the
> techniques in the draft to, say, block access to phishing websites, or
> execute a court order.
>

As I said before, it's useful here to distinguish between blocking that is
with the consent of the user (albeit sometimes in an opt-out fashion as
with safe browsing) and that which is imposed on the user without their
consent. I don't see a problem with calling the latter censorship, even if
the content being blocked is non-political.

-Ekr

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Tue, 4 Aug 2020 17:19:53 +0000

On Aug 4, 2020, at 1:15 PM, Eric Rescorla <[email-masked]<mailto:[email-masked]>> wrote:

On Tue, Aug 4, 2020 at 9:59 AM Vittorio Bertola <vittorio.bertola=[email-masked]<mailto:[email-masked]>> wrote:

> Il 04/08/2020 17:38 Mallory Knodel <[email-masked]<mailto:[email-masked]>> ha scritto:
>
>

As I said before, it's useful here to distinguish between blocking that is with the consent of the user (albeit sometimes in an opt-out fashion as with safe browsing) and that which is imposed on the user without their consent. I don't see a problem with calling the latter censorship, even if the content being blocked is non-political.

I like consent vs. non-consent better than legitimate vs. illegitimate it is definitely a more clear state (legitimacy is in the eye of the beholder, I’d think).

I’m not sure consent vs. non-consent will address Vittorio or Elliot’s critiques here, I suspect not.

best, Joe

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 4 Aug 2020 20:58:31 +0200

On Tue, Aug 04, 2020 at 05:25:41PM +0200,
 Vittorio Bertola <vittorio.bertola=[email-masked]> wrote 

> 3. only the blocking of political content opposing a country's regime

I don't think that anyone, at the IETF or elsewhere, would label
"censorship" "any blocking of content". If I install uBlock on my
browser (or Pi Hole on the network), it is clearly not censorship if
half of the content of a Web page is blocked.

Censorship is when a third party blocks content that the sender wants
to send and the recipient wants to receive. Your case 2 is in the grey
area since it can be said that the recipient does not want to receive
malware.

Also, case 3 is way too narrow. If content is blocked for business
reasons, it is no longer censorship?

> accepts to be depicted like that.

I agree with Mallory here: people cannot choose how they are depicted,
it would be too easy.

> Then, it seems to me (though I haven't gone through the draft
> checking each and every reference) that almost all examples in the
> draft relate to authoritarian countries

Several examples (may be only a minority) are for the European
Union. Most members of the EU cannot probably be described as
"authoritarian".

> - only limit the survey to the examples that fall in #3, as these
> are unanimously considered to be censorship;

Not even that case is unanimous. The chinese governement does not call
its blocking "censorship" but use nice words like "maintaning
harmony".

---

From: Eliot Lear <[email-masked]>
Date: Tue, 4 Aug 2020 21:47:13 +0200

Hi Joe and everyone

First, I want to thank the chairs and the authors and Vittorio and others for engaging in a good discussion, and in particular, I’d like to thank you for taking the time to write out this document.

There are some interesting parallels between this discussion and the terminology flames that have taken place on the IETF list.  Who gets to define or choose terms?  Does the IETF have the experience and understanding to do so?  I think I would prefer the answer to be “no”.  We are, after all, mostly engineers, and we should stick to our knitting, as it were.  To a lesser extent, this is true of the IRTF as well.

Where I think we get to have more of a voice is how those terms apply to us and our industry, and that is something we shouldn’t duck.  Therefore, my view is that we should go with a definition that would be generally acceptable to appropriate experts, if there is one.  I will note that the Wikipedia one has changed in the time you wrote the document, which does lead to a concern about stability.   You could otherwise hedge along the lines Vittorio is suggesting or in some other way.

But then we should also at least briefly state how the term applies in our context, so as to make clear that the intent is not to label every network administrator a censor.  Keep in mind that there are a great many devices on the network that will process content that have no UI, that have very limited ability to protect themselves.  Explaining how that protection is viewed is a bit broader than the scope of the current document, but would not be out of line for this group to cover, if only for a few lines.

There is also a human element that also needs to be captured in this context that a few of us noted: there are negative connotations with the word, as there should be (IMHO).  I would encourage HR people to appreciate those connotations and not to weaken them by attempting to stretch the definition beyond what you believe is really bad for society, as you will otherwise inure people to the very thing you wish to prevent.

All of this having been said, if you do want to continue on the discussion of the definition:

> On 4 Aug 2020, at 19:19, Joseph Lorenzo Hall <[email-masked]> wrote:
> 
> I’m not sure consent vs. non-consent will address Vittorio or Eliot’s critiques here, I suspect not.
> 

For my part it’s pretty close, my caveat being that the it would not be censorship if the owner of the device receiving the content in particular either did or would have freely and expressly given consent to certain harmful content being blocked.  I’ll readily note that is not a testable condition in advance, although it would be in retrospect.  Look at it this way: if your neighbor sees a robber breaking into your house while you are on vacation, would you like the neighbor to wait for permission to protect your property?  Surely not.

Eliot

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Tue, 4 Aug 2020 20:31:34 +0000

On Aug 4, 2020, at 3:47 PM, Eliot Lear <[email-masked]<mailto:[email-masked]>> wrote:

A quick clarification: When one cites wikipedia, there are specific ways to do that to make sure that the thing you cite to does not change. So, in the draft, we do this:

 [WP-Def-2020]
              Wikipedia contributors, "Censorship", 2020,
              <https://en.wikipedia.org/w/
              index.php?title=Censorship&oldid=943938595>.

Which points to a specific historical instance of the Wikipedia page on censorship (rather than whatever it is now). So, technically, the definition that we are using has not changed. That being said, the current definition differs from what we point to by one word, and I do like the more current version (changes “corporations” to “controlling bodies”) but it’s not a big enough change to me remarkable in my opinion.

On 4 Aug 2020, at 19:19, Joseph Lorenzo Hall <[email-masked]<mailto:[email-masked]>> wrote:

Thanks, Eliot (sorry for double-l-ing you earlier!).

I think I’m starting to see the outlines of a paragraph that capture this… I’ve heard from a few people that are on vacation that can’t opine until next week at the earliest, so I’ll wait to hear more and then take a shot at it.

best, Joe

(work at ISOC, here as my self)

--
Joseph Lorenzo Hall, Senior Vice President, Strong Internet
[email-masked]<mailto:[email-masked]> | +1-703-483-9504
internetsociety.org<http://internetsociety.org> | @internetsociety
pgp: https://josephhall.org/gpg-key
3CA28D7B9F6DDBD34B1016075F86698740A9A871

---

From: Vittorio Bertola <[email-masked]>
Date: Wed, 5 Aug 2020 09:40:41 +0200 (CEST)

> Il 04/08/2020 20:58 Stephane Bortzmeyer <[email-masked]> ha scritto:
> 
> to send and the recipient wants to receive.

> reasons, it is no longer censorship?

If an employer blocks access to Facebook from the office to prevent employees from wasting their paid time, I don't see how that could be considered an attack on human rights.

In any case, I don't think that the purpose of the draft should be to define what censorship is. I was rather suggesting that we document the disagreements so that there can be consensus on the draft and no one feels offended by it. If on the other hand it is not meant to be a consensus document, then there could perhaps be another non-consensus draft documenting the alternative views; this could also be a valid approach.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 6 Aug 2020 21:32:22 +0200

On Wed, Aug 05, 2020 at 09:40:41AM +0200,
 Vittorio Bertola <[email-masked]> wrote 
 a message of 20 lines which said:

> Under this definition - or any other definition based on consent

Note that I did not mention consent but desire. This is because, in
Internet policy speak, "consent" is used for something which is quite
different from a real consent: just clicking "I agree" on a button,
whithout reading the dozens of pages of the terms of use, code of
conduct or whatever. For the end user, it is reasonable to click
without reading since they have no choice, anyway. (Another good
reason for not reading the text is because it was written by
californian lawyers so ordinary humans cannot really understand it.)

This is why GDPR, in its wisdom
<https://eur-lex.europa.eu/eli/reg/2016/679/oj>, says "Consent is
presumed not to be freely given if it does not allow separate consent
to be given to different personal data processing operations despite
it being appropriate in the individual case, or if the performance of
a contract, including the provision of a service, is dependent on the
consent despite such consent not being necessary for such
performance." According to this vision, most of the time, on the
Internet, consent was not freely given.

To summarize: "consent" is now a very dangerous term and it is better
not to use it.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 6 Aug 2020 21:37:22 +0200

On Wed, Aug 05, 2020 at 09:40:41AM +0200,
 Vittorio Bertola <[email-masked]> wrote 
 a message of 20 lines which said:

> So I don't think you can expect everyone to agree on this approach.

Well, this entire I-D is about a political issue (even if the draft
takes care of discussing only techniques) and it is common in politics
that not everyone agrees. As Mallory reminded us, IRTF does not
require consensus.

> If an employer blocks access to Facebook from the office to prevent
> employees from wasting their paid time, I don't see how that could
> be considered an attack on human rights.

You are talking about something different. I said "this is censorship"
and you replied "it is not an attack on human rights". As was
discussed here, censorship is a fact (unless one wants to rewrite
language into NewSpeak). Its legitimacy is an opinion. Taking down
nazi Web sites is censorship. IMHO, it is legitimate. We should not be
afraid of words.

---

From: Juliana Guerra <[email-masked]>
Date: Thu, 13 Aug 2020 12:48:23 -0500

Hello everyone,

Following the discussion, I think that even if the draft is technical it
has a political impact that need to be addressed by a clear use of
language in the description of techniques, including the reference to
censorship. The fact that the word "censorship" as a category can be
understood as politically charged does not prevent its usefulness for
describing the scope of the techniques described in the draft. Providing
a working definition of how some terms will be understood through the
document could be useful to understand the functional reference to the
term censorship, and in there particularly acknowledge how sensitive
these terminology can be perceived and what is the purpose of using it
in the draft.

In that sense, I suggest to include in this description that even if in
many cases some authors understand the term "censorship regime", as
referred to the actions taken by a government without democratic
legitimacy, this is not the intended use provided to the word in this
draft, but rather clearly stating that this is a technical approach to a
political issue that makes reference to a diferential of power between
who makes the decision and is in control of execution of a technique
that has human rights implications. It is also important to clearly
mention that the discussion about human rights implications, or even the
legitimacy of the actions described are totally out of scope of what is
covered by this draft. The reference of consent to account for the
differential of power in this situation does not seem to quite fit to
put this issue in a better direction to be solved, so I suggest to avoid
it in this context (there are other topics where I think it's necessary
to open a discussion on that).

In this way, as Stephane pointed out in his last message the attempt is
not to ignore the meaning of words, but neither providing them a reach
that goes beyond the scope of the technical analysis provided by the
draft that refers, as Mallory pointed out a few messages ago, to the
impacts of the techniques themselves nor the legitimacy or intent of who
executes them.

Regards!

Juliana

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Thu, 13 Aug 2020 17:51:38 +0000

Thank you, Juliana. I'll see if I can draft some good text this weekend along these lines. best, Joe
________________________________
From: Pearg <[email-masked]> on behalf of Juliana Guerra <[email-masked]>
Sent: Thursday, August 13, 2020 13:48
To: [email-masked] <[email-masked]>
Subject: Re: [Pearg] I-D Action: draft-irtf-pearg-censorship-04.txt

Hello everyone,

Regards!

Juliana

--
Pearg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/pearg