Subject: [Pearg] Proposed work on the topic of: IP Address Privacy

From: Sara Dickinson <[email-masked]>
Date: Fri, 14 May 2021 10:42:37 +0100

Hi PEARG, 

This is a belated follow up to the Interim meeting and IETF110 discussion on the topic of "IP Address Privacy".

There appeared to be interest in working on one or more documents to capture the current status and future research directions in this space. A general proposal for such work could include:

* An analysis of the current use cases, attempting to categorise/group such use cases where commonalities exist
* Generating requirements for proposed 'replacement signals' from this analysis (these could be different for each category/group of use cases)
* Research to evaluate existing technologies or propose new mechanisms for such signals

One request was to have a broad scope for the range of use cases considered. We may need a first pass at the initial analysis to see if this is really feasible. 

The chairs would like to hear if
1) The above is a reasonable summary of work that folks think could/should be done in PEARG
2) If people are interested in volunteering to work on some or all of this

Please let us know your thoughts on this topic during the next couple of weeks. Before the end of May, we’ll try to summarise the responses and the plan for moving forward. 

Best regards

Sara, on behalf of the chairs.

---

From: Antoine FRESSANCOURT <[email-masked]>
Date: Mon, 17 May 2021 12:53:55 +0000

Hello,

1/ The work plan proposed seems to me reasonable, and will help contextualize the work that has been presented in recent meetings / interim meetings.

2/ I am eager to help in most items in the work plan. I don't feel comfortable with bootstrapping initial draft versions but I am more than willing to participate and share ideas.

Best regards,

Antoine Fressancourt

-----Original Message-----
From: Pearg [mailto:[email-masked]] On Behalf Of Sara Dickinson
Sent: Friday, May 14, 2021 11:43 AM
To: [email-masked]
Subject: [Pearg] Proposed work on the topic of: IP Address Privacy

Hi PEARG, 

Best regards

Sara, on behalf of the chairs.
-- 
Pearg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/pearg

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 17 May 2021 10:24:25 -0700

> On May 14, 2021, at 2:42 AM, Sara Dickinson <[email-masked]> wrote:
> 
> Hi PEARG, 
> 

This summary does sound reasonable, and the proposed work sounds quite useful.

> 2) If people are interested in volunteering to work on some or all of this

I’m happy to contribute, review, and write text, although I’d prefer to not be a primary author or editor.

Best,
Tommy

---

From: Luigi Iannone <[email-masked]>
Date: Tue, 18 May 2021 12:52:01 +0200

Hi,

> On 14 May 2021, at 11:42, Sara Dickinson <[email-masked]> wrote:
> 
> Hi PEARG, 
> 

Yes. Reasonable summary. 

> 2) If people are interested in volunteering to work on some or all of this

Happy to help, especially on the third item.

Ciao

L.

---

From: Mallory Knodel <[email-masked]>
Date: Wed, 19 May 2021 11:59:14 -0400

Hi,

> 1) The above is a reasonable summary of work that folks think could/should be done in PEARG
I think it's a good start-- it may mean that there is more to research 
once the work is underway.
> 2) If people are interested in volunteering to work on some or all of this

Like others, I couldn't yet commit to leading on any of the items. 
However given more clarity on research questions, I'd be happy to join 
efforts in the first and third categories.

-Mallory

-- 
Mallory Knodel
CTO, Center for Democracy and Technology
gpg fingerprint :: E3EB 63E0 65A3 B240 BCD9 B071 0C32 A271 BD3C C780

---

From: Paul Jensen <[email-masked]>
Date: Fri, 21 May 2021 10:17:50 -0400

1) I might decrease the focus on 'replacement signals' and increase focus
on finding ways to enhance the privacy of existing uses of IP addresses.
2) I'm interested in helping, especially with the first and last work items.

On Fri, May 14, 2021 at 5:43 AM Sara Dickinson <[email-masked]> wrote:

> There appeared to be interest in working on one or more documents to
> capture the current status and future research directions in this space. A
> general proposal for such work could include:
>
> * Generating requirements for proposed 'replacement signals' from this
> analysis (these could be different for each category/group of use cases)
> One request was to have a broad scope for the range of use cases
> considered. We may need a first pass at the initial analysis to see if this
> is really feasible.
>
> Please let us know your thoughts on this topic during the next couple of
> weeks. Before the end of May, we’ll try to summarise the responses and the
> plan for moving forward.
>
>
> Best regards
>

---

From: sara dickinson <[email-masked]>
Date: Mon, 24 May 2021 11:33:05 +0100

Hi All,

Many thanks to all who responded and expressed interest in this work. The chairs will follow up with specific people to get an initial draft together in the near future.

To answer a couple of specific questions/comments:

> 1) Will it focus on "IP Address",  any conderation about BLE/Wi-Fi MAC Address?

I believe the aim is to focus on IP address privacy (which is a large enough topic in itself). If there is interest in working on similar analysis of other such identifiers in parallel I would suggest proposing that work to the list after the first draft on IP address privacy is available (for context).

> 1) I might decrease the focus on 'replacement signals' and increase focus on finding ways to enhance the privacy of existing uses of IP addresses.

Yes - that aspect was missing from the original list and I agree that would be useful research.

Best regards

Sara.

> On 14 May 2021, at 10:42, Sara Dickinson <[email-masked]> wrote:
> 
> Hi PEARG,
>