Subject: RE: LL vs. E2E ARQ [Re: When non TCP/IP literate people design c able modem systems]

From: Nitin Vaidya <[email-masked]>
Date: Fri, 25 Jun 1999 09:55:53 -0700

> -----Original Message-----
      > From: Lloyd Wood [mailto:[email-masked]]
      ...
      > ...  anyone got an example of a good
      > link designed from scratch for data with LL ARQ because it really
was
      > seen as the best choice? TIA.

IEEE 802.11 Wireless MAC allows for local retransmits.
I do not know what thought process went into the design of this MAC, 
but I presume the designers considered local retransmission as a good 
choice, if not the best.

- nitin

---

From: wolisz <[email-masked]>
Date: Fri, 25 Jun 1999 15:58:08 -0700

> but I presume the designers considered local retransmission as a good

Nitin,

in fact it has been seen as the best alternative.
Unfortunately enough, the performance of TCP on top of that,
although improved in comparison with the case without local retransmission
is still not quite satisfactory.
You might find results of the measurements in both cases
       (note: based on   pre-IEEE802.11 proprietary solutions,
           which have, however , strong similarities to those selected
          later by IEEE802.11!)

made for TCP, SNOOP and ReSOA
in
         M. Schläger, B.Rathke, S. Bodenstein, A. Wolisz;
        "Advocating a Remote Socket Architecture for Internet Access using
Wireless LANs"
         accepted for publication in Mobile Networks and Applications,
Balzer Science Publishers
         Special Issue on Wireless Internet and  Intranet Access, to appear
in 1999
available from
        http://www-tkn.ee.tu-berlin.de/publications/journals.html

In this paper we demonstrate, that ReSoA , a proxy architecture, designed so
as to
support the classical TCP socket semantic seems to be the best solution for
WLANs.

Adam Wolisz
(Technical University of Berlin)

---

From: "Perry E. Metzger" <[email-masked]>
Date: 27 Jun 1999 16:35:21 -0400

> but I presume the designers considered local retransmission as a good 

Whether the designers had any clue about what this might do to TCP/IP
performance is another story.

.pm