Subject: source code query

From: "Mike Cronin" <[email-masked]>
Date: Thu, 24 Aug 2000 16:34:53 +0100

Hello all,

I am a student on work experience and have been given a job relating to multicast 
routing. I have been searching extensively for free source code or pre-compiled 
executable software for multicast routing protocols, especially PIM - Protocol 
Independant Multicast, but any of the others such as DVMRP or MOSPF would be 
sufficient. I have also been looking for IGMP (Internet Group Management Protocol) 
source code to implement and administer a multicast group. I hope to integrate this 
project on Linux or FreeBSD servers. Since I have had no luck checking the various multicast sites I was hoping you might be able to help me on this one. Thank you for your time.
    
            Yours sincerely,
                    Michael Cronin,
                    Broadcom Eireann Research Ltd.,
                    Kestrel House,
                    Clanwilliam Place,
                    Dublin 2,
                    IRELAND.
                    +353 1 604 6065.

---

From: Matthew Davy <[email-masked]>
Date: Fri, 25 Aug 2000 10:50:41 -0500

There are links to a couple of PIM implementations on:

http://netweb.usc.edu/pim/

- Matt

-----------------------------------------------------------------------------
Matthew Davy		      [email-masked]			 812-855-7728
University Information Technology Services                 Network Operations
-----------------------------------------------------------------------------

---

From: "Wilbert de Graaf" <[email-masked]>
Date: Wed, 27 Sep 2000 21:44:08 -0700

Michael,

I have an implementation of IGMPv3 on FreeBSD (patches for 4.0 and 4.1) available on my website:

http://home.hetnet.nl/~wilbertdg/igmpv3.html

- Wilbert

----- Original Message ----- 
From: Mike Cronin 
To: [email-masked] 
Sent: Thursday, August 24, 2000 8:34 AM
Subject: source code query

Hello all,

            Yours sincerely,
                    Michael Cronin,