Subject: RE: Assert messages in PIM-SM

From: Billy Ng <[email-masked]>
Date: Thu, 30 Nov 2000 09:54:51 -0500

Hi Vinodkumar,

first of all, this question belongs to the pim mailing list,
so I am forwarding to it also.

Basically your question on the role of the DR is valid if
you don't have any downstream router.  If there is a downstream
router, that router can send a join/prune toward its RPF neighbor
which could be different from that of the DR, so assert could happen
when data comes down both the RPF router and the DR router.

--Billy

> -----Original Message-----
> From: Vinodkumar Parasmal [mailto:[email-masked]]
> Sent: Thursday, November 30, 2000 5:33 AM
> To: IDMR
> Subject: Assert messages in PIM-SM
> 
> 
> Hi all,
> I have a doubt regarding PIM-SM Assert and DR Mechanisms in  
> multi-access
> LANs.I could not justify why we need Assert when we have a DR Election
> mechanism and a DR Elected thro' that mechanism.According to my
> understanding the DR will be responsible for sending all PIM 
> control packets
> and forwarding Multicast Data .
> Could somebody point out the different scenarios which 
> explain the need for
> both the mechanisms .
> 
> Thanks in Advance
> Vinod
> 
> 
> 
>

---

From: helmy <[email-masked]>
Date: Thu, 30 Nov 2000 09:37:25 -0800 (PST)

You also need Asserts to resolve a situation where 2 upstream routers on
the same LAN (one leading to the RP and another leading to the
source) when switching from the shared *,G tree to the SPT S,G tree

Regards,
-Ahmed