Subject: Join/Prune Messages

From: [email-masked]
Date: Wed, 25 Apr 2001 14:25:59 +0200

Hello,

Join/Prune message are sent to all pim neighbor routers with TTL of 1 (multicast
address 224.0.0.13). But only one router (the upstream neighbor router) will
process the message.
I'm just wondering if, for an adaptation of PIM-SM, for simulations in NS, we
can only send pim Join/Prune message in unicast to the upstream neighbor.

Do we loose informations in doing that.

Thank You

MAMAN Gregory

ALCATEL SPACE INDUSTRIES
Dép TS/AT/E
Tel : 33 (0)5 34 35 37 52  /  Fax : 33 (0)5 34 35 61 69
Porte : 2070  /  E-Mail : [email-masked]

---

From: Christopher Thomas Brown <[email-masked]>
Date: Wed, 25 Apr 2001 13:37:00 -0400

You do lose information if you unicast.

The other neighbors on a multicast access network need to process the
JP message in order to determine if they need to override a prune
contained in the message.

ctbrown

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 25 Apr 2001 12:15:43 -0700

>> contained in the message.

    And if you wanted to do the Join Supression optimization, you'd lose that
    too.

Dino