Subject: Questions on the new BSR draft

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Wed, 18 Apr 2001 16:20:11 -0500

I was reading the BSR draft and couldn't find any explanation on how multicast communication across different "admin scoped zones" is achieved. It talks about C-RP and C-BSR configurations within an SZ and how to send C-RP adv. and BSM within an admin scoped zone. But, how does multicast work inter-SZ? I presume there must be some communication between the zone border routers or the BSRs in each scoped zone - but, I'm not clear on this.

I might be missing something really fundamental here. So, please pardon my ignorance. Any pointers would be of help.

Thanks,
Vidya

---

From: Mark Handley <[email-masked]>
Date: Wed, 18 Apr 2001 15:50:09 -0700

>I was reading the BSR draft and couldn't find any explanation on how multicast
> communication across different "admin scoped zones" is achieved. It talks abo
>ut C-RP and C-BSR configurations within an SZ and how to send C-RP adv. and BS
>M within an admin scoped zone. But, how does multicast work inter-SZ? I presum
>e there must be some communication between the zone border routers or the BSRs
> in each scoped zone - but, I'm not clear on this.
>

If you're using a scoped group, then there is *by definition* no
communication between the different scope zones that that group falls
into.  The point of admin scoping is to prevent unwanted
communication.

If you're using a global group, then you use a global BSR, and hash to
a global RP (where "global" here means "within the PIM domain").

BTW, we decided at the IETF to not do admin scoped BSR the way the
current BSR draft specifies it (at least as far as the roles of ZBRs
and the dynamic config of BSRs).  There'll be a new draft out before
too long.  If anyone needs it, I can send you a current snapshot if
you let me know.

Cheers,
	Mark