Subject: Re: KAT restart ??

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Mon, 16 Apr 2001 17:04:02 +0500

> Hi,
>    From the draft,  the definition of KeepAliveTimer is
> "Period after last (S,G) data packet during which (S,G) Join state 
> willbe maintained even in the absence of (S,G) join message"

    As per my understanding , "No", we shouldn't restart. it is the time
after last (S,G) data packet, so should only be updated by the receipt
of (S,G) data packet. I guess receipt of (S,G) join will only restart 
the Expiry timer. 

Am I correct ???

-----
Jyotheesh 

> So, should I restart the KAT on receiving a per- interface downstream
> (S,G) join message ? This is not mentioned in the per- interface(S,G)
> downstream J/P state-machine in the draft.
> 
> Thanks for your time.
> 
> --
> regards
> radha
> 
> 
>

---

From: Reji Varghese <[email-masked]>
Date: Mon, 16 Apr 2001 17:29:17 +0530

Hi,

KeepAliveTimer is to keep a link/connection up/active based on the arrival
of an Update/Data packet. Thus, the restart should happen only on receipt
of
an Update/Data packet and not on the receipt of a Join message.
That's how I understand it.

Regards
Reji