Subject: RE: [pim] Sending a prune on RPF change

From: "Nicholas, Jonathan" <[email-masked]>
Date: Thu, 15 Nov 2001 09:15:09 -0500

I suspect you are referring to PIM-SM, but let me reassure you that the
PIM-DM draft (to be out shortly) does NOT send a Prune to an old upstream
router for reasons similar to those cited.

Jonathan Nicholas

> -----Original Message-----
> From: John Zwiebel [mailto:[email-masked]]
> Sent: Wednesday, November 14, 2001 6:44 PM
> To: [email-masked]
> Subject: [pim] Sending a prune on RPF change
> 
> 
> 
> With IETF coming, and since I will be unable to attend,
> I want to check that "someone" will be addressing my 
> concerns WRT sending prunes to the old RPF neighbor when
> there is a routing change.  
> 
> To summarize, I found that doing so just generates a lot
> of extra PIM control traffic on a subnet that has multiple
> downstream routers that lead to receivers because the
> change in the URIB is not realized all at the same time.
> 
> A router that is "late" in recognizing the RPF change will
> send a join-override, which keeps the old RPF neighbor forwarding.
> Even if there is only one downstream, router, the prune 
> to the old RPF neighbor can not be processed immediately --
> meaning there will be an assert on the LAN to determine the
> winner in any case.
> 
> Bottom line: sending a prune to an old RPF neighbor does not
> help and therefore should not be specified.
> 
> 
> Thanks
> z
> 

************************************ 
If this email is not intended for you, or you are not responsible for the
delivery of this message to the addressee, please note that this message may
contain ITT Privileged/Proprietary Information.  In such a case, you may not
copy or deliver this message to anyone.  You should destroy this message and
kindly notify the sender by reply email.  Information contained in this
message that does not relate to the business of ITT is neither endorsed by
nor attributable to ITT. 
************************************

---

From: John Zwiebel <[email-masked]>
Date: Thu, 15 Nov 2001 09:06:32 -0800

> router for reasons similar to those cited.

One would think that in this situation, dense and sparse should
operate in the same manner.

> _______________________________________________
> Pim-external mailing list
> [email-masked]
> http://mailist.procket.com/mailman/listinfo/pim-external