Subject: [pim] I-D ACTION:draft-ietf-pim-sm-v2-new-04.txt,.ps

From: [email-masked]
Date: Fri, 30 Nov 2001 06:02:32 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Protocol Independent Multicast Working Group of the IETF.

	Title		: Protocol Independent Multicast - Sparse Mode PIM-SM): 
                          Protocol Specification (Revised)
	Author(s)	: B. Fenner, M. Handley, H. Holbrook, I. Kouvelas
	Filename	: draft-ietf-pim-sm-v2-new-04.txt,.ps
	Pages		: 135
	Date		: 29-Nov-01
	
This document specifies Protocol Independent Multicast -
Sparse Mode (PIM-SM).  PIM-SM is a multicast routing protocol
that can use the underlying unicast routing information base
or a separate multicast-capable routing information base.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pim-sm-v2-new-04.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-pim-sm-v2-new-04.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-pim-sm-v2-new-04.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Sundeep Singatwaria" <[email-masked]>
Date: Fri, 30 Nov 2001 14:25:59 -0800

Could the authors explain why we have a prune pending timer of 5 seconds in
the new draft. 2236 has it as 70s

Consider following scenarios.

Case 1:

sender
r1           r2 (RP)
|               |
-------------- multiaccess LAN
|               |
r3            r4
receiver

r3 upstream for RP is r2 and r3 upstream towards source is r1. When r3
switches to SPT it will
prune the RP tree and will receive data from r1. so the only check done is
upstream router address is different - no same iif check - else we will
forever get the data from the RP tree

Source ->r1 -> r2(RP) ->r3->receiver

r1, r2 and r3 are on the same subnet. R3 upstream for source is r1 and r2 is
configured as the RP. r3 will send a prune towards RP and join towards
source. (S,G) joins towards source and (*,G) join + (S,G,RPT) prune at the
RP can go at different times. So R2 with every S,G,RPT prune will prune off
the S,G tree also.
This will stop the traffic till the next S,G join repairs the state. So the
receiver will never receive data continously.

With 70s PPT r2 will cancel the PPT when it receives a join every 60s. so
traffic will never stop. However with 5s PPT traffic will stop
intermittently.

Sundeep

---

From: John Zwiebel <[email-masked]>
Date: Fri, 30 Nov 2001 15:28:35 -0800

> the new draft. 2236 has it as 70s

2236 is IGMPv2.  

-- The RP only has to prune once.
-- (S,G,R) prunes are only valid on "inherited" olists
-- The (S,G) join received by r1 makes it an "immediate" olist.

FWIW, at cisco when this problem first came up we ignored
(S,G,R) prunes for (S,G) entries.  Data may flow for an extra
3 minutes, but that's no big deal.

> _______________________________________________
> Pim-external mailing list
> [email-masked]
> http://mailist.procket.com/mailman/listinfo/pim-external