Subject: Re: [pim] [pimsm] question on overriding prunes.

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Tue, 13 Nov 2001 09:17:17 +0500

> When we see a Prune(*,G) to RPF'(S,G) for an (S,G) in joined state
> we lower the upstream join timer to override it with a Join(S,G).
> This is in spec to interoperate with RPF 2362.
> 
> My question is, do we still need to do this even when we have a (*,G)
> in joined state? We will override a Join(*,G) in this case 

 Why will you override with a join(*,G) ? It's a (*,G) prune on the up-
strm interface to RPF'(S,G) ( i.e not to RPF'(*,G)), I am not very sure 
which part of the spec says to override a prune(*,G) message to 
RPF'(S,G) . Just let me know, if I am wrong here ..

Thanks,
Jyotheesh

> and
> overriding
> with Join(S,G)s as well seems redundant (unless of course we have to
> assume
> that our override for Prune(*,G) could be too late and the upstream
> router
> might have already flushed out all (*,G) and (S,G) states on the
> interface).
> 
> Thanks,
> Ardas
> 
>

---

From: Ardas Cilingiroglu <[email-masked]>
Date: Mon, 12 Nov 2001 23:50:59 -0500

Jyotheeswara Rao Kurma wrote:

> strm interface to RPF'(S,G) ( i.e not to RPF'(*,G)),

I meant the case where RPF'(S,G) is the same as RPF'(*,G).

> I am not very sure

Figure 8: Upstream (S,G) state machine

>   ------------------------------------------------------------------------
>                                Name: InterScan_Disclaimer.txt
>    InterScan_Disclaimer.txt    Type: Plain Text (text/plain)
>                            Encoding: 7bit