Subject: Re: [pim] [pimsm] Sending PruneEcho(S,G,rpt) when PPT expires for (S,G,rpt)

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Tue, 13 Nov 2001 09:41:55 +0500

> Hi,
> 
> Expiry of the PrunePendingTimer for (*,*,RP),(*,G) and (S,G) entries
> result in sending a PruneEcho message to increase reliability.
> 
> Why do we not have the same for (S,G,rpt) entries?

  If we want to do that(increase reliablity ) , We have to consider the 
other side effect. every (*,G) join, will contain (S,G,Rpt) prune, and 
this (*,G) join is periodic. So if at all if any router wants (S,G) 
traffic, let it over-write within the over-ride interval. otherwise 
prune this interface from (S,G) oif-list.  

 Keep in mind that (S,G.Rpt) prunes are PERIODIC , i.e not same as 
(*,G), (S,G) or (*,*,RP) prunes...

Thanks,
Jyotheesh 

> Thanks,
> Ardas

---

From: Ardas Cilingiroglu <[email-masked]>
Date: Mon, 12 Nov 2001 23:59:12 -0500

> (*,G), (S,G) or (*,*,RP) prunes...

PPT is started only when (S,G,rpt) is in NoInfo state on that interface
(Fig. 5), i.e. when the first (S,G,rpt) prune is received. Therefore,
PruneEcho will NOT be sent after every (S,G,rpt) prune received.

Thanks,
Ardas

>
>
> Thanks,
> Jyotheesh
>
>
> > Thanks,
> > Ardas
> >
> >
>
>   ------------------------------------------------------------------------
>                                Name: InterScan_Disclaimer.txt
>    InterScan_Disclaimer.txt    Type: Plain Text (text/plain)
>                            Encoding: 7bit