Subject: [pim] about PMBR

From: Jiahao Wang <[email-masked]>
Date: Fri, 26 Apr 2002 11:34:17 +0800 (CST)

Hi, Liming Wei
   
    Thank your advice very much!
    I think I had better implement the domain wide
report in PIM-SM. There are some reasons. PIM-SM can
support inter-domain multicast better than DVMRP, such
as MSDP/MBGP, and Cisco has implemented it. The source
codes of MrouteD and PimD are written by USC, they are
very similar, therefore, it is easy to touch PIMD
after touching MroutD.
    According to RFC 2715 and
draft-ietf-pim-sm-v2-new-05.txt, PMBR should have
several multicast components, I am concerned that
DVMRP and PIM-SM component on PMBR. There is only one
component running on one interface at PMBR, isn't it?
I am not sure that PMBR should run PIM-SM at PIM cloud
interfaces and run DVMRP at DVMRP cloud interfaces.
Could you help me interpret it?
    Thanks!

Best regards
Jiahaow

_________________________________________________________
Do You Yahoo!? 
到世界杯主题公园玩一玩，赢取世界杯门票乐一乐。
http://cn.fifaworldcup.yahoo.com/
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Pavlin Radoslavov <[email-masked]>
Date: Thu, 25 Apr 2002 22:06:45 -0700

> codes of MrouteD and PimD are written by USC, they are

An (out-of-topic) clarification. Mrouted was not written in USC;
rather, various pieces of code from mrouted have been reused in
pimd (in particular, most of the things that are DVMRP and PIM-SM
independent such as IGMP and UNIX kernel interaction).

FreeBSD's mrouted manual page says that the authors of mrouted are
Steve Deering, Ajit Thyagarajan, Bill Fenner (I guess in order of
appearance :)

Pavlin