Subject: [pim] pim-sm questions

From: "James Huang" <[email-masked]>
Date: Tue, 9 Apr 2002 15:28:57 -0700

Hi all,

I have two questions related to pim-sm:

(1) When CouldAssert(S,G,I) becomes FALSE and the per-interface (S,G) assert state-machine moves from IAmWinner to NoInfo, a AssertCancel(S,G) message will be sent. According to the spec, it will send a (S,G) assert with RPT bit set to 1 and metric set to infinite.  What is the reason for setting RPT to 1 when a (S,G) assert is sent?

(2) According to sec 4.5.9 of the latest spec, triggered Prune(S,G,rpt) will be send to RPF'(S,G,rpt).  What if RPF'(S,G,rpt) is the same as RPF'(S,G) as in the following case?  Should triggered Prune(S,G,rpt) be sent to RPF'(*,G) instead?

			S --------------> RP
			|			|
			|			|
			R1			R2
			|			|
			|			|
		-----------------------------------
			|			|
			|			|
			R3			R4
			^			^
			|			|
			|			|
		igmp(S,G) join	   igmp(*,G) join

In this case, R1 will send a (S,G) assert when R2 forward the (S,G) traffic to the lan.
WHen R4 sees the assert, it will set SPTbit to 1 and PruneDesired(S,G) become TRUE.
R4 will send a Prune(S,G,rpt) upstream.  Should R4 send it to R2 or R1??

Regards,
James C. Huang

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: "James Huang" <[email-masked]>
Date: Tue, 9 Apr 2002 16:06:33 -0700

Hi all,

I have figured out the answer for my question (2).  When R4 receives the Assert(S,G) from R1, it will move the per-intf (S,G) assert state-machine from the NoINfo state to the AssertLoser state and set SPT bit to 1.  Setting SPTbit to 1 will in turn cause AssertTrackingDesired(S,G,I) to become FALSE, and the state-machine will again move from the AssertLoser state to the NoInfo state.  So When R4 sends a prune(S,G,rpt) to RPF'(S,G,rpt), it will be send RPF'(*,G).

I am still confused by question (1). Can someone find the answer for me?

Regards,
James Huang 

-----Original Message-----
From: James Huang 
Sent: Tuesday, April 09, 2002 3:29 PM
To: [email-masked]
Subject: [pim] pim-sm questions

Hi all,

			S --------------> RP
			|			|
			|			|
			R1			R2
			|			|
			|			|

Regards,
James C. Huang