Subject: [pim] RE: PIM MIB question

From: "Nicholas, Jonathan" <[email-masked]>
Date: Mon, 8 Jul 2002 06:26:11 -0500

This is as specified in RFC 2934, with which this draft is intended to be
backwards compatible.  

I don't know why it was written this way in RFC 2934.

Jonathan Nicholas

> -----Original Message-----
> From: Roger Lin [mailto:[email-masked]]
> Sent: Wednesday, July 03, 2002 7:24 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: PIM MIB question
> 
> 
> Jonathan,
> 
>   On page 15 of draft-ietf-pim-v2-00.txt file,
> pimIpMRouteNextHopPruneReason
> is assigned the value of {pimIpMRouteNextHopEntry 2}.
> 
>   Shouldn't it be assigned the value of 1, instead of 2, 
> since it is the
> first field in the table?
> 
>   Your help in this matter will be greately appreciated.
> 
> Roger Lin
> IPInfusion, Inc.
> San Jose, CA
> 
> 

************************************ 
If this email is not intended for you, or you are not responsible for the
delivery of this message to the addressee, please note that this message may
contain ITT Privileged/Proprietary Information.  In such a case, you may not
copy or deliver this message to anyone.  You should destroy this message and
kindly notify the sender by reply email.  Information contained in this
message that does not relate to the business of ITT is neither endorsed by
nor attributable to ITT. 
************************************ 

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: "Nicholas, Jonathan" <[email-masked]>
Date: Wed, 17 Jul 2002 07:10:19 -0500

All the entries in the pimIpMRouteNextHopTable will be for downstream
interfaces.

The index ipMRouteNextHopAddress corresponds to the ipMRouteNextHopTable
index.  From RFC 2932 "The address of the next-hop specific to this entry.
For most interfaces, this is identical to ipMRouteNextHopGroup.  NBMA
interfaces, however, may have multiple next-hop addresses out a single
outgoing interface."

PIM does not currently make special considerations for NBMA interfaces.
This may be something for the WG to take up.

Jon

> Sent: Tuesday, July 16, 2002 8:23 PM
> To: [email-masked]
>   I have a couple questions about pimIpMRouteNextHopTable:
> 
> 1. Are the entries in this table refer to downstream or 
> upstream, or all
> PIM
> enabled interfaces?
> 
> 2. If they are supposed to be downstream entries, then the 
> INDEX element
> 
> ipMRouteNextHopAddress does not make sense since nexthop router
> address is only meaningful on the upstream interface of a PIM state.
> 
> 3. If they refer to upstream interfaces, then the oid
> does not make sense since a prune clearly happens only on a downstream
> interface.
> 
> I am confused by this table, can you help me here?
> 
> 
> Best Regards,
> 
> Roger Lin
> 408-7941530
> IPInfusion Inc.
> 
> 
>

---

From: "Bakar" <[email-masked]>
Date: 17 Jul 2002 13:41:01 -0000

Hi Jon,

   I thought the ipMrouteNextHopAddress to be nothing but the 
Group Address of the mroute entry. Are you telling the samething 
?

regards,
Bakar

---

From: "Nicholas, Jonathan" <[email-masked]>
Date: Wed, 17 Jul 2002 09:03:45 -0500

Most of the time they are the same.  On NBMA nets, they could be different.

Jon

> From: Bakar [mailto:[email-masked]]
> Sent: Wednesday, July 17, 2002 9:41 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [pim] RE: PIM MIB question
> 
> 
> Hi Jon,
>