Subject: [pim] Topology confusion

From: "Sachidananda" <[email-masked]>
Date: Tue, 9 Jul 2002 19:50:13 +0530

Hi All,

I have some confusion regarding the topological restriction imposed by the multicast routing protocol in the domain. Does the domain concept in PIM mean that all the routers in the domain be necessarily be of same version? Or is it possible to have both PIM v1 and PIM v2 routers coexisting in the same domain?
In case if the 2 can co-exist, then is there any draft / write-up illustrating the inter-operability between different versions of PIM?    

Thanking in advance for clarifying my doubts.
Sachi & Bhargav.

---

From: John Zwiebel <[email-masked]>
Date: Tue, 09 Jul 2002 11:24:41 -0700

On 7/9/02 7:20 AM, "Sachidananda" <[email-masked]> wrote:

> Hi All,
>  
> I have some confusion regarding the topological restriction imposed by the
> multicast routing protocol in the domain. Does the domain concept in PIM mean
> that all the routers in the domain be necessarily be of same version? Or is it
> possible to have both PIM v1 and PIM v2 routers coexisting in the same domain?
> In case if the 2 can co-exist, then is there any draft / write-up illustrating
> the inter-operability between different versions of PIM?
>  

A PIM domain is that area serviced by a common RP and generally under
Control of a single administrator.   The ³single administrator² is the
Key (IMHO) since there isn¹t anything that prevents PIM (from a
Protocol perspective) from having an RP that services the entire
World.   So the idea of a domain isn¹t inherent in the protocol itself
But is a way of setting up borders and boundaries so that your
Configuration doesn¹t interfere with someone elses.

PIMv1 hasn¹t been around for a long time.  Bill was right that there
Are problems getting the two to interoperate.  I may be mistaken, but
It is my belief that only Cisco implemented much PIMv1 and they¹ve
Moved on to PIMv2 and are in the process (like everyone else) of
Moving to the new PIMv2 spec.

If you have a choice, don¹t deploy PIMv1, and if you discover that
Some vendor is still sending out PIMv1 messages by default, you might
Want to encourage them to make that configurable.

It is possible to have PIMv1 and PIMv2 in the same network ‹ if your
Network is all cisco¹s ;-)

IMHO, you are asking for trouble if you try to maintain a combined network
Especially with the new spec being deployed.

2 cents