Subject: [pim] Doubt regarding assert on IIF

From: "[email-masked]" <[email-masked]>
Date: Wed, 31 Jul 2002 00:12:44 -0400 (EDT)

Hi, 
What are the initial values for the assert metric and metric preference on the iif of
a route entry?
My doubt is assert message that is received on the iif should always be a preferred assert
which means that the massert metric and metric pref should be better than that of the 
current assert winner.
When the router loses assert, according to action  A6 in the state machine the router stores the assert
metric. So it logically means (as i interpret) as follows
"The assert winnner for a route entry on the incoming interface is always the upstream router that
has better metric towards the source from that router. This should be the RPF neighbor or
the router that won the assert on the outgoing interface"
But the down stream router initially does not know what are the metrics in its RPf neighbor 
towards the source. So with what values should the downstream router compare the assert 
metrics and metric preferences received on the incoming interfafce.
thanks in advance
rajesh.

------------------------------------------------
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

---

From: Rishabh Parekh <[email-masked]>
Date: Wed, 31 Jul 2002 09:51:05 -0700

Raj,
In the "No Info" Assert state we always compare the received Assert
metric with my_assert_metric(S,G,I).
Actually, if you read the detailed description of the "Receive preferred
Assert" event in "No Info" state in both the (S,G) and (*,G) Assert
state machines, you will notice that the received metric is compared
with "our own" metric. In this regard, the definiton of "preferred
assert" is slightly mis-leading as there is no Assert Winner in "No
Info" state!
When the Assert message arrives on the iif, my_assert_metric(S,G,I)
should always be worse than the upstream router's Assert metric and
therefore the downstream router will always lose the Assert.

Regards,
Rishabh Parekh.

"[email-masked]" wrote:

   Hi,

   What are the initial values for the assert metric and metric
   preference on the iif of

   a route entry?

   My doubt is assert message that is received on the iif should
   always be a preferred assert

   which means that the massert metric and metric pref should be
   better than that of the

   current assert winner.

   When the router loses assert, according to action A6 in the state
   machine the router stores the assert

   "The assert winnner for a route entry on the incoming interface is
   always the upstream router that

   has better metric towards the source from that router. This should
   be the RPF neighbor or

   But the down stream router initially does not know what are the
   metrics in its RPf neighbor

   towards the source. So with what values should the downstream
   router compare the assert

   thanks in advance

   rajesh.

>
> -----------------------------------------------------------------------

--
----------------------
Rishabh Parekh
Software Engineer
IP Infusion inc.
[email-masked]
Office: 408-794-1546
----------------------