Subject: [pim] How to configure PIMD in auto-rp mode with Cisco Router like RP

From: Eric Dubé <[email-masked]>
Date: Wed, 10 Jul 2002 12:12:50 -0400

Hi,

    I'm working on ETS (École de Technologie Supérieure) University 
Laboratory in Canada on a multicast project and I want to test our 
application with pimd on linux redhat 7.1.

    I would like to know how to configure PIMD in auto-RP mode.  My RP 
are a Cisco Router (Catalyst 5500) and I tried to compile the source 
code with the option BROKEN_CISCO_CHECKSUM but the problem still there. 
  Everything work fine if my router Linux Redhat 7.1 is configure in RP. 
 I test multicast with the IP/TV Server and Viewer of Cisco on two 
workstation Windows NT 4.0 for now because I know that IP/TV work fine. 
 When I will succesfully configure my Linux router, I will test our 
application (writing in C).

    Can you help me.

    Thank you   
    Eric Dubé
    [email-masked]
    http://www.ele.etsmtl.ca/lagrit/

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Hitoshi Asaeda <[email-masked]>
Date: Wed, 10 Jul 2002 18:53:54 +0200 (MEST)

>     I would like to know how to configure PIMD in auto-RP mode.  My RP 

Auto-RP is cisco original, afaik.
In any case, it's not defined in rfc2362, so it's not supported by
pimd.

> code with the option BROKEN_CISCO_CHECKSUM but the problem still there. 

Unfortunately, setting that option doesn't affect anything for
auto-RP.

>   Everything work fine if my router Linux Redhat 7.1 is configure in RP. 

So for your case, in order to make pimd cooperate with cisco, you may
want to try to setup your cisco routers with "ip pim rp-cand ...".
--
Hitoshi Asaeda
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 10 Jul 2002 12:54:12 -0400

Hi

The PIM wg list is not generally the best place to go with PIM 
configuration questions.

I would

1.) Look at the material at
http://darkwing.uoregon.edu/~llynch/mcastwks/
from the recent Internet2 multicast workshop.

2.) Join the mcohort mail list (from the above page).

3.) If you still have questions, ask on the mcohort list.

Regards
Marshall Eubanks

Eric Dubé wrote:

>    Thank you      Eric Dubé

-- 
                                  Regards
                                  Marshall Eubanks

This e-mail may contain confidential and proprietary information of
Multicast Technologies, Inc, subject to Non-Disclosure Agreements

T.M. Eubanks
Multicast Technologies, Inc
10301 Democracy Lane, Suite 410
Fairfax, Virginia 22030
Phone : 703-293-9624       Fax     : 703-293-9609
e-mail : [email-masked]
http://www.multicasttech.com

Test your network for multicast :
http://www.multicasttech.com/mt/
  Status of Multicast on the Web  :
  http://www.multicasttech.com/status/index.html