Subject: [pim] Query on the pseudocode in section 4.4.2

From: "Bandi, Sarveshwar" <[email-masked]>
Date: Wed, 11 Dec 2002 12:26:46 -0500

Hi All,

I would like to use an modified version of the pseudocode in section 4.4.2
(receiving register messages at RP) as follows
packet_arrives_on_rp_tunnel( pkt ) {
	if( outer.dst is not one of my addresses ) {
		drop the packet silently.
		# note that this should not happen if the lower layer is
working
	}
	if( I_am_RP( G ) && outer.dst == RP(G) ) {
	/* 
--> 	Moving this action down.
--> 		restart KeepaliveTimer(S,G)
	*/

	if(( inherited_olist(S,G) == NULL ) OR SPTbit(S,G)) {
		send RegisterStop(S,G) to outer.src
	} else {
-->   /* Moved restarting the timer over here */
		restart KeepaliveTimer(S,G)
		if( ! pkt.NullRegisterBit ) {
		decapsulate and pass the inner packet to the normal
		forwarding path for forwarding on the (*,G) tree.
		}
	}
	} else {
		send RegisterStop(S,G) to outer.src
		# Note (*)
	}
}

Basically what i would like to do is restart the keepalivetimer only if
there are interested listeners for this group G at the RP. I guess the
behaviour would be that, the SPT from RP to S would be created only when
someone joins the RPT. Once the SPT is created the SPTbit would be set and
the KeepAlivetimer would be restarted by the forwarding pseudocode. This
also would imply that SPT would not be formed unless someone joined the RPT.

I was just wondering if such an modification is ok. Would this affect the
functioning of the protocol in any other way? Also is the delay in forming
SPT after receivers join the RPT acceptable? Would this lead to any black
holes?

Would appreciate comments on this.

Thanks and regards,
Sarvesh

Sarveshwar Bandi

Senior Member, Technical Staff
Netplane Network Technologies (India) Pvt. Ltd.
http://www.netplane.com
Ph: +91-40-355 3709/10/11/12 Extn: 1126
Fax: +91-40-355 3713

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Pavlin Radoslavov <[email-masked]>
Date: Wed, 11 Dec 2002 23:57:32 -0800

You may want to check
http://netweb.usc.edu/pipermail/pim/2002-October/000259.html

(note that the archive for that thread was split between September
and October)

The original purpose of that pseudo code was different (i.e., not to
do SPT switch on the first packet received at the RP), but in
addition to that it does also what you want.

Regards,
Pavlin