Subject: Re: [pim] A query about assertTrackingDesired and CouldAssert macros

From: "Prashant Jhingran" <[email-masked]>
Date: 1 Dec 2002 18:40:54 -0000

hi Sarvesh,
           Well in a nutshell yes it means the same.
           If you look closely at the two macros, a part of it 
(Interface I present in the downstream interface) is the same.
But in case of CouldAssert macro, RPF check towards the S or RP is 
a MUST condition whereas its an optional condition in the other 
macro.
These checks finally boil down to the fact that 
AssertTrackingDesired can only be true for upstream interface 
while the other on downstream interface.

regards,
Prashant

On Fri, 29 Nov 2002 Bandi, Sarveshwar wrote :
>Hi,
>     Is it right to say that macros AssertTrackingDesired(*,G) 
>and
>AssertTrackingDesired(S,G) macros return TRUE only for
>RPF_Interface(RP) and RPF_interface(S) respectively?
>
>   Similarly is it right to say that macros CouldAssert(*,G) 
>and
>CouldAssert(S,G) return TRUE only for downstream interfaces?
>
>
>Thanks and regards,
>Sarvesh
>
>Sarveshwar Bandi
>
>Senior Member, Technical Staff
>Netplane Network Technologies (India) Pvt. Ltd.
>http://www.netplane.com
>Ph: +91-40-355 3709/10/11/12 Extn: 1126
>Fax: +91-40-355 3713
>
>_______________________________________________
>pim mailing list
>[email-masked]
>http://catarina.usc.edu/mailman/listinfo/pim

________________________________________________________________
  NIIT supports World Computer Literacy Day on 2nd December.
  Enroll for NIIT SWIFT Jyoti till 2nd December for only Rs. 749
  and get free Indian Languages Office software worth Rs. 2500.
  For details contact your nearest NIIT centre, SWIFT Point
  or click here http://swift.rediff.com/

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: "Prashant Jhingran" <[email-masked]>
Date: 1 Dec 2002 18:40:33 -0000

hi Sarvesh,

regards,
Prashant