Subject: RE: [pim] IGMPv3 - PIM-Dm and SSM Issue?

From: "Manish Kumar" <[email-masked]>
Date: Tue, 22 Jul 2003 13:02:25 -0700

Thanks Jags and Maneesh,
 
The reason I asked about receiver generating igmp v3 (S,G) join is because of the fact that source is lying on the PIM-SSM domain. I was just trying to find out whether there is any mechanism by which S,G join is propagated to the border router.
 
If the other domain is PIM-SM, then it is possible to receive data as border router will send (*,*,Rp) join and pull the data from the source and then flood it into the Dm domain.
 
Does this mean that PIM-SSM and PIM-DM will never work together?
To me it looks like, it may be a valid case in deployment. As Maneesh said by configuring IGMP static join at R2 will make it work. But it needs user intervention.
 
Maneesh, in other scenarios, as u said,  it would work.
 
Thanks,
Manish

-----Original Message-----
From: Rajamanickam jaganbabu [mailto:[email-masked]]
Sent: Monday, July 21, 2003 10:39 PM
To: Manish Kumar; [email-masked]
Subject: Re: [pim] IGMPv3 - PIM-Dm and SSM Issue?

Hi Manish,
  Yes you are right, in your case the packet will be droped at R3 itself. This is not only in the case of SSM joins grenerated from the PC, it will happen even PC sends IGMP (*,G) joins. Mulitcast packet will never reach from R3 to R1 according to your topology.
  If the receiver is on the other side of your topology (i.e PC connected to R3 and if the source is connected to R1) then there is possible of PC receiving the packets from the "source".
    
Thanx,
Jags 

Manish Kumar <[email-masked]> wrote:

Hi,

I would like to know how a IGMP-v3 receiver lying on a PIM-DM domain receives data packet from source lying in a PIM-SSM domain?

PC-----dm------R1 ----dm-----R2-----sm----R3-----sm---Source
(igmp-v3 join)

R2 is connected on one side with SM router and other side with Dm router.

R2 and R3 supports PIM-SSM, no RPs.

In PIM-DM, how can igmpv3 join be propagated towards the source?
How does interdomain multicast work with PIM-SSM and PIM-DM?

Am I missing something or above scenario is never possible?

Let me know.

Thanks in advance,
Manish

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

 Yahoo! India Mobile <http://in.yimg.com/i/in/mobile/pctomob.gif>  <http://in.mobile.yahoo.com/new/pc/> SMS using the Yahoo!  <http://in.mobile.yahoo.com/new/pc/> Messenger; Download <http://in.messenger.yahoo.com/>  latest version.

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Rajamanickam jaganbabu <[email-masked]>
Date: Wed, 23 Jul 2003 07:32:29 +0100 (BST)

Hi Manish,
   I think at present there is no mechanism to propogate Source specific joins to the Border router which just supports PIM DM on one interface and PIM-SSM on the other interface. 
   Actually your are talking about very small network, where you said you can do user intervention to push the packet to the other domain, but this is not a permenant solution, I think if we enhance DWR draft to support to propogate SSM specific informations to the border router, then it is possible to have the scenario which you have mentioned (this is just a  sugession, if iam wrong please correct me).
 
  Note:
    This should be done only for SSM group.

Thanx,
Jags

 

 
Thanks,
Manish

-----Original Message-----
From: Rajamanickam jaganbabu [mailto:[email-masked]]
Sent: Monday, July 21, 2003 10:39 PM
To: Manish Kumar; [email-masked]
Subject: Re: [pim] IGMPv3 - PIM-Dm and SSM Issue?

Hi Manish,
    
Thanx,
Jags 

Let me know.

Thanks in advance,
Manish

 SMS using the Yahoo! Messenger; Download latest version.
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

SMS using the Yahoo! Messenger;Download latest version.

---

From: "Marshall Eubanks" <[email-masked]>
Date: Wed, 23 Jul 2003 09:23:37 -0400

On Wed, 23 Jul 2003 07:32:29 +0100 (BST)
 Rajamanickam jaganbabu <[email-masked]> wrote:
> Hi Manish,
>    I think at present there is no mechanism to propogate Source specific
> joins to the Border router which just supports PIM DM on one interface and
> PIM-SSM on the other interface. 
>    Actually your are talking about very small network, where you said you can
> do user intervention to push the packet to the other domain, but this is not
> a permenant solution, I think if we enhance DWR draft to support to propogate
> SSM specific informations to the border router, then it is possible to have
> the scenario which you have mentioned (this is just a  sugession, if iam
> wrong please correct me).

I am confused here - all inter-domain joins at present are (S,G) and, of
course, the first hop router turns IGMP membership requests into PIM
joins. So if there is a border router between a PIM SM and a PIM DM domain,
why does it matter that the joins are SSM or not ? How does the BR even know
this ? Or is the trouble that
this is not really two domains ?

Regards
Marshall Eubanks

> The reason I asked about receiver generating igmp v3 (S,G) join is because of
> the fact that source is lying on the PIM-SSM domain. I was just trying to
> find out whether there is any mechanism by which S,G join is propagated to
> the border router.
>  
> If the other domain is PIM-SM, then it is possible to receive data as border
> router will send (*,*,Rp) join and pull the data from the source and then
> flood it into the Dm domain.
>  
> To me it looks like, it may be a valid case in deployment. As Maneesh said by
> configuring IGMP static join at R2 will make it work. But it needs user
> intervention.
>  
>   Yes you are right, in your case the packet will be droped at R3 itself.
> This is not only in the case of SSM joins grenerated from the PC, it will
> happen even PC sends IGMP (*,G) joins. Mulitcast packet will never reach from
> R3 to R1 according to your topology.
>   If the receiver is on the other side of your topology (i.e PC connected to
> R3 and if the source is connected to R1) then there is possible of PC
> receiving the packets from the "source".
>     
> Thanx,
> Jags 
> 
> I would like to know how a IGMP-v3 receiver lying on a PIM-DM domain receives
> data packet from source lying in a PIM-SSM domain?
>

---

From: "Prashant Jhingran" <[email-masked]>
Date: Wed, 23 Jul 2003 20:46:13 +0530

Well Quite true Marshall,
                        DM is a flood & prune oriented protocol whereas SM
is receiver oriented. Therefore the following doubt looks a bit confusing:-
"> In PIM-DM, how can igmpv3 join be propagated towards the source?"
In DM, I think we always prune the source (in case if we don't want the
traffic)coz once source comes up, it automatically starts flooding the
network.

Regarding the BR behavior actually speaking the multicast Interop RFC lacks
in clarifying some issues & I think they have been discussed at length on
the mailing list and they really require clarifications.
Once clarified, we won't have such doubts.

regards,
Prashant

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Marshall Eubanks
Sent: Wednesday, July 23, 2003 6:54 PM
To: Rajamanickam jaganbabu; Manish Kumar; [email-masked]
Subject: Re: [pim] IGMPv3 - PIM-Dm and SSM Issue?

Regards
Marshall Eubanks

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Rajamanickam jaganbabu <[email-masked]>
Date: Thu, 24 Jul 2003 06:59:19 +0100 (BST)

Hi Marshall,
  I think you are little bit confused about the topology. If BR has PIM-DM and a pure PIM-SSM interfaces, then as per the topology Manish has refered, it is clearly seen that there is no way to forward the packet from PIM-SSM  to DM domain (without user intervension), here since the IGMP recevier is one hop ahead from the DR, he can't hear IGMP V3 (S,G) joins directly as PIM-DM does not send joins whenever the IGMP group membership reports are received, so somebody has to inform the border router about his source specific joins to the border router else there won't be any entry in the BR for the (S,G) route, so the one way is through DWR, that is why is suggested to have source specific report towards the DR (which is not supported in the present DWR and 2715RFC).
   I hope this would clarrify you.
Thanx,
Jags

Marshall Eubanks <[email-masked]> wrote:
On Wed, 23 Jul 2003 07:32:29 +0100 (BST)

Regards
Marshall Eubanks

> Manish Kumar wrote:
> Manish Kumar wrote:

---

From: Rajamanickam jaganbabu <[email-masked]>
Date: Thu, 24 Jul 2003 08:23:34 +0100 (BST)

Hi,
   Please ignore my previous mail, it has Typo mistakes. The actual mail content is found below
 
   I think you are little bit confused about the topology. If BR has PIM-DM and a pure PIM-SSM interfaces, then as per the topology Manish has refered, it is clearly seen that there is no way to forward the packet from PIM-SSM  to DM domain (without user intervension), here since the IGMP recevier is one hop ahead from the BR, he can't hear IGMP V3 (S,G) joins directly as PIM-DM does not send joins whenever the IGMP group membership reports are received, so somebody has to inform the border router about his source specific joins to the border router else there won't be any entry in the BR for the (S,G) route, so the one way is through DWR, that is why is suggested to have source specific report towards the BR (which is not supported in the present DWR and 2715RFC).   I hope this would clarrify you.
Thanx,
Jags

Rajamanickam jaganbabu <[email-masked]> wrote:Hi Marshall,
  I think you are little bit confused about the topology. If BR has PIM-DM and a pure PIM-SSM interfaces, then as per the topology Manish has refered, it is clearly seen that there is no way to forward the packet from PIM-SSM  to DM domain (without user intervension), here since the IGMP recevier is one hop ahead from the DR, he can't hear IGMP V3 (S,G) joins directly as PIM-DM does not send joins whenever the IGMP group membership reports are received, so somebody has to inform the border router about his source specific joins to the border router else there won't be any entry in the BR for the (S,G) route, so the one way is through DWR, that is why is suggested to have source specific report towards the DR (which is not supported in the present DWR and 2715RFC).
   I hope this would clarrify you.
Thanx,
Jags

course, the first hop router tu! rns IGMP membership requests into PIM

Regards
Marshall Eubanks

> R3 to R1 ! according to your topology.
> Le! t me know.

 SMS using the Yahoo! Messenger; Download latest version._______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: "Marshall Eubanks" <[email-masked]>
Date: Thu, 24 Jul 2003 12:18:03 -0400

On Thu, 24 Jul 2003 06:59:19 +0100 (BST)
> Hi Marshall,

OK, I see the problem now, and I see no solution in the various RFC's.

One possible solution would be to treat the Dense Mode network (which
could be DVMRP also) as a "stub network" ( as in 
http://www.cisco.com/warp/public/105/48.html#stub )
for SSM - then SSM (S,G) joins would be passed upstream to the border
router which would act as an IGMP proxy and then could join and flood the
resulting SSM data into the dense mode cloud.

Sounds like some drafts need to be updated.

Regards
Marshall Eubanks

>   I think you are little bit confused about the topology. If BR has PIM-DM
> and a pure PIM-SSM interfaces, then as per the topology Manish has refered,
> it is clearly seen that there is no way to forward the packet from PIM-SSM
> to DM domain (without user intervension), here since the IGMP recevier is one
> hop ahead from the DR, he can't hear IGMP V3 (S,G) joins directly as PIM-DM
> does not send joins whenever the IGMP group membership reports are received,
> so somebody has to inform the border router about his source specific joins
> to the border router else there won't be any entry in the BR for the (S,G)
> route, so the one way is through DWR, that is why is suggested to have source
> specific report towards the DR (which is not supported in the present DWR and
> 2715RFC).