Subject: [pim] Question on Join Request

From: vikram pim <[email-masked]>
Date: Thu, 27 Oct 2005 15:11:02 -0700 (PDT)

Hi Gurus,
 
I have a question and have illustrated below:
 
(Assumption R5 and R6 have reachability to RP for (*,G)
 
Diag1
                  RP (*,G)
 
             R5            R6
              |             |
              |             |
             R2*          R1
              |1            | 1
              |              |
             --------------------
                   |
                   |
                   H1
* Indicate R1 is still the DR
 
In Diag 1, Host H1 is receiver on a multicast group (G) for which the R2 is chosen to be the DR by virtue of its IP (the cost being 1 each). Now it assumes the responsibility of ferrying the Join for (*,G) and (S,G) to the RP/Source respectively and maintaining the health with R5.
 
In Diag2 below, However if R5 goes down and R6 is now the router used to reach RP/Source for (*,G) and (S,G).
R2 would use R1 to reach R6 for joins and the path is pretty sub-optimal. Is there a way for R1 to somehow detect this and take over the DR ship because implicitly it is behaving as a DR. 

Diag 2             
                  RP (*,G)
 
             R5 X           R6
              |             |
              |             |
             R2 *           R1
              | 1          | 1
              |             |
             --------------------
                   |
                   |
                   H1
 
Cheers,
vikram

---------------------------------
 Yahoo! FareChase - Search multiple travel sites in one click.  

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Christopher Thomas Brown <[email-masked]>
Date: Thu, 27 Oct 2005 19:12:53 -0400

On Thu, 2005-10-27 at 15:11 -0700, vikram pim wrote:
> R2 would use R1 to reach R6 for joins and the path is pretty
> sub-optimal. Is there a way for R1 to somehow detect this and take
> over the DR ship because implicitly it is behaving as a DR. 

No, nothing in the protocol provides for detecting this.

Chris

> Diag 2             
>                   RP (*,G)
>  
>              R5 X           R6
>               |             |
>               |             |
>              R2 *           R1
>               | 1          | 1
>               |             |
>            &n! bsp; --------------------
>                    |
>                    |
>                    H1
>  
> Cheers,
> vikram
> 
> ______________________________________________________________________

---

From: vikram pim <[email-masked]>
Date: Thu, 27 Oct 2005 18:45:47 -0700 (PDT)

Hi Chris,
 
I was wondering if it is possible for the R2 and R1 to decipher that R1 should be taking over as the DR for the RP in this particular PIM domain? or atleast R2 knowing about it?
 
Thanx
vikram

Christopher Thomas Brown <[email-masked]> wrote:

Chris