Subject: RE: [pim] MCAST tools

From: "Field, Brian" <[email-masked]>
Date: Tue, 25 Oct 2005 17:33:48 -0600

Another option:

http://www.videolan.org/vlc/

Brian 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Marshall Eubanks
Sent: Tuesday, October 25, 2005 5:27 PM
To: Steven Giammarino
Cc: [email-masked]
Subject: Re: [pim] MCAST tools

ping can do this. Just ping the  group address. You can use rtpdump to
join the group at the other end (just join using any  port use tcpdump
to look for the packets). This won't generally work interdomain.

You can also use rtpdump and  rtptran to record and loop a little video
or audio sequence.  Most streaming servers, such as the  Darwin
Streaming Server, support multicast sourcing.

However, the best solution is to set up 2 (or more)  multicast beacons,
which will tell you useful things about the multicast transmission :

http://dast.nlanr.net/Projects/Beacon/

BTW. these sorts of questions belong on either  (for I2 members) the
I2 Multicast WG list or the IP Multicast list

http://www.multicasttech.com/faq/mail_list.html

Regards
Marshall Eubanks

On 10/25/05, Steven Giammarino <[email-masked]> wrote:
> ?
> Hello- I was wondering if anyone knows of a free tool that can send a 
> mcast stream to a reciever? I want to see if my newly configured
newtwork is passing multicast traffic Thanks!
>
>
> **********************************************************************
> The information in this Internet e-mail is confidential and may be
legally privileged.  No confidentiality or privilege is waived or lost
by any mistransmission.
> It is intended solely for the addressee.  Access to this Internet 
> e-mail by anyone else is unauthorized and any disclosure, copying, 
> distribution or any action taken or omitted to be taken in reliance on
it, is prohibited and may be unlawful.
>
> When addressed to our clients any opinions or advice contained in this

> Internet e-mail are subject to the terms and conditions expressed in 
> any applicable documentation or market practices governing the
relationship between the sender  and its clients.
> Any views expressed in this message are those of the individual sender

> except where they are stated to be the views of the company.
> **********************************************************************
>
>
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pim
>

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Pavlin Radoslavov <[email-masked]>
Date: Tue, 25 Oct 2005 21:42:17 -0700

For testing purpose MGEN is quite nice:

http://tang.itd.nrl.navy.mil/5522/mgen/mgen_index.html

Pavlin

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 26 Oct 2005 08:26:55 -0400

And there is the brand new multicast detective from UCSD

Web page is at:  http://www.nmsl.cs.ucsb.edu/mcast_detective/

and our humble multicast tester

http://www.multicasttech.com/

Regards
Marshall

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 26 Oct 2005 08:28:49 -0400

> http://www.multicasttech.com/

More specifically,

http://www.multicasttech.com/mt