Subject: RE: [pim] MCAST tools

From: "Ganapathasaa" <[email-masked]>
Date: Wed, 26 Oct 2005 18:03:38 +0530

I remember using "mping", ping extended for multicast.

Thanks,
Ganapath

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Marshall Eubanks
Sent: Wednesday, October 26, 2005 5:59 PM
To: Pavlin Radoslavov
Cc: [email-masked]; Steven Giammarino; Field, Brian
Subject: Re: [pim] MCAST tools

On 10/26/05, Marshall Eubanks <[email-masked]> wrote:
> And there is the brand new multicast detective from UCSD
>
> Web page is at:  http://www.nmsl.cs.ucsb.edu/mcast_detective/
>
> and our humble multicast tester
>
> http://www.multicasttech.com/

More specifically,

http://www.multicasttech.com/mt

>
> Regards
> Marshall
>
> On 10/26/05, Pavlin Radoslavov <[email-masked]> wrote:
> > For testing purpose MGEN is quite nice:
> >
> > http://tang.itd.nrl.navy.mil/5522/mgen/mgen_index.html
> >
> > Pavlin
> >
> > >
> > > Another option:
> > >
> > > http://www.videolan.org/vlc/
> > >
> > > Brian
> > >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> > > Marshall Eubanks
> > > Sent: Tuesday, October 25, 2005 5:27 PM
> > > To: Steven Giammarino
> > > Cc: [email-masked]
> > > Subject: Re: [pim] MCAST tools
> > >
> > > ping can do this. Just ping the  group address. You can use
rtpdump to
> > > join the group at the other end (just join using any  port use
tcpdump
> > > to look for the packets). This won't generally work interdomain.
> > >
> > > You can also use rtpdump and  rtptran to record and loop a little
video
> > > or audio sequence.  Most streaming servers, such as the  Darwin
> > > Streaming Server, support multicast sourcing.
> > >
> > > However, the best solution is to set up 2 (or more)  multicast
beacons,
> > > which will tell you useful things about the multicast transmission
:
> > >
> > > http://dast.nlanr.net/Projects/Beacon/
> > >
> > > BTW. these sorts of questions belong on either  (for I2 members)
the
> > > I2 Multicast WG list or the IP Multicast list
> > >
> > > http://www.multicasttech.com/faq/mail_list.html
> > >
> > > Regards
> > > Marshall Eubanks
> > >
> > >
> > > On 10/25/05, Steven Giammarino <[email-masked]>
wrote:
> > > > ?
> > > > Hello- I was wondering if anyone knows of a free tool that can
send a
> > > > mcast stream to a reciever? I want to see if my newly configured
> > > newtwork is passing multicast traffic Thanks!
> > > >
> > > >
> > > >
**********************************************************************
> > > > The information in this Internet e-mail is confidential and may
be
> > > legally privileged.  No confidentiality or privilege is waived or
lost
> > > by any mistransmission.
> > > > It is intended solely for the addressee.  Access to this
Internet
> > > > e-mail by anyone else is unauthorized and any disclosure,
copying,
> > > > distribution or any action taken or omitted to be taken in
reliance on
> > > it, is prohibited and may be unlawful.
> > > >
> > > > When addressed to our clients any opinions or advice contained
in this
> > >
> > > > Internet e-mail are subject to the terms and conditions
expressed in
> > > > any applicable documentation or market practices governing the
> > > relationship between the sender  and its clients.
> > > > Any views expressed in this message are those of the individual
sender
> > >
> > > > except where they are stated to be the views of the company.
> > > >
**********************************************************************
> > > >
> > > >
> > > > _______________________________________________
> > > > pim mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/pim
> > > >
> > >
> > > _______________________________________________
> > > pim mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/pim
> > >
> > > _______________________________________________
> > > pim mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/pim
> > >
> >
> >
>

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Stig Venaas <[email-masked]>
Date: Wed, 26 Oct 2005 14:45:27 +0200

> I remember using "mping", ping extended for multicast.

I suppose I should mention ssmping and asmping too then (:

They both work sort of like ping, with the client you ping an
ssmpingd server and get both unicast and multicast replies back.
It can tell you that multicast (ssm or asm) is working, and also
how many hops from source, rtt etc.

You can run your own clients and server to test, or you can try
to ping some public servers (or whatever servers you might know
of) to check that you can receive from the outside world.

More info at http://www.venaas.no/multicast/ssmping/

Stig

---

From: "Steven Giammarino" <[email-masked]>
Date: Wed, 26 Oct 2005 09:31:57 -0400

?
Thank you for everyoneâEUR(tm)s comments!! 

Steven G
Icap America

________________________________

From: Stig Venaas [mailto:[email-masked]]
Sent: Wed 10/26/2005 8:45 AM
To: Ganapathasaa
Cc: Marshall Eubanks; Pavlin Radoslavov; Field, Brian; Steven Giammarino; [email-masked]
Subject: Re: [pim] MCAST tools

Stig

**********************************************************************
The information in this Internet e-mail is confidential and may be legally privileged.  No confidentiality or privilege is waived or lost by any mistransmission.
It is intended solely for the addressee.  Access to this Internet e-mail by anyone else 
is unauthorized and any disclosure, copying, distribution or any action taken or omitted
to be taken in reliance on it, is prohibited and may be unlawful.

When addressed to our clients any opinions or advice contained in this Internet e-mail are
subject to the terms and conditions expressed in any applicable documentation or market 
practices governing the relationship between the sender  and its clients.
Any views expressed in this message are those of the individual sender except where they 
are stated to be the views of the company.
**********************************************************************