Subject: [pim] RE: some doubts about draft-ietf-pim-mib-v2-09 and draft-ietf-pim-bsr-mib-01

From: "David McWalter" <[email-masked]>
Date: Mon, 5 Mar 2007 14:34:35 -0000

Greetings.
 
The PIM WG owns these drafts, so I think these questions belong on the list [email-masked].
 
1.  I don't think it's usual to add router instance information to protocol MIBs.  I'm no VPN expert, so you might like to check this draft for some suggestions.
http://www.ietf.org/internet-drafts/draft-ietf-l3vpn-vr-mib-04.txt
 
2. Yes, this is inconsistent.  I believe a different E-BSR can be selected per address type as well as per-zone, so not-accessible seems correct.  I think the fix is to add AddressType to the index of pimBsrElectedBSRTable.  Right, Bharat?
 
Regards,
David McWalter.
 
 -----Original Message-----
From: LuanHaiYan [mailto:[email-masked]]
Sent: 05 March 2007 13:40
To: [email-masked]
Cc: [email-masked]; David McWalter
Subject: some doubts about draft-ietf-pim-mib-v2-09 and draft-ietf-pim-bsr-mib-01

hi,
   I have some doubts abouts draft-ietf-pim-bsr-mib-01 and`draft-ietf-pim-mib-v2-09.txt.
I will appreciate it if anybody could anwser it.
   
   1.  For PIM (*,G) State Table/PIM (S,G) State Table/PIM (S,G,RPT) State Table in draft-ietf-pim-mib-v2-09, instances information is not considered, if routers can support mvpn, maybe  there are same (*,G)/(S,G). how to support them?
  
   2. In Page13 of draft-ietf-pim-bsr-mib-01, BSR Elected-BSR Table is defined as follows:
     `
   -- The BSR Elected-BSR Table
   --
 
   pimBsrElectedBSRTable OBJECT-TYPE
       SYNTAX     SEQUENCE OF PimBsrElectedBSREntry
       MAX-ACCESS not-accessible
       STATUS     current
       DESCRIPTION
               "The (conceptual) table containing information about
               elected BSRs.  The table contains one row for each
               zone for which there is an elected BSR."
       ::= { pimBsrObjects 4 }
 
   pimBsrElectedBSREntry OBJECT-TYPE
       SYNTAX     PimBsrElectedBSREntry
       MAX-ACCESS not-accessible
       STATUS     current
       DESCRIPTION
               "An entry (conceptual row) in the
                pimBsrElectedBSRTable."
       INDEX      { pimBsrElectedBSRZoneIndex }
       ::= { pimBsrElectedBSRTable 1 }
 
   PimBsrElectedBSREntry ::= SEQUENCE {
       pimBsrElectedBSRZoneIndex        InetZoneIndex,
       pimBsrElectedBSRAddressType      InetAddressType,
       pimBsrElectedBSRAddress          InetAddress,
       pimBsrElectedBSRPriority         Unsigned32,
       pimBsrElectedBSRHashMaskLength   Unsigned32,
       pimBsrElectedBSRExpiryTime       TimeTicks
   }
 
   pimBsrElectedBSRZoneIndex OBJECT-TYPE
       SYNTAX     InetZoneIndex
       MAX-ACCESS not-accessible
       STATUS     current
       DESCRIPTION
               "The zone index uniquely identifies the zone on a
               device to which this Elected BSR is attached. There
               is one entry for each zone in ipMcastZoneTable.
               Scope-level information for this zone can be extracted
               from ipMcastZoneTable in IP MCAST MIB."
       ::= { pimBsrElectedBSREntry 1 }
 
   pimBsrElectedBSRAddressType OBJECT-TYPE
       SYNTAX     InetAddressType
       MAX-ACCESS not-accessible
       STATUS     current
       DESCRIPTION
               "The address type of the elected BSR."
       ::= { pimBsrElectedBSREntry 2 }

pimBsrElectedBSRZoneIndex is the index of elected bsr table, 
why  is pimBsrElectedBSRAddressType defined as not-accessible?
or maybe should it be read-only?

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "bharat_joshi" <[email-masked]>
Date: Mon, 5 Mar 2007 21:00:48 +0530

Hi,

       AFAIK, there is an E-BSR elected for each scope zone. Inet
Address Type is not involved here.

       But as you rightly pointed out, this object should have read-only
permission. Thanks for pointing this out. I shall fix this in next
revision.

Thanks & Regards,

Bharat

________________________________

From: David McWalter [mailto:[email-masked]]
Sent: Monday, March 05, 2007 8:05 PM
To: LuanHaiYan; [email-masked]
Cc: [email-masked]; bharat_joshi
Subject: RE: some doubts about draft-ietf-pim-mib-v2-09 and
draft-ietf-pim-bsr-mib-01

Greetings.

The PIM WG owns these drafts, so I think these questions belong on the
list [email-masked].

1.  I don't think it's usual to add router instance information to
protocol MIBs.  I'm no VPN expert, so you might like to check this draft
for some suggestions.

2. Yes, this is inconsistent.  I believe a different E-BSR can be
selected per address type as well as per-zone, so not-accessible seems
correct.  I think the fix is to add AddressType to the index of
pimBsrElectedBSRTable.  Right, Bharat?

Regards,

David McWalter.

 -----Original Message-----
From: LuanHaiYan [mailto:[email-masked]]
Sent: 05 March 2007 13:40
To: [email-masked]
Cc: [email-masked]; David McWalter
Subject: some doubts about draft-ietf-pim-mib-v2-09 and
draft-ietf-pim-bsr-mib-01

hi,

   I have some doubts abouts draft-ietf-pim-bsr-mib-01
and`draft-ietf-pim-mib-v2-09.txt.

   1.  For PIM (*,G) State Table/PIM (S,G) State Table/PIM (S,G,RPT)
State Table in draft-ietf-pim-mib-v2-09, instances information is not
considered, if routers can support mvpn, maybe  there are same
(*,G)/(S,G). how to support them?

   2. In Page13 of draft-ietf-pim-bsr-mib-01, BSR Elected-BSR Table is
defined as follows:

     `

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message. Further, you are not to copy, disclose, or distribute this e-mail or its contents to any other person and any such actions are unlawful. This e-mail may contain viruses. Infosys has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Infosys reserves the right to monitor and review the content of all messages sent to or from this e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***