Subject: [pim] Need clarification for rfc statement

From: "Arnab Bakshi" <[email-masked]>
Date: Tue, 4 Sep 2007 09:52:20 +0530

Hi All,

    I need a little clarification on what the following rfc statement means:

Draft: draft-ietf-pim-dm-new-v2-05
~~~~~~~~~~~~~~~~~~~~~~~~

4.4.1.2.  Transitions from the Pruned (P) State

  S becomes directly connected
    Unicast routing changed so that S is directly connected.  The
    Upstream(S,G) state machine remains in the Pruned (P) state.

    My doubt here is the scenario in which S becomes directly
connected. How can this happen without modifying the interface address
of the router? As per as my understanding, "directly connected" means
both entities are in same subnet.

Any inputs regarding the above would be grateful

Thanks and Regards
-- 
Arnab

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Nicholas, Jonathan - ACD " <[email-masked]>
Date: Tue, 4 Sep 2007 07:27:17 -0400

The statement is included to support a future mobility case, likely
involving IPv6, which does not require the same subnets on the same
physical media.

Jonathan Nicholas 

> -----Original Message-----
> From: Arnab Bakshi [mailto:[email-masked]] 
> Sent: Tuesday, September 04, 2007 12:22 AM
> To: [email-masked]
> Subject: [pim] Need clarification for rfc statement
> 
> Hi All,
> 
> connected. How can this happen without modifying the 
> interface address of the router? As per as my understanding, 
> "directly connected" means both entities are in same subnet.
> 
*****************************************************************
This e-mail and any files transmitted with it may be proprietary 
and are intended solely for the use of the individual or entity to 
whom they are addressed. If you have received this e-mail in 
error please notify the sender. Please note that any views or
opinions presented in this e-mail are solely those of the author 
and do not necessarily represent those of ITT Corporation. The 
recipient should check this e-mail and any attachments for the 
presence of viruses. ITT accepts no liability for any damage 
caused by any virus transmitted by this e-mail.
*******************************************************************

---

From: "Arnab Bakshi" <[email-masked]>
Date: Tue, 4 Sep 2007 17:58:54 +0530

Thanks Nicholas !
  It seems this statement is not valid for current addressing schemes-
IPv4 and IPv6.

Arnab

-- 
Arnab Bakshi
Software Engineer
IXIA Technologies.
8th & 9th Floor, Infinity Tower - 2
Saltlake Sector-V
Kolkata-91
Ph: +91 33 23391304 /
      +91 33 23572466/67/68
Mobile: +919830660593

---

From: Suresh Boddapati <[email-masked]>
Date: Tue, 4 Sep 2007 05:41:25 -0700 (PDT)

Not quite. Here is an example:

1) The source is directly connected but the interface
connecting to the source is down.
2) The source is reachable through another interface,
as learnt by IGP.
3) The interface connected to the source comes back
up. Now the source *becomes* directly connected, since
typically the unicast routing will prefer a direct
route over an IGP learnt route.

We didnt have to modify the address of the interface
in this example.

Suresh

--- Arnab Bakshi <[email-masked]> wrote:

> > >     I need a little clarification on what the
> following rfc
> > > statement means:
> > >